summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-04 15:25:34 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-04 15:25:34 +0000
commiteb3a50903957178535536a5f9d928e86ff79ed51 (patch)
treec1bc979b2d0b9e3430d311058196f17ad71ebb4c /dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
parentAdded ~sparc keyword. (diff)
downloadhistorical-eb3a50903957178535536a5f9d928e86ff79ed51.tar.gz
historical-eb3a50903957178535536a5f9d928e86ff79ed51.tar.bz2
historical-eb3a50903957178535536a5f9d928e86ff79ed51.zip
python 2.3 support blah blah sandbox issue
Diffstat (limited to 'dev-python/pygtkglext/pygtkglext-1.0.0.ebuild')
-rw-r--r--dev-python/pygtkglext/pygtkglext-1.0.0.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild b/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
index 351f1597e88a..af4d201743ea 100644
--- a/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
+++ b/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild,v 1.2 2003/12/06 13:43:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild,v 1.3 2004/01/04 15:25:34 liquidx Exp $
+
+inherit python
DESCRIPTION="Python bindings to GtkGLExt"
HOMEPAGE="http://gtkglext.sourceforge.net/"
@@ -10,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND=">=dev-lang/python-2.2
+DEPEND=">=dev-lang/python-2.2.3-r3
>=dev-python/pygtk-2
>=dev-libs/glib-2.0
>=x11-libs/gtk+-2.0
@@ -21,9 +23,6 @@ DEPEND=">=dev-lang/python-2.2
virtual/glu"
src_compile() {
- # ugly hack for sandbox (opens file readwrite, but only really reads)
- addwrite /usr/share/pygtk/2.0/codegen
-
econf
emake || die
}
@@ -34,3 +33,12 @@ src_install() {
insinto /usr/share/doc/${PF}/examples
doins examples/*.py
}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}