summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-10-24 22:02:22 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-10-24 22:02:22 +0000
commit062d2468cb88336d5c8541f50c0d1e938a86e5a8 (patch)
tree7f967c83f02eac3688644b9a236f2d6335ed998d /dev-python/pmw
parentAdded wmf use flag (diff)
downloadhistorical-062d2468cb88336d5c8541f50c0d1e938a86e5a8.tar.gz
historical-062d2468cb88336d5c8541f50c0d1e938a86e5a8.tar.bz2
historical-062d2468cb88336d5c8541f50c0d1e938a86e5a8.zip
Updated to 1.1
Diffstat (limited to 'dev-python/pmw')
-rw-r--r--dev-python/pmw/ChangeLog8
-rw-r--r--dev-python/pmw/files/digest-pmw-1.11
-rw-r--r--dev-python/pmw/pmw-1.1.ebuild55
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/pmw/ChangeLog b/dev-python/pmw/ChangeLog
index c4165bdc81cc..2f80cf343be1 100644
--- a/dev-python/pmw/ChangeLog
+++ b/dev-python/pmw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pmw
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.2 2002/07/30 00:50:10 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.3 2002/10/24 22:02:22 agenkin Exp $
+
+*pmw-1.1 (24 Oct, 2002)
+
+ 24 Oct 2002; Arcady Genkin <agenkin@gentoo.org> pmw-1.1.ebuild :
+
+ Updated to version 1.1
*pmw-0.8.5 (<Mar 19, 2002>)
diff --git a/dev-python/pmw/files/digest-pmw-1.1 b/dev-python/pmw/files/digest-pmw-1.1
new file mode 100644
index 000000000000..e9e333b6dc3c
--- /dev/null
+++ b/dev-python/pmw/files/digest-pmw-1.1
@@ -0,0 +1 @@
+MD5 f28603d1d3cc2b76faf884c4bb430a59 Pmw.1.1.tar.gz 393556
diff --git a/dev-python/pmw/pmw-1.1.ebuild b/dev-python/pmw/pmw-1.1.ebuild
new file mode 100644
index 000000000000..3cbbea73b08c
--- /dev/null
+++ b/dev-python/pmw/pmw-1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.1.ebuild,v 1.1 2002/10/24 22:02:22 agenkin Exp $
+
+DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
+HOMEPAGE="http://pmw.sourceforge.net/"
+
+DEPEND=">=dev-lang/python-2.1"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="MIT"
+
+
+SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
+S="${WORKDIR}"/Pmw
+
+src_compile() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ die "You need to recompile Python with Tkinter support"
+ fi
+ python -c 'import compileall; compileall.compile_dir(".",force=1)'
+}
+
+src_install () {
+ # Figures out the destination directory, based on Python's version
+ # installed.
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local pmwdir="/usr/lib/python${pv}/site-packages/Pmw"
+
+ local dir
+ for dir in `find . -type d`
+ do
+ # Skip the doc directory
+ if [ `basename "${dir}"` = "doc" ]
+ then
+ continue
+ fi
+ insinto "${pmwdir}/${dir}"
+ cd "${dir}"
+ # Install all regular files in this dir
+ local file
+ for file in *
+ do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ dodoc README
+ local docdir=`find . -type d -name doc`
+ dohtml -a html,gif,py "${docdir}"/*
+}