summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-27 17:31:09 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-27 17:31:09 +0000
commitb76698c1a59ca210751d969eac48cd641a42124f (patch)
tree12a82e28c80c807a3191e11d8c21af85ae6e4f8d /dev-python/kombu
parent[eclass] Add env file to add /usr/lib/mysql to LDPATH. Fixes bug 474952. (diff)
downloadhistorical-b76698c1a59ca210751d969eac48cd641a42124f.tar.gz
historical-b76698c1a59ca210751d969eac48cd641a42124f.tar.bz2
historical-b76698c1a59ca210751d969eac48cd641a42124f.zip
update dep, update test phase, patch partially fixing testsuite
Package-Manager: portage-2.1.11.63/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/ChangeLog6
-rw-r--r--dev-python/kombu/files/kombu-2.5.10-tests.patch36
-rw-r--r--dev-python/kombu/kombu-2.5.10.ebuild35
3 files changed, 54 insertions, 23 deletions
diff --git a/dev-python/kombu/ChangeLog b/dev-python/kombu/ChangeLog
index 5231eeace219..8ff98687910b 100644
--- a/dev-python/kombu/ChangeLog
+++ b/dev-python/kombu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/kombu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.24 2013/04/28 01:04:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.25 2013/06/27 17:31:09 idella4 Exp $
+
+ 27 Jun 2013; Ian Delaney <idella4@gentoo.org> +files/kombu-2.5.10-tests.patch,
+ kombu-2.5.10.ebuild:
+ update dep, update test phase, patch partially fixing testsuite
28 Apr 2013; Ian Delaney <idella4@gentoo.org> kombu-2.5.10.ebuild:
Add py3.3, drop py3.1 & pypy support, drop dep simplejson, tidied up dep list,
diff --git a/dev-python/kombu/files/kombu-2.5.10-tests.patch b/dev-python/kombu/files/kombu-2.5.10-tests.patch
new file mode 100644
index 000000000000..f5e72d0c4f54
--- /dev/null
+++ b/dev-python/kombu/files/kombu-2.5.10-tests.patch
@@ -0,0 +1,36 @@
+From 95dacce13e704e83d640e488ff50ccd16ca8411b Mon Sep 17 00:00:00 2001
+From: Ask Solem <ask@celeryproject.org>
+Date: Tue, 25 Jun 2013 14:22:49 +0100
+Subject: [PATCH] Fixes test suite failures when logging enabled. Closes #227
+
+diff -ur kombu-2.5.10.orig/kombu/tests/transport/test_pyamqp.py
+kombu-2.5.10/kombu/tests/transport/test_pyamqp.py
+--- kombu/tests/transport/test_pyamqp.py 2013-04-12 00:57:56.000000000 +0800
++++ kombu/tests/transport/test_pyamqp.py 2013-06-27 23:39:30.545684336 +0800
+@@ -3,8 +3,10 @@
+
+ import sys
+
++from functools import partial
+ from mock import patch
+ from nose import SkipTest
++from itertools import count
+
+ try:
+ import amqp # noqa
+@@ -13,6 +15,7 @@
+ else:
+ from kombu.transport import pyamqp
+ from kombu import Connection
++from kombu.utils.compat import next
+
+ from kombu.tests.utils import TestCase
+ from kombu.tests.utils import mask_modules, Mock
+@@ -43,6 +46,7 @@
+ pass
+
+ self.conn = Mock()
++ self.conn._get_free_channel_id.side_effect = partial(next, count(0))
+ self.conn.channels = {}
+ self.channel = Channel(self.conn, 0)
+
diff --git a/dev-python/kombu/kombu-2.5.10.ebuild b/dev-python/kombu/kombu-2.5.10.ebuild
index 2eb5f81676b7..81c5edb552b6 100644
--- a/dev-python/kombu/kombu-2.5.10.ebuild
+++ b/dev-python/kombu/kombu-2.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.5.10.ebuild,v 1.2 2013/04/28 01:04:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.5.10.ebuild,v 1.3 2013/06/27 17:31:09 idella4 Exp $
EAPI=5
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="amqplib doc examples test"
RDEPEND=">=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- >=dev-python/py-amqp-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/py-amqp-1.0.12[${PYTHON_USEDEP}]
amqplib? ( >=dev-python/amqplib-1.0.2[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( dev-python/nose-cover3[${PYTHON_USEDEP}]
@@ -33,39 +33,30 @@ DEPEND="${RDEPEND}
dev-python/beanstalkc[$(python_gen_usedep python2_7)]
dev-python/couchdb-python[$(python_gen_usedep python2_7)] )
dev-python/setuptools[${PYTHON_USEDEP}]"
-
DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
python_compile_all() {
if use doc; then
emake -C docs html || die "kombu docs failed installation"
fi
}
-# wip; https://github.com/celery/kombu/issues/227; at this point upstr. maintainer established these tests
-# 'can and do' pass, acks their failing 'on Travis' and offers neither a solution nor any plan to make 1.
+# https://github.com/celery/kombu/issues/227
python_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
if [[ "${EPYTHON}" == python3* ]]; then
- nosetests --py3where=build/lib -e test_basic_consume_registers_ack_status \
- -e test_close_resolves_connection_cycle -e test_init \
- -e test_message_to_python -e test_prepare_message \
- -e test_produce_consume -e test_produce_consume_noack kombu/tests \
- || die "Tests failed under ${EPYTHON}"
+ nosetests --py3where=build/lib \
+ -e test_produce_consume -e test_produce_consume_noack kombu/tests \
+ || die "Tests failed under ${EPYTHON}"
else
- nosetests -e test_basic_consume_registers_ack_status -e test_close_resolves_connection_cycle \
- -e test_init -e test_message_to_python -e test_prepare_message \
- || die "Tests failed under ${EPYTHON}"
+ nosetests || die "Tests failed under ${EPYTHON}"
fi
}
-
+
python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/.build/html/. )
distutils-r1_python_install_all
-
- if use examples; then
- docompress -x usr/share/doc/${P}/examples/
- insinto usr/share/doc/${PF}/
- doins -r examples/
- fi
-
- use doc && dohtml -r docs/.build/html/
}