summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
commit1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae (patch)
treee5858b1bc23fa91ef29bbd90813bf2a028bdb3f9 /dev-python/gtkspell-python
parentsparc stable (bug 351487) (diff)
downloadhistorical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.tar.gz
historical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.tar.bz2
historical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.zip
Add missing eclass variables for proper python-updater behavior, bug #344833. Clean up old revision.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gtkspell-python')
-rw-r--r--dev-python/gtkspell-python/ChangeLog7
-rw-r--r--dev-python/gtkspell-python/gtkspell-python-2.19.1.ebuild32
-rw-r--r--dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild5
3 files changed, 10 insertions, 34 deletions
diff --git a/dev-python/gtkspell-python/ChangeLog b/dev-python/gtkspell-python/ChangeLog
index 5dd8ea7b75b4..65525566ff5e 100644
--- a/dev-python/gtkspell-python/ChangeLog
+++ b/dev-python/gtkspell-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gtkspell-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/ChangeLog,v 1.18 2011/01/30 18:14:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/ChangeLog,v 1.19 2011/02/26 13:22:16 eva Exp $
+
+ 26 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ -gtkspell-python-2.19.1.ebuild, gtkspell-python-2.25.3.ebuild:
+ Add missing eclass variables for proper python-updater behavior, bug #344833.
+ Clean up old revision.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> gtkspell-python-2.25.3.ebuild:
alpha/ia64/sparc stable wrt #348987
diff --git a/dev-python/gtkspell-python/gtkspell-python-2.19.1.ebuild b/dev-python/gtkspell-python/gtkspell-python-2.19.1.ebuild
deleted file mode 100644
index 270e91ccb27b..000000000000
--- a/dev-python/gtkspell-python/gtkspell-python-2.19.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/gtkspell-python-2.19.1.ebuild,v 1.11 2010/07/11 15:13:31 pacho Exp $
-
-EAPI="2"
-G_PY_PN="gnome-python-extras"
-
-inherit gnome-python-common
-
-PVP="$(get_version_component_range 1-2)"
-SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
- mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
-
-DESCRIPTION="GtkSpell bindings for Python"
-# The LICENSE with gtkspell-3 is LGPL and there is no way to express this in
-# an ebuild, currently. Punt till we actually have to face the issue.
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc examples"
-
-RDEPEND="=app-text/gtkspell-2*"
-DEPEND="${RDEPEND}"
-
-EXAMPLES="examples/gtkspell/*"
-
-src_prepare() {
- epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
- eautoreconf
-
- gnome-python-common_src_prepare
-}
diff --git a/dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild b/dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild
index 0074b49a7ee6..d53fb3306e1f 100644
--- a/dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild
+++ b/dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild,v 1.7 2011/01/30 18:14:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/gtkspell-python-2.25.3.ebuild,v 1.8 2011/02/26 13:22:16 eva Exp $
EAPI="2"
G_PY_PN="gnome-python-extras"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
inherit gnome-python-common