summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2005-07-02 18:13:00 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2005-07-02 18:13:00 +0000
commitc9edc35bd336c8eefce18cfb19df2780f3c5b2e5 (patch)
tree6f721c9bf676a5c45881783e322904f4fbc69a03 /dev-python/gnome-python-extras
parentadd firefox local use flag for soon to be committed gnome-python-extras. (diff)
downloadhistorical-c9edc35bd336c8eefce18cfb19df2780f3c5b2e5.tar.gz
historical-c9edc35bd336c8eefce18cfb19df2780f3c5b2e5.tar.bz2
historical-c9edc35bd336c8eefce18cfb19df2780f3c5b2e5.zip
Initial commit. Fixes #93504
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-python/gnome-python-extras')
-rw-r--r--dev-python/gnome-python-extras/ChangeLog10
-rw-r--r--dev-python/gnome-python-extras/Manifest4
-rw-r--r--dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.10.21
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.10.2.ebuild71
-rw-r--r--dev-python/gnome-python-extras/metadata.xml10
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
new file mode 100644
index 000000000000..550bf2306ec6
--- /dev/null
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/gnome-python-extras
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.1 2005/07/02 18:13:00 allanonjl Exp $
+
+*gnome-python-extras-2.10.2 (02 Jul 2005)
+
+ 02 Jul 2005; John N. Laliberte <allanonjl@gentoo.org> +metadata.xml,
+ +gnome-python-extras-2.10.2.ebuild:
+ Initial commit. Fixes #93504
+
diff --git a/dev-python/gnome-python-extras/Manifest b/dev-python/gnome-python-extras/Manifest
new file mode 100644
index 000000000000..7cadd27fa9ac
--- /dev/null
+++ b/dev-python/gnome-python-extras/Manifest
@@ -0,0 +1,4 @@
+MD5 16454e227ff39ede5c15bb73490fba0d gnome-python-extras-2.10.2.ebuild 1628
+MD5 a14ed04e38bc6413e8a57ebd12e5b520 ChangeLog 421
+MD5 7815efa8e3c1eece4b748785c644df85 metadata.xml 243
+MD5 dee99b75f4b766a4a588ddb6b8a086c0 files/digest-gnome-python-extras-2.10.2 79
diff --git a/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.10.2 b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.10.2
new file mode 100644
index 000000000000..ae57c40b3423
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.10.2
@@ -0,0 +1 @@
+MD5 0b7a276032646582e6e266beaef7a090 gnome-python-extras-2.10.2.tar.bz2 351085
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.10.2.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.10.2.ebuild
new file mode 100644
index 000000000000..af9748c3457c
--- /dev/null
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.10.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.10.2.ebuild,v 1.1 2005/07/02 18:13:00 allanonjl Exp $
+
+inherit eutils gnome2 python
+
+DESCRIPTION="GNOME 2 Bindings for Python"
+HOMEPAGE="http://www.pygtk.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc firefox mozilla"
+
+RDEPEND=">=dev-lang/python-2.3
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/glib-2.6.0
+ >=dev-python/gnome-python-2.10.0
+ >=dev-python/pygtk-2.4.0
+ >=libgtkhtml-2.3.1
+ >=libgnomeprint-2.2.0
+ >=libgnomeprintui-2.2.0
+ >=x11-libs/gtksourceview-1.1.90
+ >=gnome-base/gnome-panel-2.2.0
+ >=x11-libs/libwnck-2.9.92
+ firefox? ( >=www-client/mozilla-firefox-1.0)
+ mozilla? ( >=www-client/mozilla-1.2 )
+ >=gnome-base/libgtop-2.9.5
+ >=gnome-extra/nautilus-cd-burner-2.9.4
+ >=app-text/gtkspell-2.0.0
+ media-video/totem
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ "
+
+G2CONF=""
+USE_DESTDIR="1"
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+src_compile() {
+
+ # only controls linking, can't disable w/o a patch :)
+ use firefox && G2CONF="${G2CONF} --with-gtkmozembed=firefox"
+ use mozilla && G2CONF="${G2CONF} --with-gtkmozembed=mozilla"
+
+ gnome2_src_configure ${G2CONF}
+
+ emake || make || die "make failed!"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
diff --git a/dev-python/gnome-python-extras/metadata.xml b/dev-python/gnome-python-extras/metadata.xml
new file mode 100644
index 000000000000..aaabf1a4f5d0
--- /dev/null
+++ b/dev-python/gnome-python-extras/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<herd>python</herd>
+<maintainer>
+ <email>allanonjl@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+