summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-06 17:33:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-06 17:33:12 +0000
commitd866fbeed0f1fd89c8b0362bf0162c699ee9cbc5 (patch)
treec5f41989e06642dd2544e010783642727ce97208 /dev-python/gmpy
parentVersion Bump, #347561; Fix for libXft recognition, #347569 (diff)
downloadhistorical-d866fbeed0f1fd89c8b0362bf0162c699ee9cbc5.tar.gz
historical-d866fbeed0f1fd89c8b0362bf0162c699ee9cbc5.tar.bz2
historical-d866fbeed0f1fd89c8b0362bf0162c699ee9cbc5.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/gmpy')
-rw-r--r--dev-python/gmpy/files/gmpy-1.11-tests.patch32
-rw-r--r--dev-python/gmpy/gmpy-1.11.ebuild49
-rw-r--r--dev-python/gmpy/gmpy-1.12.ebuild44
3 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/gmpy/files/gmpy-1.11-tests.patch b/dev-python/gmpy/files/gmpy-1.11-tests.patch
deleted file mode 100644
index c8c69ae2c006..000000000000
--- a/dev-python/gmpy/files/gmpy-1.11-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-http://code.google.com/p/gmpy/source/detail?r=251
-
---- test3/gmpy_test_mpf.py
-+++ test3/gmpy_test_mpf.py
-@@ -419,6 +419,7 @@
-
- sav = sys.stdout
- class _Dummy:
-+ encoding = None
- def write(self,*whatever):
- pass
- try:
---- test3/gmpy_test_mpq.py
-+++ test3/gmpy_test_mpq.py
-@@ -359,6 +359,7 @@
-
- sav = sys.stdout
- class _Dummy:
-+ encoding = None
- def write(self,*whatever):
- pass
- try:
---- test3/gmpy_test_mpz.py
-+++ test3/gmpy_test_mpz.py
-@@ -967,6 +967,7 @@
-
- sav = sys.stdout
- class _Dummy:
-+ encoding = None
- def write(self,*whatever):
- pass
- try:
diff --git a/dev-python/gmpy/gmpy-1.11.ebuild b/dev-python/gmpy/gmpy-1.11.ebuild
deleted file mode 100644
index 4ce94cb8252e..000000000000
--- a/dev-python/gmpy/gmpy-1.11.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gmpy/gmpy-1.11.ebuild,v 1.5 2010/07/17 22:46:31 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="Python bindings for dev-libs/gmp"
-HOMEPAGE="http://www.aleax.it/gmpy.html http://code.google.com/p/gmpy/ http://pypi.python.org/pypi/gmpy"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86"
-IUSE=""
-
-RDEPEND="dev-libs/gmp"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DISTUTILS_SETUP_FILES=("setup.py" "setes.py")
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-tests.patch"
-}
-
-src_test() {
- testing() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- pushd test3 > /dev/null
- else
- pushd test > /dev/null
- fi
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" gmpy_test.py || return 1
- popd > /dev/null
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- dohtml doc/index.html
- dodoc doc/gmpydoc.txt
-}
diff --git a/dev-python/gmpy/gmpy-1.12.ebuild b/dev-python/gmpy/gmpy-1.12.ebuild
deleted file mode 100644
index 59d53ccde808..000000000000
--- a/dev-python/gmpy/gmpy-1.12.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gmpy/gmpy-1.12.ebuild,v 1.3 2010/09/21 20:29:14 hwoarang Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Python bindings for GMP library"
-HOMEPAGE="http://www.aleax.it/gmpy.html http://code.google.com/p/gmpy/ http://pypi.python.org/pypi/gmpy"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86"
-IUSE=""
-
-RDEPEND="dev-libs/gmp"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DISTUTILS_SETUP_FILES=("setup.py" "setes.py")
-
-src_test() {
- testing() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- pushd test3 > /dev/null
- else
- pushd test > /dev/null
- fi
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" gmpy_test.py || return 1
- popd > /dev/null
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- dohtml doc/index.html
- dodoc doc/gmpydoc.txt
-}