summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 10:33:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 10:33:22 +0000
commit6b43e3ba6bf280120dc98a0492b4d441a89259f3 (patch)
tree4be340880663ee2198a3ed86707ebf68b8c5db24 /dev-python/envisageplugins
parentVersion bump, remove old, arm/ia64/sparc/x86 stable (diff)
downloadhistorical-6b43e3ba6bf280120dc98a0492b4d441a89259f3.tar.gz
historical-6b43e3ba6bf280120dc98a0492b4d441a89259f3.tar.bz2
historical-6b43e3ba6bf280120dc98a0492b4d441a89259f3.zip
Initial import
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'dev-python/envisageplugins')
-rw-r--r--dev-python/envisageplugins/ChangeLog10
-rw-r--r--dev-python/envisageplugins/envisageplugins-3.0.1.ebuild48
-rw-r--r--dev-python/envisageplugins/metadata.xml25
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/envisageplugins/ChangeLog b/dev-python/envisageplugins/ChangeLog
new file mode 100644
index 000000000000..cf83e5ddbcd8
--- /dev/null
+++ b/dev-python/envisageplugins/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/envisageplugins
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/ChangeLog,v 1.1 2009/01/15 10:20:14 bicatali Exp $
+
+*envisageplugins-3.0.1 (15 Jan 2009)
+
+ 15 Jan 2009; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +envisageplugins-3.0.1.ebuild:
+ Initial import
+
diff --git a/dev-python/envisageplugins/envisageplugins-3.0.1.ebuild b/dev-python/envisageplugins/envisageplugins-3.0.1.ebuild
new file mode 100644
index 000000000000..baba460ca25e
--- /dev/null
+++ b/dev-python/envisageplugins/envisageplugins-3.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/envisageplugins-3.0.1.ebuild,v 1.1 2009/01/15 10:20:14 bicatali Exp $
+
+EAPI=2
+inherit distutils
+
+MY_PN="EnvisagePlugins"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Plugins for the Envisage framework"
+HOMEPAGE="http://code.enthought.com/projects/envisage_plugins.php"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+IUSE="examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="dev-python/apptools
+ dev-python/envisagecore
+ dev-python/traitsgui"
+
+DEPEND="dev-python/setuptools
+ test? ( >=dev-python/nose-0.10.3
+ dev-python/apptools
+ dev-python/enthoughtbase )"
+
+# tests need an X display
+RESTRICT=test
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ sed -i -e "/self.run_command('build_docs')/d" setup.py || die
+}
+
+src_test() {
+ PYTHONPATH=build/lib ${python} setup.py test || die "tests failed"
+}
+
+src_install() {
+ find "${S}" -name \*LICENSE.txt -delete
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}
diff --git a/dev-python/envisageplugins/metadata.xml b/dev-python/envisageplugins/metadata.xml
new file mode 100644
index 000000000000..e9b3d5be45d5
--- /dev/null
+++ b/dev-python/envisageplugins/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The EnvisagePlugins project from the Enthought Tool Suite
+ includes a number of plug-ins for the Envisage framework that
+ Enthought has found useful for building scientific
+ applications. Envisage does not require that you use these
+ plug-ins, but you may find them useful to avoid having to reinvent
+ these particular wheels:
+ * Workbench: Provides an application GUI window that supports
+ views and perspectives, similar to the Eclipse IDE.
+ * Action: Supports user-interaction command mechanisms, such as
+ toolbars, menus, and buttons.
+ * Single Project: Supports a project paradigm for saving
+ application data, assuming an interaction model in which only
+ one project can be open in the application at a time.
+ * Text Editor: Provides a rudimentary text editor interface.
+ * Python Shell: Provides an interactive Python shell within a
+ Workbench-based application.
+ * Debug: Provides the Frame Based Inspector from the ETSDevTools
+ project as an Envisage plug-in
+ </longdescription>
+</pkgmetadata>