summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-06-30 10:05:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-06-30 10:05:53 +0000
commitd94fe1497c4f99f3f5e40abf820ccfc8a626c0c5 (patch)
treea8a9b9f83e392f5f56ed6af2b9cb4753928d3c75 /dev-php
parentbig updates (diff)
downloadhistorical-d94fe1497c4f99f3f5e40abf820ccfc8a626c0c5.tar.gz
historical-d94fe1497c4f99f3f5e40abf820ccfc8a626c0c5.tar.bz2
historical-d94fe1497c4f99f3f5e40abf820ccfc8a626c0c5.zip
big updates
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/Manifest14
-rw-r--r--dev-php/mod_php/files/70_mod_php.conf71
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.2-r31
-rw-r--r--dev-php/mod_php/mod_php-4.3.2-r1.ebuild3
-rw-r--r--dev-php/mod_php/mod_php-4.3.2-r2.ebuild4
-rw-r--r--dev-php/mod_php/mod_php-4.3.2-r3.ebuild161
-rw-r--r--dev-php/mod_php/mod_php-4.3.2.ebuild17
7 files changed, 225 insertions, 46 deletions
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index 5dd80519392b..e7edb33b0e01 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,12 +1,10 @@
-MD5 a32c7501e3740b25ed274fa975ebe098 mod_php-4.3.2-r3.ebuild~ 3546
-MD5 136c8a948544ac163e93e4c45e46092c mod_php-4.3.2.ebuild 2740
-MD5 e0874cf1aa3bf54ffa79c65a8f6e4f25 mod_php-4.3.2-r2.ebuild 3613
-MD5 e0874cf1aa3bf54ffa79c65a8f6e4f25 mod_php-4.3.2-r2.ebuild~ 3613
-MD5 171b138769aa006ffa4393144555cba3 mod_php-4.3.2-r1.ebuild 2676
-MD5 16c901c9b81273c00b5236dee387ad0b ChangeLog 18472
-MD5 a32c7501e3740b25ed274fa975ebe098 mod_php-4.3.2-r3.ebuild 3546
+MD5 75b2655fca588a345ddd693cf40b3218 mod_php-4.3.2.ebuild 3178
+MD5 f389bde39dbbb564cafe6d6373ca7a9e mod_php-4.3.2-r2.ebuild 3667
+MD5 a2abdac0d990f87991007345db84281b mod_php-4.3.2-r1.ebuild 2730
+MD5 76731f74c469016057c2fe2e821bfdb4 ChangeLog 19162
+MD5 eeaf122d117dcf9edb21b4e1270f4b5b mod_php-4.3.2-r3.ebuild 4723
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
-MD5 77023a54f39bae40733118d5cabd8f7f files/70_mod_php.conf 853
+MD5 b8b9eaba318ccf5b095a857847f00465 files/70_mod_php.conf 1066
MD5 9eb059611498a51db4d0d4b993ceb7a2 files/digest-mod_php-4.3.2 63
MD5 663577b8f4b90d61f245bb6052629194 files/pear_config.diff 422
MD5 9eb059611498a51db4d0d4b993ceb7a2 files/digest-mod_php-4.3.2-r1 63
diff --git a/dev-php/mod_php/files/70_mod_php.conf b/dev-php/mod_php/files/70_mod_php.conf
index 2088bbb78c2b..b06b9cd75742 100644
--- a/dev-php/mod_php/files/70_mod_php.conf
+++ b/dev-php/mod_php/files/70_mod_php.conf
@@ -1,34 +1,39 @@
-<IfDefine PHP>
- <IfModule !mod_php4.c>
- LoadModule php4_module extramodules/libphp4.so
- </IfModule>
-</IfDefine>
+<IfDefine PHP4>
+
+ # Load the module first
+ <IfModule !mod_php4.c>
+ LoadModule php4_module extramodules/libphp4.so
+ </IfModule>
+
+ # Set it to handle the files
+ <IfModule mod_mime.c>
+ AddType application/x-httpd-php .php
+ AddType application/x-httpd-php .phtml
+ AddType application/x-httpd-php .php3
+ AddType application/x-httpd-php .php4
+ AddType application/x-httpd-php-source .phps
+ </IfModule>
+
+ # Fix some bugs
+ <Files *.php>
+ LimitRequestBody 524288
+ RequestHeader unset If-Modified-Since
+ </Files>
+ <Files *.php3>
+ LimitRequestBody 524288
+ RequestHeader unset If-Modified-Since
+ </Files>
+ <Files *.php4>
+ LimitRequestBody 524288
+ RequestHeader unset If-Modified-Since
+ </Files>
+ <Files *.phps>
+ LimitRequestBody 524288
+ RequestHeader unset If-Modified-Since
+ </Files>
+ <Files *.phtml>
+ LimitRequestBody 524288
+ RequestHeader unset If-Modified-Since
+ </Files>
-<IfModule mod_mime.c>
- AddType application/x-httpd-php .php
- AddType application/x-httpd-php .phtml
- AddType application/x-httpd-php .php3
- AddType application/x-httpd-php .php4
- AddType application/x-httpd-php-source .phps
-</IfModule>
-
-<Files *.php>
- LimitRequestBody 524288
- RequestHeader unset If-Modified-Since
-</Files>
-<Files *.php3>
- LimitRequestBody 524288
- RequestHeader unset If-Modified-Since
-</Files>
-<Files *.php4>
- LimitRequestBody 524288
- RequestHeader unset If-Modified-Since
-</Files>
-<Files *.phps>
- LimitRequestBody 524288
- RequestHeader unset If-Modified-Since
-</Files>
-<Files *.phtml>
- LimitRequestBody 524288
- RequestHeader unset If-Modified-Since
-</Files>
+</IfDefine4>
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.2-r3 b/dev-php/mod_php/files/digest-mod_php-4.3.2-r3
new file mode 100644
index 000000000000..8271dab4f822
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.2-r3
@@ -0,0 +1 @@
+MD5 8aec1bb2dbcca1c92835c71e2e30d9c5 php-4.3.2.tar.bz2 3697581
diff --git a/dev-php/mod_php/mod_php-4.3.2-r1.ebuild b/dev-php/mod_php/mod_php-4.3.2-r1.ebuild
index 447d882f6959..ab4ea114b739 100644
--- a/dev-php/mod_php/mod_php-4.3.2-r1.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r1.ebuild,v 1.1 2003/06/10 19:14:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r1.ebuild,v 1.2 2003/06/30 10:05:50 robbat2 Exp $
+use apache2 && PHPSAPI="apache2" || PHPSAPI="apache1"
inherit php eutils
IUSE="${IUSE} apache2"
diff --git a/dev-php/mod_php/mod_php-4.3.2-r2.ebuild b/dev-php/mod_php/mod_php-4.3.2-r2.ebuild
index 3824e860ec1d..05767cdb3c83 100644
--- a/dev-php/mod_php/mod_php-4.3.2-r2.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.2-r2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r2.ebuild,v 1.4 2003/06/24 22:27:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r2.ebuild,v 1.5 2003/06/30 10:05:50 robbat2 Exp $
+use apache2 && PHPSAPI="apache2" || PHPSAPI="apache1"
inherit php eutils
IUSE="${IUSE} apache2"
@@ -111,6 +112,7 @@ apache2msg() {
}
pkg_postinst() {
+ php_pkg_postinst
einfo "To have Apache run php programs, please do the following:"
if [ "`use apache2`" ] ; then
apache2msg
diff --git a/dev-php/mod_php/mod_php-4.3.2-r3.ebuild b/dev-php/mod_php/mod_php-4.3.2-r3.ebuild
new file mode 100644
index 000000000000..26be1eebf79b
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.2-r3.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r3.ebuild,v 1.1 2003/06/30 10:05:50 robbat2 Exp $
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~arm ~sparc"
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+
+DEPEND="${DEPEND}
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 ) "
+
+detectapache() {
+ local domsg=
+ [ -n "$1" ] && domsg=1
+ HAVE_APACHE1=
+ HAVE_APACHE2=
+ has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+ has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+ [ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+ [ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+ [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+ case "${APACHEVER}" in
+ 1) [ -n "${domsg}" ] && einfo 'Apache1 only detected' ;;
+ 2) [ -n "${domsg}" ] && einfo 'Apache2 only detected';;
+ both)
+ if [ "`use apache2`" ]; then
+ [ -n "${domsg}" ] && einfo "Multiple Apache versions detected, using Apache2 (USE=apache2)"
+ APACHEVER=2
+ else
+ [ -n "${domsg}" ] && einfo 'Multiple Apache versions detected, using Apache1 (USE=-apache2)'
+ APACHEVER=1
+ fi ;;
+ *) if [ -n "${domsg}" ]; then
+ MSG="Unknown Apache version!"; eerror $MSG ; die $MSG
+ else
+ APACHEVER=0
+ fi; ;;
+ esac
+}
+
+detectapache
+
+SLOT="${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+PHPSAPI="apache${APACHEVER}"
+
+inherit php eutils
+
+src_unpack() {
+ multiinstwarn
+ detectapache domsg
+ php_src_unpack
+}
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|prechild|leader|threadpool|prefork'|xargs|cut -d. -f1`"
+ case "${APACHE2_MPM}" in
+ prefork) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ;;
+ esac;
+ fi
+
+ # optional support for apache2
+ #&& myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ #|| myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+
+ #use apache2 \
+ myconf="${myconf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ #php CGI stuff
+ #--enable-discard-path --enable-force-cgi-redirect
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+ einfo "Adding extra symlink to php.ini for Apache${USE_APACHE2}"
+ dodir /etc/apache${USE_APACHE2}/conf/
+ dodir ${PHPINIDIRECTORY}
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache${USE_APACHE2}/conf/${PHPINIFILENAME}
+
+ einfo "Adding extra symlink to Apache${USE_APACHE2} extramodules for PHP"
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules ${PHPINIDIRECTORY}/lib
+ exeinto /usr/lib/apache${USE_APACHE2}-extramodules
+ einfo "Installing mod_php shared object now"
+ doexe .libs/libphp4.so
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ einfo "Installing a Apache2 config for PHP (70_mod_php.conf)"
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ else
+ einfo "Installing a Apache config for PHP (mod_php.conf)"
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache/conf/addon-modules/${PHPINIFILENAME}
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ ewarn "This is a CHANGE from previous behavior, which was \"-D PHP\""
+ ewarn "This is for the upcoming PHP5 support. The ebuild will attempt"
+ ewarn "to make this update between PHP and PHP4 automatically"
+}
+
+multiinstwarn() {
+ ewarn "Due to some previous bloopers with PHP and slotting, you may have"
+ ewarn "multiple copies of mod_php installed. Please look at the autoclean"
+ ewarn "output at the end of the emerge and unmerge all but relevant"
+ ewarn "copies."
+}
+
+pkg_preinst() {
+ multiinstwarn
+ php_pkg_preinst
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ dosed 's,-D PHP,-D PHP4,' /etc/conf.d/apache2
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ multiinstwarn
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\""
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ multiinstwarn
+ if [ -n "${USE_APACHE2}" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}
diff --git a/dev-php/mod_php/mod_php-4.3.2.ebuild b/dev-php/mod_php/mod_php-4.3.2.ebuild
index fa21bcbf9457..9a2b9da0f217 100644
--- a/dev-php/mod_php/mod_php-4.3.2.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2.ebuild,v 1.4 2003/06/05 20:06:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2.ebuild,v 1.5 2003/06/30 10:05:50 robbat2 Exp $
+use apache2 && PHPSAPI="apache2" || PHPSAPI="apache1"
inherit php eutils
IUSE="${IUSE} apache2"
@@ -18,6 +19,7 @@ DEPEND="${DEPEND}
apache2? ( >=net-www/apache-2.0.43-r1 )
)"
+
src_compile() {
#no readline on server SAPI
myconf="${myconf} --without-readline"
@@ -74,7 +76,16 @@ src_install() {
}
apache2msg() {
- einfo "Edit /etc/conf.d/apache2 and add \"-D PHP\""
+ ewarn "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ ewarn "This is a CHANGE from previous behavior, which was \"-D PHP\""
+ ewarn "This is for the upcoming PHP5 support. The ebuild will attempt"
+ ewarn "to make this update between PHP and PHP4 automatically"
+}
+
+pkg_preinst() {
+ php_pkg_preinst
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ dosed 's,-D PHP,-D PHP4,' /etc/conf.d/apache2
}
pkg_postinst() {
@@ -84,7 +95,7 @@ pkg_postinst() {
else
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
- einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\""
einfo "That will include the php mime types in your configuration"
einfo "automagically and setup Apache to load php when it starts."
fi