summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-26 23:22:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-26 23:22:25 +0000
commitd6392c9a7855b021fc53164e41bd1825c03606b4 (patch)
tree0fa4d9a7646700e3fb4785353fba082009f01dcb /dev-php
parent*** empty log message *** (diff)
downloadhistorical-d6392c9a7855b021fc53164e41bd1825c03606b4.tar.gz
historical-d6392c9a7855b021fc53164e41bd1825c03606b4.tar.bz2
historical-d6392c9a7855b021fc53164e41bd1825c03606b4.zip
Cleaned up the config section.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog4
-rw-r--r--dev-php/mod_php/Manifest4
-rw-r--r--dev-php/mod_php/mod_php-4.3.1-r3.ebuild20
3 files changed, 14 insertions, 14 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 6b763893bb5a..33c3852b6bb0 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.72 2003/05/26 21:10:23 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.73 2003/05/26 23:22:20 robbat2 Exp $
*mod_php-4.3.1-r3 (23 Apr 2003)
26 May 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.1-r3.ebuild:
- Added DB4 fix in eclass.
+ Added DB4 fix in eclass. Cleaned up the config section.
17 May 2003; Robin H. Johnson <robbat2@gentoo.org> files/70_mod_php.conf:
Fixed bug #18445 properly. Apache2 doesn't like shell wildcarding in it's
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index cddc28151d7e..95f95f00de1a 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,9 +1,9 @@
-MD5 9b5416f0ed508853611588a3de6469c6 mod_php-4.3.1-r3.ebuild 2574
+MD5 9863994689eadaf7f96a033bd1a88b7c mod_php-4.3.1-r3.ebuild 2582
MD5 ec77ebae880bd19afa8027c4dc90a8a2 mod_php-4.3.1.ebuild 8929
MD5 c99a00bf82ec9a082399ab1dd931c415 mod_php-4.3.1-r2.ebuild 9241
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
MD5 dfc6bd16160024127fa9b0c242fc8ab5 mod_php-4.3.0-r2.ebuild 8634
-MD5 657837f1847b4552a30938f85ef795a2 ChangeLog 15883
+MD5 812a7324d155691c614b53b80373f307 ChangeLog 15914
MD5 c585d6d5154fe64839f25db957301433 mod_php-4.3.1-r1.ebuild 9135
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 77023a54f39bae40733118d5cabd8f7f files/70_mod_php.conf 853
diff --git a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
index d87beaa41397..d54de0ffd6f5 100644
--- a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.8 2003/05/14 20:08:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.9 2003/05/26 23:22:20 robbat2 Exp $
inherit php eutils
@@ -67,26 +67,26 @@ src_install() {
}
pkg_postinst() {
- einfo
einfo "To have Apache run php programs, please do the following:"
if [ "`use apache2`" ] ; then
einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
- einfo
- einfo "Please note Apache 2 support in php is currently experimental"
else
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\""
- einfo
einfo "That will include the php mime types in your configuration"
einfo "automagically and setup Apache to load php when it starts."
fi
}
pkg_config() {
- ${ROOT}/usr/sbin/apacheaddmod \
- ${ROOT}/etc/apache/conf/apache.conf \
- extramodules/libphp4.so mod_php4.c php4_module \
- before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
- :;
+ if [ "`use apache2`" ] ; then
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
}