summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-20 23:53:59 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-20 23:53:59 +0000
commitc033565ed964a0c17f25a6821474585428723755 (patch)
tree49f9f308b2dbcaf7e5934a3704f5004afa138016 /dev-php
parentVersion bumped. (diff)
downloadhistorical-c033565ed964a0c17f25a6821474585428723755.tar.gz
historical-c033565ed964a0c17f25a6821474585428723755.tar.bz2
historical-c033565ed964a0c17f25a6821474585428723755.zip
Version bumped.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/groupoffice/Manifest4
-rw-r--r--dev-php/groupoffice/files/digest-groupoffice-1.952
-rw-r--r--dev-php/groupoffice/groupoffice-1.95.ebuild65
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-php/groupoffice/Manifest b/dev-php/groupoffice/Manifest
index 0cf21a275b64..97b4bf7742b9 100644
--- a/dev-php/groupoffice/Manifest
+++ b/dev-php/groupoffice/Manifest
@@ -1,8 +1,8 @@
-MD5 58e206aa846087b5d285f567412023d4 ChangeLog 1260
+MD5 db3d3ffa449cb9183caa47936c74b7bd ChangeLog 1387
MD5 b3d12db8b7bfb4d40b3cf8c29341a35d groupoffice-1.93.ebuild 1644
MD5 11431d8f77db466e967841a751914c9e groupoffice-1.94.ebuild 1881
MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
-MD5 17cdad93ee2bb58c0ced6dc02d516887 groupoffice-1.95.ebuild 1880
+MD5 1b0b1f20e58fb1771937c193ec36a89a groupoffice-1.95.ebuild 1880
MD5 7a3a1675407a4dfc097aa364f5877cf9 files/digest-groupoffice-1.93 141
MD5 c9ecb492eeb607cf19a4094efcb6c6c5 files/digest-groupoffice-1.94 141
MD5 78f16ee026c820272586b7f363380623 files/digest-groupoffice-1.95 142
diff --git a/dev-php/groupoffice/files/digest-groupoffice-1.95 b/dev-php/groupoffice/files/digest-groupoffice-1.95
new file mode 100644
index 000000000000..101c092c0919
--- /dev/null
+++ b/dev-php/groupoffice/files/digest-groupoffice-1.95
@@ -0,0 +1,2 @@
+MD5 535c0af53daa333a4cea21fb5c3243b3 groupoffice-1.95.tar.gz 1128729
+MD5 4ee2188438e2a98cf17d6b47796ec30a GO-theme-crystal-1.93.tar.gz 286777
diff --git a/dev-php/groupoffice/groupoffice-1.95.ebuild b/dev-php/groupoffice/groupoffice-1.95.ebuild
new file mode 100644
index 000000000000..cd19522da4f7
--- /dev/null
+++ b/dev-php/groupoffice/groupoffice-1.95.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.95.ebuild,v 1.1 2004/01/20 23:53:50 mholzer Exp $
+
+inherit webapp-apache
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
+HOMEPAGE="http://group-office.sourceforge.net/"
+SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
+ mirror://sourceforge/group-office/GO-theme-crystal-1.93.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa"
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+webapp-detect || NO_WEBSERVER=1
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ if [ -d ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old ${PN} version first."
+ ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack GO-theme-crystal-1.93.tar.gz
+}
+
+src_install() {
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+
+ mkdir -p ${D}${destdir}
+ mv ${WORKDIR}/crystal ${S}/themes
+ cd ${S}
+ dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
+ rm -rf CHANGELOG FAQ INSTALL README.ldap TODO TRANSLATORS
+
+ cp -r . ${D}${destdir}
+
+ cd "${D}/${HTTPD_ROOT}"
+ chown -R "${HTTPD_USER}:${HTTPD_GROUP}" ${PN}
+ # Fix permissions
+ find ${D}${destdir} -type d | xargs chmod 755
+ find ${D}${destdir} -type f | xargs chmod 644
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
+ einfo "to complete the install. You need to add MySQL users"
+ einfo "and configure ${PN}"
+}