summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-26 23:35:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-26 23:35:47 +0000
commitb1f5fb8cd52cf40095399d739e5785b83f3b9c89 (patch)
treead7db262ef401046af82cb4075a53c02119ec755 /dev-php
parentCorrectly postinst slightly with regards to conf.d/apache* directives. (diff)
downloadhistorical-b1f5fb8cd52cf40095399d739e5785b83f3b9c89.tar.gz
historical-b1f5fb8cd52cf40095399d739e5785b83f3b9c89.tar.bz2
historical-b1f5fb8cd52cf40095399d739e5785b83f3b9c89.zip
Correctly postinst slightly with regards to conf.d/apache* directives.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/Manifest7
-rw-r--r--dev-php/mod_php/mod_php-4.3.1-r3.ebuild12
2 files changed, 10 insertions, 9 deletions
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index fd9c181c153d..96052f01c236 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,17 +1,14 @@
-MD5 84dae8f668842a9405ec588075d6ee27 mod_php-4.3.1-r3.ebuild 2570
+MD5 51647abe3d6bcf314ed554d74970fed9 mod_php-4.3.1-r3.ebuild 2570
MD5 ec77ebae880bd19afa8027c4dc90a8a2 mod_php-4.3.1.ebuild 8929
MD5 c99a00bf82ec9a082399ab1dd931c415 mod_php-4.3.1-r2.ebuild 9241
-MD5 8915f8233c4f6995b53ab72e44bf377d ChangeLog~ 15999
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
MD5 dfc6bd16160024127fa9b0c242fc8ab5 mod_php-4.3.0-r2.ebuild 8634
-MD5 8915f8233c4f6995b53ab72e44bf377d ChangeLog 15999
-MD5 84dae8f668842a9405ec588075d6ee27 mod_php-4.3.1-r3.ebuild~ 2570
+MD5 a424b54e90f9fb3ffc1445a2162f1f56 ChangeLog 15999
MD5 c585d6d5154fe64839f25db957301433 mod_php-4.3.1-r1.ebuild 9135
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 77023a54f39bae40733118d5cabd8f7f files/70_mod_php.conf 853
MD5 316366d60770de4c45957483cde50fe8 files/digest-mod_php-4.3.1 63
MD5 663577b8f4b90d61f245bb6052629194 files/pear_config.diff 422
-MD5 296a399eaf03902956090998b8a1f038 files/70_mod_php.conf~ 854
MD5 ad1869c3f2c3a60b4d7c4d26026373cf files/digest-mod_php-4.2.3-r2 63
MD5 3604218eee0ba5f7a1eac325de001eb1 files/digest-mod_php-4.3.0-r2 63
MD5 316366d60770de4c45957483cde50fe8 files/digest-mod_php-4.3.1-r1 63
diff --git a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
index 6df07be180cc..631e318a68b1 100644
--- a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.10 2003/05/26 23:27:34 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.11 2003/05/26 23:35:41 robbat2 Exp $
inherit php eutils
@@ -66,14 +66,18 @@ src_install() {
fi
}
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP\""
+}
+
pkg_postinst() {
einfo "To have Apache run php programs, please do the following:"
if [ "`use apache2`" ] ; then
- einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ apache2msg
else
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
- einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
einfo "That will include the php mime types in your configuration"
einfo "automagically and setup Apache to load php when it starts."
fi
@@ -81,7 +85,7 @@ pkg_postinst() {
pkg_config() {
if [ "`use apache2`" ] ; then
- einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ apache2msg
else
${ROOT}/usr/sbin/apacheaddmod \
${ROOT}/etc/apache/conf/apache.conf \