summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-23 00:58:29 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-23 00:58:29 +0000
commit8a65f03db6c8f3c21a9ca7f64067d558e9441c9d (patch)
treec136921ec2b52b525beaf51ba4e93f44a5290283 /dev-php
parentVersion bumped. (diff)
downloadhistorical-8a65f03db6c8f3c21a9ca7f64067d558e9441c9d.tar.gz
historical-8a65f03db6c8f3c21a9ca7f64067d558e9441c9d.tar.bz2
historical-8a65f03db6c8f3c21a9ca7f64067d558e9441c9d.zip
Version bumped.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/groupoffice/Manifest4
-rw-r--r--dev-php/groupoffice/files/digest-groupoffice-1.942
-rw-r--r--dev-php/groupoffice/groupoffice-1.94.ebuild63
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-php/groupoffice/Manifest b/dev-php/groupoffice/Manifest
index bb9e071d778b..69217e2cd3f9 100644
--- a/dev-php/groupoffice/Manifest
+++ b/dev-php/groupoffice/Manifest
@@ -1,6 +1,6 @@
MD5 fb81279895aa62ac6bfd454baadec725 groupoffice-1.93.ebuild 1630
MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
-MD5 ea47ede5c3592c442834b86017bcd50c groupoffice-1.94.ebuild 1530
-MD5 6de9b83ed59eb797f1bc6f624958639a ChangeLog 699
+MD5 c4184bd366c84b528cd2b78cb9acb4ed groupoffice-1.94.ebuild 1867
+MD5 955d04498297980d4b4492ac22e6b680 ChangeLog 826
MD5 9ab4f42534d1764c767a329e364b2812 files/digest-groupoffice-1.94 140
MD5 25ba2eb31d2f0d3ceae26bbf9e6e6f2b files/digest-groupoffice-1.93 140
diff --git a/dev-php/groupoffice/files/digest-groupoffice-1.94 b/dev-php/groupoffice/files/digest-groupoffice-1.94
new file mode 100644
index 000000000000..dc563d38a89f
--- /dev/null
+++ b/dev-php/groupoffice/files/digest-groupoffice-1.94
@@ -0,0 +1,2 @@
+MD5 8b860e4a048906f7eb049b5e539f364c groupoffice-1.94.tar.gz 827064
+MD5 8cb2d7e57d2497223ce032a74a40a6ff GO-theme-Crystal-1.9.tar.gz 285813
diff --git a/dev-php/groupoffice/groupoffice-1.94.ebuild b/dev-php/groupoffice/groupoffice-1.94.ebuild
new file mode 100644
index 000000000000..c782419d80c9
--- /dev/null
+++ b/dev-php/groupoffice/groupoffice-1.94.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.94.ebuild,v 1.1 2003/11/23 00:58:24 mholzer Exp $
+
+inherit webapp-apache
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
+HOMEPAGE="http://group-office.sourceforge.net/"
+SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
+ mirror://sourceforge/group-office/GO-theme-Crystal-1.9.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+webapp-detect || NO_WEBSERVER=1
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ if [ -d ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old ${PN} version first."
+ ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack GO-theme-Crystal-1.9.tar.gz
+}
+
+src_install() {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+
+ mkdir -p ${D}${destdir}
+ mv ${WORKDIR}/crystal ${S}/themes
+ cd ${S}
+ dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
+ rm -rf CHANGELOG FAQ INSTALL README.ldap TODO TRANSLATORS
+
+ cp -r . ${D}${destdir}
+
+ cd "${D}/${HTTPD_ROOT}"
+ chown -R "${HTTPD_USER}:${HTTPD_GROUP}" ${PN}
+ # Fix permissions
+ find ${D}${destdir} -type d | xargs chmod 755
+ find ${D}${destdir} -type f | xargs chmod 644
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
+ einfo "to complete the install. You need to add MySQL users"
+ einfo "and configure ${PN}"
+}