summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-04-03 17:22:24 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-04-03 17:22:24 +0000
commita8a7bf77fded4491f4e77542a1c200bd84871678 (patch)
treeac55a4a4668753d1628a1105d6432faa1aad1091 /dev-php5/xcache
parentStable for HPPA (bug #360055). (diff)
downloadhistorical-a8a7bf77fded4491f4e77542a1c200bd84871678.tar.gz
historical-a8a7bf77fded4491f4e77542a1c200bd84871678.tar.bz2
historical-a8a7bf77fded4491f4e77542a1c200bd84871678.zip
Removed older versions
Package-Manager: portage-2.1.9.41/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'dev-php5/xcache')
-rw-r--r--dev-php5/xcache/xcache-1.3.0-r1.ebuild87
-rw-r--r--dev-php5/xcache/xcache-1.3.0-r2.ebuild81
-rw-r--r--dev-php5/xcache/xcache-1.3.0.ebuild87
3 files changed, 0 insertions, 255 deletions
diff --git a/dev-php5/xcache/xcache-1.3.0-r1.ebuild b/dev-php5/xcache/xcache-1.3.0-r1.ebuild
deleted file mode 100644
index 4af25dacd47a..000000000000
--- a/dev-php5/xcache/xcache-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/xcache-1.3.0-r1.ebuild,v 1.2 2011/03/13 08:09:26 olemarkus Exp $
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-PHPSAPILIST="apache2 cgi fpm"
-
-inherit php-ext-source-r1 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="!dev-php/eaccelerator !dev-php5/pecl-apc"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- has_php
- require_php_sapi_from cgi apache2
-}
-
-src_compile() {
- has_php
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r1_src_compile
-}
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php AUTHORS ChangeLog NEWS README THANKS
-
- php-ext-base-r1_addtoinifiles "xcache.admin.enable_auth" '"On"'
- php-ext-base-r1_addtoinifiles "xcache.admin.user" '"admin"'
- php-ext-base-r1_addtoinifiles "xcache.admin.pass" '""'
-
- php-ext-base-r1_addtoinifiles "xcache.cacher" '"On"'
- php-ext-base-r1_addtoinifiles "xcache.size" '"64M"'
- php-ext-base-r1_addtoinifiles "xcache.count" '"2"'
- php-ext-base-r1_addtoinifiles "xcache.slots" '"8k"'
- php-ext-base-r1_addtoinifiles "xcache.ttl" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.gc_interval" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.var_size" '"8M"'
- php-ext-base-r1_addtoinifiles "xcache.var_count" '"1"'
- php-ext-base-r1_addtoinifiles "xcache.var_slots" '"8K"'
- php-ext-base-r1_addtoinifiles "xcache.var_ttl" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.var_maxttl" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.var_gc_interval" '"600"'
- php-ext-base-r1_addtoinifiles "xcache.readonly_protection" '"Off"'
- php-ext-base-r1_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
-
- php-ext-base-r1_addtoinifiles "xcache.coverager" '"Off"'
- php-ext-base-r1_addtoinifiles "xcache.coveragedump_directory" '""'
-
- php-ext-base-r1_addtoinifiles "xcache.optimizer" '"Off"'
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}/admin"
- doins admin/*
- insinto "${PHP_EXT_SHARED_DIR}/coverager"
- doins coverager/*
-}
-
-pkg_postinst() {
- elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
- elog "release were installed into ${ROOT}usr/share/php5/xcache/."
-}
diff --git a/dev-php5/xcache/xcache-1.3.0-r2.ebuild b/dev-php5/xcache/xcache-1.3.0-r2.ebuild
deleted file mode 100644
index 88bb4ed118e3..000000000000
--- a/dev-php5/xcache/xcache-1.3.0-r2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/xcache-1.3.0-r2.ebuild,v 1.4 2011/03/13 08:09:26 olemarkus Exp $
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-PHPSAPILIST="apache2 cgi fpm"
-
-EAPI="2"
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="virtual/httpd-php
-!dev-php/eaccelerator !dev-php5/pecl-apc"
-RDEPEND="${DEPEND}"
-
-src_compile() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_compile
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- php-ext-source-r2_addtoinifiles "xcache.admin.enable_auth" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.admin.user" '"admin"'
- php-ext-source-r2_addtoinifiles "xcache.admin.pass" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.cacher" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.size" '"64M"'
- php-ext-source-r2_addtoinifiles "xcache.count" '"2"'
- php-ext-source-r2_addtoinifiles "xcache.slots" '"8k"'
- php-ext-source-r2_addtoinifiles "xcache.ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.gc_interval" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_size" '"8M"'
- php-ext-source-r2_addtoinifiles "xcache.var_count" '"1"'
- php-ext-source-r2_addtoinifiles "xcache.var_slots" '"8K"'
- php-ext-source-r2_addtoinifiles "xcache.var_ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_maxttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_gc_interval" '"600"'
- php-ext-source-r2_addtoinifiles "xcache.readonly_protection" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
-
- php-ext-source-r2_addtoinifiles "xcache.coverager" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.coveragedump_directory" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.optimizer" '"Off"'
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}/admin"
- doins admin/*
- insinto "${PHP_EXT_SHARED_DIR}/coverager"
- doins coverager/*
-}
-
-pkg_postinst() {
- elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
- elog "release were installed into ${ROOT}usr/share/php5/xcache/."
-}
diff --git a/dev-php5/xcache/xcache-1.3.0.ebuild b/dev-php5/xcache/xcache-1.3.0.ebuild
deleted file mode 100644
index 74f0c5eb2636..000000000000
--- a/dev-php5/xcache/xcache-1.3.0.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/xcache-1.3.0.ebuild,v 1.4 2011/03/13 08:09:26 olemarkus Exp $
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-PHPSAPILIST="apache2 cgi"
-
-inherit php-ext-source-r1 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="!dev-php/eaccelerator !dev-php5/pecl-apc"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- has_php
- require_php_sapi_from cgi apache2
-}
-
-src_compile() {
- has_php
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r1_src_compile
-}
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php AUTHORS ChangeLog NEWS README THANKS
-
- php-ext-base-r1_addtoinifiles "xcache.admin.enable_auth" '"On"'
- php-ext-base-r1_addtoinifiles "xcache.admin.user" '"admin"'
- php-ext-base-r1_addtoinifiles "xcache.admin.pass" '""'
-
- php-ext-base-r1_addtoinifiles "xcache.cacher" '"On"'
- php-ext-base-r1_addtoinifiles "xcache.size" '"64M"'
- php-ext-base-r1_addtoinifiles "xcache.count" '"2"'
- php-ext-base-r1_addtoinifiles "xcache.slots" '"8k"'
- php-ext-base-r1_addtoinifiles "xcache.ttl" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.gc_interval" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.var_size" '"8M"'
- php-ext-base-r1_addtoinifiles "xcache.var_count" '"1"'
- php-ext-base-r1_addtoinifiles "xcache.var_slots" '"8K"'
- php-ext-base-r1_addtoinifiles "xcache.var_ttl" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.var_maxttl" '"0"'
- php-ext-base-r1_addtoinifiles "xcache.var_gc_interval" '"600"'
- php-ext-base-r1_addtoinifiles "xcache.readonly_protection" '"Off"'
- php-ext-base-r1_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
-
- php-ext-base-r1_addtoinifiles "xcache.coverager" '"Off"'
- php-ext-base-r1_addtoinifiles "xcache.coveragedump_directory" '""'
-
- php-ext-base-r1_addtoinifiles "xcache.optimizer" '"Off"'
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}/admin"
- doins admin/*
- insinto "${PHP_EXT_SHARED_DIR}/coverager"
- doins coverager/*
-}
-
-pkg_postinst() {
- elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
- elog "release were installed into ${ROOT}usr/share/php5/xcache/."
-}