summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-28 12:45:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-28 12:45:00 +0000
commitf2a4ee9007b747fb833adf9abc2c680b6a1b39ef (patch)
tree223941c8bf14b8e412fd757ed96b7b234af229fc /dev-ml/oasis
parentinitial import, ebuild by various people in bug #325941 and converted to oasi... (diff)
downloadhistorical-f2a4ee9007b747fb833adf9abc2c680b6a1b39ef.tar.gz
historical-f2a4ee9007b747fb833adf9abc2c680b6a1b39ef.tar.bz2
historical-f2a4ee9007b747fb833adf9abc2c680b6a1b39ef.zip
initial import, based on ebuild by Vladimir Ivanov in bug #355767 and converted to oasis.eclass
Package-Manager: portage-2.2.0_alpha96/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/oasis')
-rw-r--r--dev-ml/oasis/ChangeLog11
-rw-r--r--dev-ml/oasis/Manifest14
-rw-r--r--dev-ml/oasis/metadata.xml5
-rw-r--r--dev-ml/oasis/oasis-0.3.0_rc3.ebuild38
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/oasis/ChangeLog b/dev-ml/oasis/ChangeLog
new file mode 100644
index 000000000000..2d30b6058856
--- /dev/null
+++ b/dev-ml/oasis/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/oasis
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/oasis/ChangeLog,v 1.1 2012/03/28 12:45:00 aballier Exp $
+
+*oasis-0.3.0_rc3 (28 Mar 2012)
+
+ 28 Mar 2012; Alexis Ballier <aballier@gentoo.org> +oasis-0.3.0_rc3.ebuild,
+ +metadata.xml:
+ initial import, based on ebuild by Vladimir Ivanov in bug #355767 and
+ converted to oasis.eclass
+
diff --git a/dev-ml/oasis/Manifest b/dev-ml/oasis/Manifest
new file mode 100644
index 000000000000..8a63c12ccb37
--- /dev/null
+++ b/dev-ml/oasis/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST oasis-0.3.0~rc3.tar.gz 272316 RMD160 90d701f7e649b796f32488f9baa047f0a41e882a SHA1 3be557f6c45851e8e74853fd0e1d16f76fcd0668 SHA256 9e62d0a76235da67e358dc624a8c97731bbfb317489f9c4c78d6bb98c74e74a4
+EBUILD oasis-0.3.0_rc3.ebuild 975 RMD160 15a5fee6c85d246e727ebb44492666c6f365f1fe SHA1 492a47469162294fc6c9df0351f2724f50ce9086 SHA256 278eace11d858da49cded8e8951f968dc02399e85a265a41661645e0777e8e05
+MISC ChangeLog 426 RMD160 4ad9e318574330212e8c457292e734f3ccd34d94 SHA1 65ea6913ce9f27dd572bd10c51d7a463365dc849 SHA256 d3149e8eb006c242bc68e859047a2535dea5be7b8fae73639c15fc2e9ec1c3ee
+MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEARECAAYFAk9zB9IACgkQvFcC4BYPU0p3eQCeOoDZrLbIfz6MF/loJ0JySh7o
+whEAoK7ol5Kg7jPBvxB0cfRmFD3OWYjy
+=3eaI
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/oasis/metadata.xml b/dev-ml/oasis/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/oasis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/oasis/oasis-0.3.0_rc3.ebuild b/dev-ml/oasis/oasis-0.3.0_rc3.ebuild
new file mode 100644
index 000000000000..d2cf89f77126
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.3.0_rc3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/oasis/oasis-0.3.0_rc3.ebuild,v 1.1 2012/03/28 12:45:00 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/829/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-fileutils-0.4.2
+ dev-ml/batteries
+ dev-ml/pcre-ocaml
+ >=dev-ml/ocaml-data-notation-0.0.3
+ dev-ml/ocamlgraph"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ test? (
+ >=dev-ml/ounit-1.1.0
+ >=dev-ml/ocaml-expect-0.0.2
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.txt" "TODO.txt" "AUTHORS.txt" "CHANGES.txt" )