summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-02 12:18:35 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-02 12:18:35 +0000
commit8e6680f63e60fc85e473f4ee1b21879ac154b82b (patch)
treedb1557872112867ccae1c03edefba52d13d47bf6 /dev-lisp
parentUnmasked net-www/cocoon-2.0.2 (diff)
downloadhistorical-8e6680f63e60fc85e473f4ee1b21879ac154b82b.tar.gz
historical-8e6680f63e60fc85e473f4ee1b21879ac154b82b.tar.bz2
historical-8e6680f63e60fc85e473f4ee1b21879ac154b82b.zip
Unmasked. Marked for testing.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/bigloo-lib/ChangeLog6
-rw-r--r--dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild28
2 files changed, 19 insertions, 15 deletions
diff --git a/dev-lisp/bigloo-lib/ChangeLog b/dev-lisp/bigloo-lib/ChangeLog
index 59b51d57e040..fc41cf08d784 100644
--- a/dev-lisp/bigloo-lib/ChangeLog
+++ b/dev-lisp/bigloo-lib/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for dev-lisp/bigloo-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo-lib/ChangeLog,v 1.2 2002/08/08 23:03:01 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo-lib/ChangeLog,v 1.3 2002/11/02 12:18:35 karltk Exp $
*bigloo-lib-0.17 (13 Apr 2002)
- 01 Aug 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild :
+ 02 Nov 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild :
+ Fixed USE flags, unmasked and marked for testing.
+ 01 Aug 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild :
Added LICENSE, SLOT and KEYWORDS (apparently Seemant had a finger in this).
13 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild files/digest-bigloo-lib-0.17 :
diff --git a/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild b/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild
index c799e48af766..e35018ef60bb 100644
--- a/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild
+++ b/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild,v 1.7 2002/10/05 05:39:11 drobbins Exp $
-
-IUSE="nls gtk postgres mysql gtk2 ipcs gd ldap X gdbm expat"
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild,v 1.8 2002/11/02 12:18:35 karltk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Bigloo support libraries"
SRC_URI="mirror://sourceforge/bigloo-lib/${P}.tar.gz"
HOMEPAGE="http://bigloo-lib.sf.net"
-
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~sparc64"
+IUSE="nls gtk postgres mysql gtk2 ipcs gd ldap X gdbm expat"
DEPEND=">=dev-lisp/bigloo-2.4
X? ( virtual/x11 )
@@ -21,6 +19,7 @@ DEPEND=">=dev-lisp/bigloo-2.4
gtk2? ( =x11-libs/gtk+-2* )
ldap? ( >=net-nds/openldap-2.0.18 )
gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ >=dev-libs/expat-1.95.4
"
src_compile() {
local myconf
@@ -50,10 +49,6 @@ src_compile() {
&& myconf="${myconf} --with-iconv --with-gettext" \
|| myconf="${myconf} --without-nls --without-gettext"
- use ipcs \
- && myconf="${myconf} --with-ipcs" \
- || myconf="${myconf} --without-ipcs"
-
# gdbm support doesn't work
# use gdbm \
# && myconf="${myconf} --with-gdbm" \
@@ -68,13 +63,20 @@ src_compile() {
&& myconf="${myconf} --with-postgres" \
|| myconf="${myconf} --without-postgres"
- use expat \
- && myconf="${myconf} --with-expat" \
- || myconf="${myconf} --without-expat"
+# We just force these, as we don't have useflags for them.
+# use expat \
+# && myconf="${myconf} --with-expat" \
+# || myconf="${myconf} --without-expat"
+# use ipcs \
+# && myconf="${myconf} --with-ipcs" \
+# || myconf="${myconf} --without-ipcs"
+
+
+ myconf="${myconf} --with-expat --with-ipcs"
econf ${myconf} || die "./configure failed"
- emake || die
+ make || die
}
src_install () {