summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-06-03 23:44:26 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-06-03 23:44:26 +0000
commit8e43840003a174b3b48cb29b4b63da250e176efb (patch)
tree8e30ee0efd109286392f24cba05503d06249fac9 /dev-lisp
parentcomments (diff)
downloadhistorical-8e43840003a174b3b48cb29b4b63da250e176efb.tar.gz
historical-8e43840003a174b3b48cb29b4b63da250e176efb.tar.bz2
historical-8e43840003a174b3b48cb29b4b63da250e176efb.zip
Fixes #3094.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog37
-rw-r--r--dev-lisp/clisp/clisp-2.28.ebuild37
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.281
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
new file mode 100644
index 000000000000..1247ae7a8bd1
--- /dev/null
+++ b/dev-lisp/clisp/ChangeLog
@@ -0,0 +1,37 @@
+# ChangeLog for dev-lisp/clisp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.1 2002/06/03 23:44:26 karltk Exp $
+
+*clisp-2.28 (03 Jun 2002)
+
+ 03 Jun 2002; Karl Trygve Kalleberg <karltk@gentoo.org> clisp-2.28.ebuild files/digest-clisp-2.28 :
+
+ From the web page:
+
+ Common Lisp is a high-level, all-purpose, object-oriented, dynamic,
+ functional programming language.
+
+ CLISP is a Common Lisp implementation by Bruno Haible, then of Karlsruhe
+ University, and Michael Stoll, then of Munich University, both in
+ Germany. It mostly supports the Lisp described in the ANSI Common Lisp
+ standard.
+
+ CLISP includes an interpreter, a compiler, a large subset of CLOS, a
+ foreign language interface and a socket interface. An X11 interface is
+ available through CLX and Garnet. Command line editing is provided by
+ readline.
+
+ CLISP runs on microcomputers (OS/2, Windows 95/98/2000/NT, Amiga
+ 500-4000, Acorn RISC PC) as well as on Unix workstations (GNU/Linux,
+ BSD, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and
+ others) and needs only 2 MB of RAM.
+
+ CLISP is Free Software and may be distributed under the terms of GNU
+ GPL. You may distribute commercial applications compiled with CLISP, see
+ file COPYRIGHT in the CLISP distribution.
+
+ The user interface comes in German, English, French, Spanish and Dutch,
+ and can be changed at run time.
+
+ Ebuild submitted by Cliff Crawford <cjc26@cornell.edu>.
+
diff --git a/dev-lisp/clisp/clisp-2.28.ebuild b/dev-lisp/clisp/clisp-2.28.ebuild
new file mode 100644
index 000000000000..48fbd1be9ec8
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.28.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.1 2002/06/03 23:44:26 karltk Exp $
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="http://cvs2.cons.org/ftp-area/clisp/source/latest/${P}.tar.gz"
+S=${WORKDIR}/${P}
+DEPEND="X? ( x11-base/xfree )"
+RDEPEND="$DEPEND"
+LICENSE="GPL-2"
+SLOT="2"
+
+src_compile() {
+ local myconf="--with-dynamic-ffi --with-dynamic-modules --with-export-syscalls --with-module=wildcard --with-module=regexp --with-module=bindings/linuxlibc6"
+ if [ -n "`use X`" ] ; then
+ myconf="${myconf} --with-module=clx/new-clx"
+ fi
+
+ unset CHOST # compilation of modules fails if we don't do this
+ unset CFLAGS
+ unset CXXFLAGS
+ ./configure --prefix=/usr ${myconf} || die "./configure failed"
+ cd src
+ ./makemake ${myconf} > Makefile
+ make config.lisp
+ emake || die
+}
+
+src_install () {
+ cd src
+ make DESTDIR=${D} prefix=/usr install-bin || die
+ install -Dm 644 clisp.1 ${D}/usr/share/man/man1/clisp.1
+ install -Dm 644 clreadline.3 ${D}/usr/share/man/man3/clreadline.3
+ dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
+}
+
diff --git a/dev-lisp/clisp/files/digest-clisp-2.28 b/dev-lisp/clisp/files/digest-clisp-2.28
new file mode 100644
index 000000000000..a42de81b78d3
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.28
@@ -0,0 +1 @@
+MD5 d5f8acf2de0db2f5f53e7747d0d84503 clisp-2.28.tar.gz 10980199