summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-07 15:53:27 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-07 15:53:27 +0000
commitd2b28471e54e4e18cafd99035c32dde8fcac0a3d (patch)
tree94b0232521207c079d0060be52892b87fdff7ced /dev-libs
parentminor corrections (diff)
downloadhistorical-d2b28471e54e4e18cafd99035c32dde8fcac0a3d.tar.gz
historical-d2b28471e54e4e18cafd99035c32dde8fcac0a3d.tar.bz2
historical-d2b28471e54e4e18cafd99035c32dde8fcac0a3d.zip
*whoeps* this one shouldnt have been removed
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/atk/atk-1.1.1.ebuild40
-rw-r--r--dev-libs/atk/files/digest-atk-1.1.11
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/atk/atk-1.1.1.ebuild b/dev-libs/atk/atk-1.1.1.ebuild
new file mode 100644
index 000000000000..3ba10b89a827
--- /dev/null
+++ b/dev-libs/atk/atk-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.1.1.ebuild,v 1.6 2002/12/07 15:53:27 foser Exp $
+
+IUSE="doc"
+
+inherit libtool gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-libs/glib-2.0.6-r1"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
+}
diff --git a/dev-libs/atk/files/digest-atk-1.1.1 b/dev-libs/atk/files/digest-atk-1.1.1
new file mode 100644
index 000000000000..a902899bc030
--- /dev/null
+++ b/dev-libs/atk/files/digest-atk-1.1.1
@@ -0,0 +1 @@
+MD5 32feb6d641496ace5bb80ed57d5d9556 atk-1.1.1.tar.bz2 265696