summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-09-25 20:24:44 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-09-25 20:24:44 +0000
commit93c497eca14e762e77331f73fee4ff734840dda7 (patch)
tree4cbbd55b6b49a47cab9afed7be41c5e71e32c7fd /dev-libs
parentNew package for generating bindings to C/C++ libs, fixes bug #65138. (diff)
downloadhistorical-93c497eca14e762e77331f73fee4ff734840dda7.tar.gz
historical-93c497eca14e762e77331f73fee4ff734840dda7.tar.bz2
historical-93c497eca14e762e77331f73fee4ff734840dda7.zip
New version to complement gcc-3.3.4.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libffi/ChangeLog7
-rw-r--r--dev-libs/libffi/Manifest4
-rw-r--r--dev-libs/libffi/files/digest-libffi-3.3.41
-rw-r--r--dev-libs/libffi/libffi-3.3.4.ebuild245
4 files changed, 255 insertions, 2 deletions
diff --git a/dev-libs/libffi/ChangeLog b/dev-libs/libffi/ChangeLog
index 48306a4bd026..87aa4b7ebf20 100644
--- a/dev-libs/libffi/ChangeLog
+++ b/dev-libs/libffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libffi
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.14 2004/09/22 21:48:48 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.15 2004/09/25 20:24:44 fafhrd Exp $
+
+*libffi-3.3.4 (25 Sep 2004)
+
+ 25 Sep 2004; Armando Di Cianno <fafhrd@gentoo.org> +libffi-3.3.4.ebuild:
+ New version to complement gcc-3.3.4.
*libffi-3.3.3-r1 (22 Sep 2004)
diff --git a/dev-libs/libffi/Manifest b/dev-libs/libffi/Manifest
index 710d098bf3c1..85633c86ef67 100644
--- a/dev-libs/libffi/Manifest
+++ b/dev-libs/libffi/Manifest
@@ -1,9 +1,10 @@
MD5 08d7b6eaa5800e26d7c5f13a0cb9f9d4 libffi-3.4.1-r1.ebuild 5686
+MD5 5c953f3a17df7e17c9c2be96349a2dc7 libffi-3.3.4.ebuild 6680
MD5 3113b98f43bda47db0f39bd6f6e3aad1 libffi-1.20.ebuild 605
MD5 210eb5394a3edcd012ab3eb5c7dd0451 libffi-3.3.3-r1.ebuild 6683
MD5 e21dd80ca7b21c735c8e7808a6c3c82e libffi-3.3.3.ebuild 6895
MD5 8e8520857bfdc8f92328b44e6449db28 libffi-3.4.1.ebuild 7094
-MD5 c452b08c07325d10b874f359b0b1e691 ChangeLog 2504
+MD5 199845d798fa3ce9fba11544e3ebe406 ChangeLog 2648
MD5 ef1d6e99f954cc3412a9e513a2d80c64 metadata.xml 1836
MD5 ed8f1e978198c34ad3dc3b81c4804199 files/digest-libffi-1.20 63
MD5 1ca677e646f4d209e68601c9ba83c629 files/libffi-without-libgcj.dpatch 2255
@@ -11,4 +12,5 @@ MD5 78c9b1a1b40fcc12f8cf34d57a970f00 files/libffi-soversion.dpatch 1943
MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libffi-3.3.3-r1 64
MD5 03a0e46a8ce1aff598b68a731112c13a files/digest-libffi-3.4.1-r1 64
MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libffi-3.3.3 64
+MD5 4068b84d9ce9d440b063718549cfc354 files/digest-libffi-3.3.4 64
MD5 03a0e46a8ce1aff598b68a731112c13a files/digest-libffi-3.4.1 64
diff --git a/dev-libs/libffi/files/digest-libffi-3.3.4 b/dev-libs/libffi/files/digest-libffi-3.3.4
new file mode 100644
index 000000000000..fe96fb0b69f8
--- /dev/null
+++ b/dev-libs/libffi/files/digest-libffi-3.3.4
@@ -0,0 +1 @@
+MD5 a1c267b34f05c8660b24251865614d8b gcc-3.3.4.tar.bz2 23331664
diff --git a/dev-libs/libffi/libffi-3.3.4.ebuild b/dev-libs/libffi/libffi-3.3.4.ebuild
new file mode 100644
index 000000000000..020dd2f08f6e
--- /dev/null
+++ b/dev-libs/libffi/libffi-3.3.4.ebuild
@@ -0,0 +1,245 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.3.4.ebuild,v 1.1 2004/09/25 20:24:44 fafhrd Exp $
+
+inherit eutils flag-o-matic libtool gnuconfig
+
+# This ebuild mod'd from libstdc++ compatbility package ebuild to create
+# a similar structure for libffi, which is also included in gcc sources.
+# __Armando Di Cianno <fafhrd@gentoo.org>
+
+do_filter_flags() {
+ declare setting
+
+ strip-flags
+
+ # In general gcc does not like optimization, and add -O2 where
+ # it is safe. This is especially true for gcc 3.3 + 3.4
+ replace-flags -O? -O2
+
+ if use amd64
+ then
+ # gcc 3.3 doesn't support -march=k8/etc on amd64, so xgcc will fail
+ setting="`get-flag march`"
+ [ ! -z "${setting}" ] && filter-flags -march="${setting}"
+ fi
+
+ # and on x86, we just need to filter the 3.4 specific amd64 -marchs
+ filter-flags -march=k8
+ filter-flags -march=athlon64
+ filter-flags -march=opteron
+
+ # gcc 3.3 doesn't support -march=pentium-m
+ replace-flags -march=pentium-m -march=pentium3
+
+ # gcc 3.3 doesn't support -mtune on numerous archs, so xgcc will fail
+ setting="`get-flag mtune`"
+ [ ! -z "${setting}" ] && filter-flags -mtune="${setting}"
+
+ # xgcc wont understand gcc 3.4 flags...
+ filter-flags -fno-unit-at-a-time
+ filter-flags -funit-at-a-time
+ filter-flags -fweb
+ filter-flags -fno-web
+
+ # xgcc isnt patched with propolice
+ filter-flags -fstack-protector-all
+ filter-flags -fno-stack-protector-all
+ filter-flags -fstack-protector
+ filter-flags -fno-stack-protector
+
+ # xgcc isnt patched with the gcc symbol visibility patch
+ filter-flags -fvisibility-inlines-hidden
+ filter-flags -fvisibility=hidden
+
+ # ...sure, why not?
+ strip-unsupported-flags
+}
+
+S=${WORKDIR}/gcc-${PV}
+
+# Theoretical cross compiler support
+[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
+
+LOC="/usr"
+MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+
+LIBPATH="${LOC}/lib/gcc-lib/${CCHOST}/${MY_PV_FULL}"
+BINPATH="${LOC}/${CCHOST}/gcc-bin/${MY_PV}"
+DATAPATH="${LOC}/share/gcc-data/${CCHOST}/${MY_PV}"
+# Dont install in /usr/include/g++-v3/, but in gcc internal directory.
+# We will handle /usr/include/g++-v3/ with gcc-config ...
+STDCXX_INCDIR="${LIBPATH}/include/g++-v${MY_PV/\.*/}"
+
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2"
+
+DESCRIPTION="libffi (from gcc) does not commonly build unless gcj is compiled, but is used by other projects, like GNUstep."
+HOMEPAGE="http://gcc.gnu.org/"
+
+LICENSE="libffi"
+
+KEYWORDS="-* ~x86"
+IUSE="nls"
+
+SLOT="0"
+## 3.2.3 -> 3.3.x install .so.5, so lets slot to 5
+#if [ "${CHOST}" == "${CCHOST}" ]
+#then
+# SLOT="5"
+#else
+# SLOT="${CCHOST}-5"
+#fi
+
+DEPEND="virtual/libc
+ !nptl? ( !uclibc? ( >=sys-libs/glibc-2.3.2-r3 ) )
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-devel/gcc-3.3.3_pre20040130
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+
+RDEPEND="virtual/libc
+ !nptl? ( !uclibc? ( >=sys-libs/glibc-2.3.2-r3 ) )
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/texinfo-4.2-r4
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+pkg_setup() {
+ if test_version_info ${PV}
+ then
+ einfo "Correctly using gcc version ${PV}"
+ else
+ eerror "Not using gcc version ${PV}!"
+ einfo "Please switch to this gcc profile using gcc-config and re-run emerge."
+ einfo "If you are using a newer version of gcc, you can see if there is a matching version of libffi."
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # XXX: fix these at some point
+ #EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/libffi-without-libgcj.dpatch
+ #EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/libffi-soversion.dpatch
+
+ cd ${S}
+ # Fixup libtool to correctly generate .la files with portage
+ elibtoolize --portage --shallow
+
+ cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+ gnuconfig_update
+}
+
+src_compile() {
+
+ local myconf=
+
+ if ! use nls || use build
+ then
+ myconf="${myconf} --disable-nls"
+ else
+ myconf="${myconf} --enable-nls --without-included-gettext"
+ fi
+
+ #use amd64 && myconf="${myconf} --disable-multilib"
+
+ do_filter_flags
+ einfo "CFLAGS=\"${CFLAGS}\""
+ einfo "CXXFLAGS=\"${CXXFLAGS}\""
+
+ # Build in a separate build tree
+ mkdir -p ${WORKDIR}/build
+ cd ${WORKDIR}/build
+
+ einfo "Configuring libffi..."
+ addwrite "/dev/zero"
+ ${S}/configure --prefix=${LOC} \
+ --bindir=${BINPATH} \
+ --includedir=${LIBPATH}/include \
+ --datadir=${DATAPATH} \
+ --mandir=${DATAPATH}/man \
+ --infodir=${DATAPATH}/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --target=${CCHOST} \
+ --with-system-zlib \
+ --enable-languages=java,c++,objc \
+ --enable-threads=posix \
+ --enable-long-long \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --enable-__cxa_atexit \
+ --enable-version-specific-runtime-libs \
+ --with-gxx-include-dir=${STDCXX_INCDIR} \
+ --with-local-prefix=${LOC}/local \
+ ${myconf} || die
+
+ touch ${S}/gcc/c-gperf.h
+
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
+
+ einfo "Compiling libffi..."
+ S="${WORKDIR}/build" \
+ emake all-target-libffi \
+ LIBPATH="${LIBPATH}" \
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
+}
+
+src_install() {
+ local x=
+
+ # Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ continue
+ fi
+ done
+ # Remove generated headers, as they can cause things to break
+ # (ncurses, openssl, etc).
+ for x in `find ${WORKDIR}/build/gcc/include/ -name '*.h'`
+ do
+ if grep -q 'It has been auto-edited by fixincludes from' ${x}
+ then
+ rm -f ${x}
+ fi
+ done
+
+ einfo "Installing libffi..."
+ # Do the 'make install' from the build directory
+ cd ${WORKDIR}/build
+ S="${WORKDIR}/build" \
+ make prefix=${LOC} \
+ bindir=${BINPATH} \
+ includedir=${LIBPATH}/include \
+ datadir=${DATAPATH} \
+ mandir=${DATAPATH}/man \
+ infodir=${DATAPATH}/info \
+ DESTDIR="${D}" \
+ LIBPATH="${LIBPATH}" \
+ install-target-libffi || die
+
+ # we want the headers...
+ mkdir -p ${D}/${LOC}/include/${PN}
+ mv ${D}/${LOC}/lib/gcc-lib/${CCHOST}/${PV}/include/* ${D}/${LOC}/include/${PN}
+ # remove now useless directory...
+ rm -Rf ${D}/${LOC}/lib/gcc-lib/
+ # we'll move this into a directory we can put at the end of ld.so.conf
+ # other than the normal versioned directory, so that it doesnt conflict
+ # with gcc 3.3.3
+ mkdir -p ${D}/${LOC}/lib/${PN}
+ mv ${D}/${LOC}/lib/* ${D}/${LOC}/lib/${PN}
+
+ mkdir -p ${D}/etc/env.d/
+ echo "LDPATH=\"${LOC}/lib/${PN}\"" >> ${D}/etc/env.d/99libffi
+ echo "CPATH=\"${LOC}/include/${PN}\"" >> ${D}/etc/env.d/99libffi
+}
+