summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-05 10:50:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-05 10:50:56 +0000
commit3fcd8b5c37d6f3060f6ecd6196f101589afbe161 (patch)
tree41721b11a3d27abb3ab4c51c5d29ee3ef2e30750 /dev-libs/yaz
parentfix bug #34605. no response from postgres herd so fixing it myself (diff)
downloadhistorical-3fcd8b5c37d6f3060f6ecd6196f101589afbe161.tar.gz
historical-3fcd8b5c37d6f3060f6ecd6196f101589afbe161.tar.bz2
historical-3fcd8b5c37d6f3060f6ecd6196f101589afbe161.zip
initial commit. required as a dep for bug #36693.
Diffstat (limited to 'dev-libs/yaz')
-rw-r--r--dev-libs/yaz/ChangeLog9
-rw-r--r--dev-libs/yaz/Manifest3
-rw-r--r--dev-libs/yaz/files/digest-yaz-2.0.81
-rw-r--r--dev-libs/yaz/yaz-2.0.8.ebuild35
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/yaz/ChangeLog b/dev-libs/yaz/ChangeLog
new file mode 100644
index 000000000000..366825b152c1
--- /dev/null
+++ b/dev-libs/yaz/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-libs/yaz
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.1 2004/01/05 10:50:56 robbat2 Exp $
+
+*yaz-2.0.8 (05 Jan 2004)
+
+ 05 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> yaz-2.0.8.ebuild:
+ initial commit. required as a dep for bug #36693.
+
diff --git a/dev-libs/yaz/Manifest b/dev-libs/yaz/Manifest
new file mode 100644
index 000000000000..c344b60b8477
--- /dev/null
+++ b/dev-libs/yaz/Manifest
@@ -0,0 +1,3 @@
+MD5 72d9a2f8f1a176451a93208a91c22f21 yaz-2.0.8.ebuild 943
+MD5 b098f58401144531fad7ae8345d83c95 ChangeLog 356
+MD5 2c601b2958127cb7cfb70ec3fb718177 files/digest-yaz-2.0.8 62
diff --git a/dev-libs/yaz/files/digest-yaz-2.0.8 b/dev-libs/yaz/files/digest-yaz-2.0.8
new file mode 100644
index 000000000000..8056622e3185
--- /dev/null
+++ b/dev-libs/yaz/files/digest-yaz-2.0.8
@@ -0,0 +1 @@
+MD5 6d4c5e8b44637fa7b98c51c0bdfda9fd yaz-2.0.8.tar.gz 1213161
diff --git a/dev-libs/yaz/yaz-2.0.8.ebuild b/dev-libs/yaz/yaz-2.0.8.ebuild
new file mode 100644
index 000000000000..47345f4d45b7
--- /dev/null
+++ b/dev-libs/yaz/yaz-2.0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-2.0.8.ebuild,v 1.1 2004/01/05 10:50:56 robbat2 Exp $
+
+DESCRIPTION="YAZ is a C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/${PN}"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+LICENSE="YAZ"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcpd"
+RDEPEND="dev-libs/libxml2
+ dev-libs/openssl
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd
+ app-text/docbook-dsssl-stylesheets
+ app-text/docbook-xsl-stylesheets
+ dev-util/pkgconfig"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myopts
+ myopts="${myopts} `use_enable tcpd tcpd /usr`"
+
+ econf ${myopts} \
+ --enable-shared \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}