summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-04 18:29:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-04 18:29:00 +0000
commit679a388b822ff8f6fec2fba14cd2f56ed709c5c3 (patch)
treec8ff6436f17462387a2af8893531b2ef72dcff62 /dev-libs/tre
parentVersion bump by Pavel. (diff)
downloadhistorical-679a388b822ff8f6fec2fba14cd2f56ed709c5c3.tar.gz
historical-679a388b822ff8f6fec2fba14cd2f56ed709c5c3.tar.bz2
historical-679a388b822ff8f6fec2fba14cd2f56ed709c5c3.zip
Restrict Jython ABIs. Call some functions only with USE="python".
Package-Manager: portage-2.2.0_alpha26_p6/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/tre')
-rw-r--r--dev-libs/tre/Manifest12
-rw-r--r--dev-libs/tre/tre-0.8.0.ebuild14
2 files changed, 13 insertions, 13 deletions
diff --git a/dev-libs/tre/Manifest b/dev-libs/tre/Manifest
index 836bc4c7a44c..10448eb909fd 100644
--- a/dev-libs/tre/Manifest
+++ b/dev-libs/tre/Manifest
@@ -1,17 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
AUX 0.8.0-python.patch 1168 RMD160 73453c97aa6cccaac220d377abe232999b39b043 SHA1 a3e921e0e1f00ff8874fbff9b22afd8c6a67da0d SHA256 acb6cd7f36f37828c829efc8818f1484dc69ddbbd98a8b31ae3003ea425d94c7
DIST tre-0.7.5.tar.bz2 396346 RMD160 240c106caef50097a9bfbad94f5cc002a9b4b497 SHA1 16b860479341f3179ef987765aacda9e2803f7bb SHA256 030f25e6e4c1714df013105494bc5e24b3e0acc65887158a52a03efd8e0759aa
DIST tre-0.8.0.tar.bz2 380714 RMD160 8031cc0c421dd0f473b4c98f49aef9805fa65b64 SHA1 a41692e64b40ebae3cffe83931ddbf8420a10ae3 SHA256 8dc642c2cde02b2dac6802cdbe2cda201daf79c4ebcbb3ea133915edf1636658
EBUILD tre-0.7.5.ebuild 1246 RMD160 3d09de2a1f7eac7d1c18321512cbac86b62a27d2 SHA1 37305c84758e7f44bbab31e976a6aee7f2ced4c5 SHA256 8ffdee595b0383efdbffac81bd152c6acb87a8c59690ed789db702725e1dd4bf
-EBUILD tre-0.8.0.ebuild 1795 RMD160 1a00a3f4a3736ff4f6857755af9276f13aa0fb3a SHA1 497112ddd4060eaacfe1e2c71f4998fe73150694 SHA256 5e3646f007517ac9a767e6b4774bba80df8c69ed4732b9da1b9c53840fd95e91
+EBUILD tre-0.8.0.ebuild 1950 RMD160 598c4965ab8a4037c5441076dc5ca56a2d770cb1 SHA1 748fc551995230337bf663a7643b87006abd5929 SHA256 24c275db5067b78cf46b0f9b017fb0bc209d1909aa17eb088eb640f00378b04a
MISC ChangeLog 6679 RMD160 3c3b44b7d93570bee996325f718db202a9d95725 SHA1 4bb28a9c6941cd1d6770bbdc914166bf951d26eb SHA256 da4f3dd9ff1390bccdc25900e459ab60c6d41c3206f7e6fda38276f7bd14ea87
MISC metadata.xml 166 RMD160 122e578c52fe3661ff8b8f1f574d8651916e3bf5 SHA1 5eb96c1efa4708676adcd6cad061b22caf9bdfe5 SHA256 064eb80cc86913e2a47d1088f1b0ebd5b64b5dab1c73d38b8501cd77891cfbbf
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.17 (GNU/Linux)
-
-iEYEARECAAYFAk1xK9oACgkQgAnW8HDreRb+HwCfeXsVGyT9yP8XPyo5qrCbxC8B
-PHcAnR1fophYIXRZGo5zvTLV23PsGNvk
-=rS30
------END PGP SIGNATURE-----
diff --git a/dev-libs/tre/tre-0.8.0.ebuild b/dev-libs/tre/tre-0.8.0.ebuild
index cb5f11c02f71..972d195ca7c4 100644
--- a/dev-libs/tre/tre-0.8.0.ebuild
+++ b/dev-libs/tre/tre-0.8.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tre/tre-0.8.0.ebuild,v 1.13 2011/03/04 18:13:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tre/tre-0.8.0.ebuild,v 1.14 2011/03/04 18:29:00 arfrever Exp $
EAPI=2
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils eutils
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
DISTUTILS_SETUP_FILES=("python/setup.py")
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PV}-python.patch
}
@@ -71,4 +75,10 @@ pkg_postinst() {
ewarn "If this causes any unforeseen incompatibilities please file a bug"
ewarn "on http://bugs.gentoo.org."
echo
+
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
}