summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-01-30 11:51:07 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-01-30 11:51:07 +0000
commit1f0619524af6e1cc9a9f5a31b2849a582de766a9 (patch)
treee28434de15584cb28669122f7bd1830abe1bc3b7 /dev-libs/qof/qof-0.7.4.ebuild
parentstable x86, bug 207634 (diff)
downloadhistorical-1f0619524af6e1cc9a9f5a31b2849a582de766a9.tar.gz
historical-1f0619524af6e1cc9a9f5a31b2849a582de766a9.tar.bz2
historical-1f0619524af6e1cc9a9f5a31b2849a582de766a9.zip
version bump, add dependency on SQLite 2 versions
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-libs/qof/qof-0.7.4.ebuild')
-rw-r--r--dev-libs/qof/qof-0.7.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/qof/qof-0.7.4.ebuild b/dev-libs/qof/qof-0.7.4.ebuild
new file mode 100644
index 000000000000..2b3d7727fea0
--- /dev/null
+++ b/dev-libs/qof/qof-0.7.4.ebuild
@@ -0,0 +1,35 @@
+ # Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.7.4.ebuild,v 1.1 2008/01/30 11:51:06 opfer Exp $
+
+inherit eutils
+
+DESCRIPTION="A Query Object Framework"
+HOMEPAGE="http://qof.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qof/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+DEPEND="gnome-extra/libgda
+ =dev-db/sqlite-2*"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-remove_spurious_CFLAGS.patch"
+}
+
+src_compile() {
+ econf || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+}