summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-08 21:12:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-08 21:12:22 +0000
commit0c159fbe60ad15cc99d239a5ca8da0c241082038 (patch)
tree513a86fdfabd86395509d5479502510107649d3e /dev-libs/openssl/openssl-0.9.7c-r1.ebuild
parentstable on alpha and ia64 (diff)
downloadhistorical-0c159fbe60ad15cc99d239a5ca8da0c241082038.tar.gz
historical-0c159fbe60ad15cc99d239a5ca8da0c241082038.tar.bz2
historical-0c159fbe60ad15cc99d239a5ca8da0c241082038.zip
fix bug #37600
Diffstat (limited to 'dev-libs/openssl/openssl-0.9.7c-r1.ebuild')
-rw-r--r--dev-libs/openssl/openssl-0.9.7c-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
index f0a2ccf16f91..ba27484f8dd7 100644
--- a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.10 2004/01/03 22:17:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.11 2004/01/08 21:12:22 robbat2 Exp $
inherit eutils flag-o-matic gcc
@@ -48,7 +48,7 @@ src_unpack() {
if [ "$(gcc-version)" == "3.3" ] || [ "$(gcc-version)" == "3.2" ] ; then
filter-flags -fprefetch-loop-arrays
fi
- sed -i -r -e "s/-O[23]/$CFLAGS/" -e "s/-fomit-frame-pointer//" -e "s/-mcpu=[a-z0-9]+//" -e "s/-m486//" Configure
+ sed -i -r -e "s|-O[23]|$CFLAGS|" -e "s/-fomit-frame-pointer//" -e "s/-mcpu=[-a-z0-9]+//" -e "s/-m486//" Configure
# openssl-0.9.6
test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
@@ -75,7 +75,7 @@ src_unpack() {
sed -i -e 's/parisc-\*-linux2/parisc\*-\*-linux2/' config
esac
- sed -i -e "s/-O[23]/$CFLAGS/" -e "s/-fomit-frame-pointer//" -e -r "s/\-mcpu=[a-z0-9]+//" -e "s/-m486//" Configure
+ sed -i -e "s|-O[23]|$CFLAGS|" -e "s/-fomit-frame-pointer//" -e -r "s/\-mcpu=[-a-z0-9]+//" -e "s/-m486//" Configure
}
}