summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-07-03 16:51:12 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-07-03 16:51:12 +0000
commitfd444b239c0b4a856cd5d8e7512f411e6bc2f4d9 (patch)
treeeeddd5cd55a72de3016de579ffcc67d8b057362b /dev-libs/openobex
parentMark stable on x86. (diff)
downloadhistorical-fd444b239c0b4a856cd5d8e7512f411e6bc2f4d9.tar.gz
historical-fd444b239c0b4a856cd5d8e7512f411e6bc2f4d9.tar.bz2
historical-fd444b239c0b4a856cd5d8e7512f411e6bc2f4d9.zip
Added patch to produce shared objects as well, necessary for multisync on amd64.
Diffstat (limited to 'dev-libs/openobex')
-rw-r--r--dev-libs/openobex/ChangeLog40
-rw-r--r--dev-libs/openobex/files/openobex-1.0.1-shared-object.patch55
-rw-r--r--dev-libs/openobex/openobex-1.0.1.ebuild11
3 files changed, 71 insertions, 35 deletions
diff --git a/dev-libs/openobex/ChangeLog b/dev-libs/openobex/ChangeLog
index f0d50548d723..6276ffab74ce 100644
--- a/dev-libs/openobex/ChangeLog
+++ b/dev-libs/openobex/ChangeLog
@@ -1,38 +1,10 @@
# ChangeLog for dev-libs/openobex
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/ChangeLog,v 1.12 2004/06/24 23:30:30 agriffis Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/ChangeLog,v 1.13 2004/07/03 16:51:11 kugelfang Exp $
- 18 Apr 2004; Jason Wever <weeve@gentoo.org> openobex-1.0.0.ebuild:
- Stable on sparc.
+*openobex-1.0.1 (03 Jul 2004)
- 14 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> openobex-0.9.8.ebuild,
- openobex-1.0.0.ebuild, openobex-1.0.1.ebuild:
- Don't assign default to S; header fix
+ 03 Jul 2004; Danny van Dyk <kugelfang@gentoo.org>
+ +files/openobex-1.0.1-shared-object.patch, openobex-1.0.1.ebuild:
+ Added a patch to produce a shared object as well.
- 15 Feb 2004; David Holm <dholm@gentoo.org> openobex-1.0.1.ebuild:
- Added to ~ppc.
-
- 12 Feb 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
- Adding ~sparc (works with some kernels, see bug #39710)
-
- 04 Nov 2003; Brandy Westcott brandy@gentoo.org openobex-1.0.1.ebuild:
- Tidy up the ebuild: add LGPL-2.1 to LICENSE; install ChangeLog in docs;
- compile using CFLAGS.
-
-*openobex-1.0.1 (01 Oct 2003)
-
- 01 Oct 2003; Markus Nigbur <pyrania@gentoo.org> openobex-1.0.1.ebuild:
- Bumped, thanks to w.haas@xover.htu.tuwien.ac.at (bug #30081)
-
-*openobex-1.0.0 (12 Mar 2003)
-
- 12 Mar 2003; George Shapovalov <george@gentoo.org> openobex-1.0.0.ebuild :
- new version (#16059), thanks to Patrik Kullman <patrik.kullman@netsafe.se> for submission
-
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
-*openobex-0.9.8 (14 may 2002)
-
- 14 May 2002; G.Shapovalov <george@gentoo.org> openobex-0.9.8.ebuild,files/digest-openobex-0.9.8 :
-
- initial release
diff --git a/dev-libs/openobex/files/openobex-1.0.1-shared-object.patch b/dev-libs/openobex/files/openobex-1.0.1-shared-object.patch
new file mode 100644
index 000000000000..9b909489b858
--- /dev/null
+++ b/dev-libs/openobex/files/openobex-1.0.1-shared-object.patch
@@ -0,0 +1,55 @@
+--- src/Makefile.in.orig 2004-07-03 17:49:53.351333976 +0200
++++ src/Makefile.in 2004-07-03 17:51:00.034196640 +0200
+@@ -90,7 +90,7 @@
+
+ include_HEADERS = obex.h obex_const.h
+
+-lib_LTLIBRARIES = libopenobex.la
++lib_LTLIBRARIES = libopenobex.la libopenobex.so
+
+ libopenobex_la_SOURCES = obex.c obex_main.c obex_main.h obex_connect.c obex_connect.h obex_header.c obex_header.h obex_object.c obex_object.h obex_transport.c obex_transport.h obex_server.c obex_server.h obex_client.c obex_client.h irobex.c irobex.h inobex.c inobex.h btobex.c btobex.h netbuf.c netbuf.h irda.h irda_wrap.h
+
+@@ -132,7 +132,7 @@
+ SOURCES = $(libopenobex_la_SOURCES)
+ OBJECTS = $(libopenobex_la_OBJECTS)
+
+-all: all-redirect
++all: shared-dir all-redirect
+ .SUFFIXES:
+ .SUFFIXES: .S .c .lo .o .obj .s
+ $(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
+@@ -142,6 +142,8 @@
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
++shared-dir:
++ mkdir -p shared
+
+ mostlyclean-libLTLIBRARIES:
+
+@@ -170,6 +172,7 @@
+
+ .c.o:
+ $(COMPILE) -c $<
++ $(COMPILE) -fPIC -o shared/$(basename $<).o -c $<
+
+ # FIXME: We should only use cygpath when building on Windows,
+ # and only if it is available.
+@@ -195,6 +198,7 @@
+
+ .c.lo:
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
++ $(LIBTOOL) --mode=compile $(COMPILE) -fPIC -o shared/$(basename $<).lo -c $<
+
+ .s.lo:
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
+@@ -215,6 +219,9 @@
+ libopenobex.la: $(libopenobex_la_OBJECTS) $(libopenobex_la_DEPENDENCIES)
+ $(LINK) -rpath $(libdir) $(libopenobex_la_LDFLAGS) $(libopenobex_la_OBJECTS) $(libopenobex_la_LIBADD) $(LIBS)
+
++libopenobex.so:
++ $(LINK) -rpath $(libdir) -shared $(libopenobex_la_LDFLAGS) shared/*.o
++
+ install-includeHEADERS: $(include_HEADERS)
+ @$(NORMAL_INSTALL)
+ $(mkinstalldirs) $(DESTDIR)$(includedir)
diff --git a/dev-libs/openobex/openobex-1.0.1.ebuild b/dev-libs/openobex/openobex-1.0.1.ebuild
index 64009ab004d1..32e3783215e6 100644
--- a/dev-libs/openobex/openobex-1.0.1.ebuild
+++ b/dev-libs/openobex/openobex-1.0.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/openobex-1.0.1.ebuild,v 1.7 2004/06/24 23:30:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/openobex-1.0.1.ebuild,v 1.8 2004/07/03 16:51:11 kugelfang Exp $
+
+inherit eutils
IUSE=""
@@ -14,6 +16,13 @@ KEYWORDS="~x86 ~sparc ~ppc ~amd64"
DEPEND=">=dev-libs/glib-1.2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ pwd
+ epatch ${FILESDIR}/${P}-shared-object.patch
+}
+
src_compile() {
econf || die
emake CFLAGS="${CFLAGS}" || die