summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-08-12 08:37:33 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-08-12 08:37:33 +0000
commite01051019098657042f2fdc7f94b540bfbfe3a45 (patch)
tree0c027eea79b6e378526d956cf8a0c94123482649 /dev-libs/log4c
parentbug #51113, add warning that flipping the PAM use flag is dangerous. (diff)
downloadhistorical-e01051019098657042f2fdc7f94b540bfbfe3a45.tar.gz
historical-e01051019098657042f2fdc7f94b540bfbfe3a45.tar.bz2
historical-e01051019098657042f2fdc7f94b540bfbfe3a45.zip
bug #60061 fixed access violation. Fixed to compile with gcc 3.4
Diffstat (limited to 'dev-libs/log4c')
-rw-r--r--dev-libs/log4c/ChangeLog8
-rw-r--r--dev-libs/log4c/Manifest14
-rw-r--r--dev-libs/log4c/files/log4c_1.0.11_test.patch17
-rw-r--r--dev-libs/log4c/files/makefile.doc.am.patch11
-rw-r--r--dev-libs/log4c/files/makefile.doc.in.patch4
-rw-r--r--dev-libs/log4c/log4c-1.0.11.ebuild6
6 files changed, 49 insertions, 11 deletions
diff --git a/dev-libs/log4c/ChangeLog b/dev-libs/log4c/ChangeLog
index 663f52f50c44..60f00a4b1708 100644
--- a/dev-libs/log4c/ChangeLog
+++ b/dev-libs/log4c/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/log4c
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.13 2004/08/11 13:50:18 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.14 2004/08/12 08:37:33 dragonheart Exp $
+
+ 12 Aug 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/log4c_1.0.11_test.patch, +files/makefile.doc.am.patch,
+ files/makefile.doc.in.patch, log4c-1.0.11.ebuild:
+ fixed access violation. Fixed to compile with gcc 3.4 thanks to patch by Olaf
+ Freyer <aaron@cs.tu-berlin.de> in bug #60061
11 Aug 2004; Daniel Black <dragonheart@gentoo.org>
+files/makefile.doc.in.patch, log4c-1.0.11.ebuild:
diff --git a/dev-libs/log4c/Manifest b/dev-libs/log4c/Manifest
index cfb1ee398d57..f10e1fbe3f16 100644
--- a/dev-libs/log4c/Manifest
+++ b/dev-libs/log4c/Manifest
@@ -1,20 +1,22 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 f4c276fd0ae1b375ebc4912a7cc972dc ChangeLog 1747
+MD5 8645bc6ce99fa7042b081ad8eae59406 ChangeLog 2044
MD5 947886de3129e5cdef1c72ab2b2e2e8e log4c-1.0.6-r1.ebuild 1018
MD5 ef3ee7cb4b111c01065c297b1a00dc5a log4c-1.0.6.ebuild 1027
-MD5 de7f54099f7dd003d0e6809116db2e31 log4c-1.0.11.ebuild 1330
+MD5 fab9d522391846ec455e030255bf8851 log4c-1.0.11.ebuild 1467
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 fcc031971422d4234f3de52e34fcf256 files/digest-log4c-1.0.6 63
MD5 fcc031971422d4234f3de52e34fcf256 files/digest-log4c-1.0.6-r1 63
MD5 1f0fac7267c1cff0be0ee973376e272e files/digest-log4c-1.0.11 64
MD5 37d8d5f4cc1cf6074bcd576c3c294b99 files/configure.in.patch 854
-MD5 89a726a759f8fef50c60987274892c0a files/makefile.doc.in.patch 378
+MD5 028648da7dc4850b5dbc3ec0469eba94 files/makefile.doc.in.patch 352
+MD5 81e6117c525d7118531b1868a13738fc files/log4c_1.0.11_test.patch 464
+MD5 1902a2badd2a965f9e4072f4b6e7adfe files/makefile.doc.am.patch 350
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
-iD8DBQFBGiG3mdTrptrqvGERAv+fAJ452uqjF1LF1/BxmfEqasxKKa29PQCfTKcD
-JO9W+vaII+ITCoCul9XCOdk=
-=XdrF
+iD8DBQFBGyjtmdTrptrqvGERAqYMAJoDnSKGL7q5QWAyO34ZfEOx1SMmXgCdHAPM
+1G8u8lqjvKd4d+cJHJSMMLw=
+=qKpI
-----END PGP SIGNATURE-----
diff --git a/dev-libs/log4c/files/log4c_1.0.11_test.patch b/dev-libs/log4c/files/log4c_1.0.11_test.patch
new file mode 100644
index 000000000000..247198b2d727
--- /dev/null
+++ b/dev-libs/log4c/files/log4c_1.0.11_test.patch
@@ -0,0 +1,17 @@
+--- tests/log4c/test_category.c.orig 2004-08-12 16:50:32.986161768 +0930
++++ tests/log4c/test_category.c 2004-08-12 16:51:06.102127376 +0930
+@@ -122,11 +122,11 @@
+ {
+ log4c_category_set_priority(root, LOG4C_PRIORITY_TRACE);
+
+- foo(root, trace);
++ foo(root, info);
+ foo(root, warn);
+- foo(sub1, trace);
++ foo(sub1, info);
+ foo(sub1, warn);
+- foo(sun1sub2, trace);
++ foo(sun1sub2, info);
+ foo(sun1sub2, warn);
+ return 1;
+ }
diff --git a/dev-libs/log4c/files/makefile.doc.am.patch b/dev-libs/log4c/files/makefile.doc.am.patch
new file mode 100644
index 000000000000..e6b1069388f0
--- /dev/null
+++ b/dev-libs/log4c/files/makefile.doc.am.patch
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig 2004-08-12 17:37:15.800069288 +0930
++++ doc/Makefile.am 2004-08-12 17:37:33.802332528 +0930
+@@ -30,7 +30,7 @@
+ echo "$(INSTALL_DATA) $$i $(DESTDIR)$(docdir)"; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(docdir); \
+ done
+- cp -r html $(docdir)
++ cp -r html $(DESTDIR)$(docdir)
+
+ uninstall-local:
+ @for i in ./man/man3/*.3; do \
diff --git a/dev-libs/log4c/files/makefile.doc.in.patch b/dev-libs/log4c/files/makefile.doc.in.patch
index fd65f46e5984..45f5ac3cd12a 100644
--- a/dev-libs/log4c/files/makefile.doc.in.patch
+++ b/dev-libs/log4c/files/makefile.doc.in.patch
@@ -1,5 +1,5 @@
---- log4c-1.0.11/doc/Makefile.in.orig 2004-08-11 22:24:32.497489472 +0930
-+++ log4c-1.0.11/doc/Makefile.in 2004-08-11 22:24:59.267419824 +0930
+--- doc/Makefile.in.orig 2003-09-13 06:31:33.000000000 +0930
++++ doc/Makefile.in 2004-08-12 16:53:59.487768752 +0930
@@ -254,7 +254,7 @@
echo "$(INSTALL_DATA) $$i $(DESTDIR)$(docdir)"; \
$(INSTALL_DATA) $$i $(DESTDIR)$(docdir); \
diff --git a/dev-libs/log4c/log4c-1.0.11.ebuild b/dev-libs/log4c/log4c-1.0.11.ebuild
index f197792f7546..cadc2ff489c4 100644
--- a/dev-libs/log4c/log4c-1.0.11.ebuild
+++ b/dev-libs/log4c/log4c-1.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.11.ebuild,v 1.2 2004/08/11 13:50:18 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.11.ebuild,v 1.3 2004/08/12 08:37:33 dragonheart Exp $
inherit eutils
@@ -21,9 +21,11 @@ DEPEND="doc? ( >=app-doc/doxygen-1.2.15
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/makefile.doc.in.patch || die "failed to patch"
cd ${S}
+ epatch ${FILESDIR}/makefile.doc.am.patch || die "failed to patch"
+ epatch ${FILESDIR}/makefile.doc.in.patch || die "failed to patch"
epatch ${FILESDIR}/configure.in.patch || die "failed to patch"
+ epatch ${FILESDIR}/log4c_1.0.11_test.patch || die "failed to patch"
}
src_compile() {