summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-09-14 06:41:11 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-09-14 06:41:11 +0000
commit30c487ca81726d0c9c0d4f0a0c4ab5fa80f85c39 (patch)
tree7b1baabe6914d920343e22cf744e1c90bc43309e /dev-libs/libxml2/libxml2-2.6.22.ebuild
parentMark 1.2.10-r1 stable on alpha (diff)
downloadhistorical-30c487ca81726d0c9c0d4f0a0c4ab5fa80f85c39.tar.gz
historical-30c487ca81726d0c9c0d4f0a0c4ab5fa80f85c39.tar.bz2
historical-30c487ca81726d0c9c0d4f0a0c4ab5fa80f85c39.zip
New release: 2.6.22
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.6.22.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.6.22.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/dev-libs/libxml2/libxml2-2.6.22.ebuild b/dev-libs/libxml2/libxml2-2.6.22.ebuild
new file mode 100644
index 000000000000..d44c731f21be
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.22.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.22.ebuild,v 1.1 2005/09/14 06:41:11 leonardop Exp $
+
+inherit libtool gnome.org flag-o-matic eutils
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug doc ipv6 python readline static"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ unpack "${A}"
+
+ epunt_cxx
+}
+
+src_compile() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable static) \
+ $(use_enable ipv6)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf || die "Configuration failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find ${S} -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die "Copilation failed"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO*
+
+ if ! use doc; then
+ rm -rf ${D}/usr/share/gtk-doc
+ rm -rf ${D}/usr/share/doc/${P}/html
+ fi
+}
+
+pkg_postinst() {
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}/etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}/etc/xml" ] || mkdir -p "${ROOT}/etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+}