summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:05:20 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:05:20 +0000
commitc5e53db0be2e3534202f4ca04a105b0605cb64fd (patch)
tree6b04ee29b8b080b619e357eb61291dd2f9d8398d /dev-libs/libpcre
parentA=-fix, try->die,... (diff)
downloadhistorical-c5e53db0be2e3534202f4ca04a105b0605cb64fd.tar.gz
historical-c5e53db0be2e3534202f4ca04a105b0605cb64fd.tar.bz2
historical-c5e53db0be2e3534202f4ca04a105b0605cb64fd.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/libpcre-3.4-r1.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/dev-libs/libpcre/libpcre-3.4-r1.ebuild b/dev-libs/libpcre/libpcre-3.4-r1.ebuild
index 31d4eab621ab..38a67dea2947 100644
--- a/dev-libs/libpcre/libpcre-3.4-r1.ebuild
+++ b/dev-libs/libpcre/libpcre-3.4-r1.ebuild
@@ -1,32 +1,28 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-3.4-r1.ebuild,v 1.1 2001/03/06 06:20:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-3.4-r1.ebuild,v 1.2 2001/11/10 12:05:20 hallski Exp $
-A=pcre-${PV}.tar.gz
S=${WORKDIR}/pcre-${PV}
DESCRIPTION="Perl compatible regular expressions"
-SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/"${A}
+SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.gz"
DEPEND="virtual/glibc"
src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ assert
- try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- try make
+ make || die
}
src_install() {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
-
- dodoc AUTHORS COPYING ChangeLog LICENCE NEWS NON-UNIX-USE README
- dodoc doc/*.txt doc/Tech.Notes
- docinto html
- dodoc doc/*.html
-
+ dodoc AUTHORS COPYING ChangeLog LICENCE NEWS NON-UNIX-USE README
+ dodoc doc/*.txt doc/Tech.Notes
+ docinto html
+ dodoc doc/*.html
}
-
-
-
-