summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:02:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:02:39 +0000
commita0f02d43a548c0278d24cd6699fa2f741d98e4b0 (patch)
tree915e6f7c498d11e5f9a477c67cf5b4ad5d8dd98f /dev-libs/libelf
parentJaxp was a repack of various apache projects under a very restrictive Sun lic... (diff)
downloadhistorical-a0f02d43a548c0278d24cd6699fa2f741d98e4b0.tar.gz
historical-a0f02d43a548c0278d24cd6699fa2f741d98e4b0.tar.bz2
historical-a0f02d43a548c0278d24cd6699fa2f741d98e4b0.zip
repoman'd
Diffstat (limited to 'dev-libs/libelf')
-rw-r--r--dev-libs/libelf/libelf-0.7.0.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-libs/libelf/libelf-0.7.0.ebuild b/dev-libs/libelf/libelf-0.7.0.ebuild
index 9eff37ed2f6e..fdfb4b3145d2 100644
--- a/dev-libs/libelf/libelf-0.7.0.ebuild
+++ b/dev-libs/libelf/libelf-0.7.0.ebuild
@@ -1,32 +1,33 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.7.0.ebuild,v 1.3 2002/07/11 06:30:21 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.7.0.ebuild,v 1.4 2002/08/01 18:02:36 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A ELF object file access library"
SRC_URI="http://www.stud.uni-hannover.de/~michael/software/libelf-0.7.0.tar.gz"
HOMEPAGE="http://www.stud.uni-hannover.de/~michael/software/"
-DEPEND="virtual/glibc nls?
- ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+
+DEPEND="nls? ( sys-devel/gettext )"
src_compile() {
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
+ local myconf
+
+ use nls || myconf="--disable-nls"
- ./configure --prefix=/usr \
- --host=${CHOST} \
+ econf \
--enable-shared \
${myconf} || die
- emake || die
+ emake || die
}
src_install () {
- make prefix=${D}/usr \
+ make prefix=${D}/usr \
install || die
- dodoc COYPING.LIB CHangeLog VERSION README
+ dodoc COYPING.LIB CHangeLog VERSION README
}
-