summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2006-01-20 11:03:48 +0000
committerMartin Schlemmer <azarah@gentoo.org>2006-01-20 11:03:48 +0000
commitac3ff10ef4eaa576e7a05bdd99018f5a1f50c1bf (patch)
tree148b367d8e0ad6bb54c4e98055809c2c03a471dd /dev-libs/klibc
parentPruned old version - keep pre13-r1 for a little while though. (diff)
downloadhistorical-ac3ff10ef4eaa576e7a05bdd99018f5a1f50c1bf.tar.gz
historical-ac3ff10ef4eaa576e7a05bdd99018f5a1f50c1bf.tar.bz2
historical-ac3ff10ef4eaa576e7a05bdd99018f5a1f50c1bf.zip
New version.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-libs/klibc')
-rw-r--r--dev-libs/klibc/ChangeLog7
-rw-r--r--dev-libs/klibc/Manifest14
-rw-r--r--dev-libs/klibc/files/digest-klibc-1.1.161
-rw-r--r--dev-libs/klibc/klibc-1.1.16.ebuild155
4 files changed, 175 insertions, 2 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index 1c4ed448a09a..53cd81488b0b 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.14 2006/01/02 08:04:33 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.15 2006/01/20 11:03:48 azarah Exp $
+
+*klibc-1.1.16 (20 Jan 2006)
+
+ 20 Jan 2006; Martin Schlemmer <azarah@gentoo.org> +klibc-1.1.16.ebuild:
+ New version.
02 Jan 2006; Joshua Kinard <kumba@gentoo.org> klibc-1.1.ebuild:
Bump to stable for getdvhoff on mips.
diff --git a/dev-libs/klibc/Manifest b/dev-libs/klibc/Manifest
index 6324e28a0d63..79d06103758e 100644
--- a/dev-libs/klibc/Manifest
+++ b/dev-libs/klibc/Manifest
@@ -1,11 +1,23 @@
-MD5 7742e1164ab350c0f859c660d7f5bfa3 ChangeLog 2377
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 b1228c26e091dddfc967df339a8f9523 ChangeLog 2497
MD5 5f74818fe6743d6f26cd199480a6d4ea files/digest-klibc-1.0.14-r1 65
MD5 9f7934fa62dac32c7a1f7fb7f3c1eff6 files/digest-klibc-1.1 62
MD5 40dd929bc6cde977c4e309596afcd6fe files/digest-klibc-1.1.1 64
+MD5 0e893c37516ea180bbbdcb60081bbec8 files/digest-klibc-1.1.16 65
MD5 4b098438d57b0f7ad9f16d534fb98eb4 files/klibc-1.0.14-nostdlib.patch 460
MD5 d771e07746a2d5b2bdac366cd992c885 files/klibc-1.1-mips32.patch 670
MD5 790a9f0a9a74e6eac6c6c1dbde2a94b6 files/klibc.m4 3619
MD5 87eac36868c96b295f5b4b631a505db9 klibc-1.0.14-r1.ebuild 4123
MD5 b6ca70e7577c32b484f33e067d12cd94 klibc-1.1.1.ebuild 4174
+MD5 db2944faf1aff0eee8c237f4bb5f3940 klibc-1.1.16.ebuild 4090
MD5 8aeec3288335b9aa00b16bf2c0ae45b6 klibc-1.1.ebuild 4165
MD5 b612d343db3c54560665171eb7db245c metadata.xml 223
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFD0MPP1ZcsMnZjRyIRAnnDAJ9we6Iuf2s4loE2Rng2zaYcqhYMtQCfS6K8
+IzveFWuZZ1Nhh3wuNgvQzT8=
+=FEEM
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/klibc/files/digest-klibc-1.1.16 b/dev-libs/klibc/files/digest-klibc-1.1.16
new file mode 100644
index 000000000000..da1d43b9af24
--- /dev/null
+++ b/dev-libs/klibc/files/digest-klibc-1.1.16
@@ -0,0 +1 @@
+MD5 80b85e84306695ed61049720008dd409 klibc-1.1.16.tar.bz2 451284
diff --git a/dev-libs/klibc/klibc-1.1.16.ebuild b/dev-libs/klibc/klibc-1.1.16.ebuild
new file mode 100644
index 000000000000..fe5a25bbd2de
--- /dev/null
+++ b/dev-libs/klibc/klibc-1.1.16.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.1.16.ebuild,v 1.1 2006/01/20 11:03:48 azarah Exp $
+
+inherit eutils linux-mod
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="A minimal libc subset for use with initramfs."
+HOMEPAGE="http://www.zytor.com/mailman/listinfo/klibc"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/libs/klibc/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/libs/klibc/Stable/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/libs/klibc/Testing/${P}.tar.bz2"
+LICENSE="|| ( GPL-2 LGPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86 ~mips"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND="dev-lang/perl
+ virtual/linux-sources"
+RDEPEND="dev-lang/perl"
+
+if [[ ${CTARGET} != ${CHOST} ]] ; then
+ SLOT="${CTARGET}"
+else
+ SLOT="0"
+fi
+
+is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
+
+guess_arch() {
+ local x
+ local host=$(echo "${CTARGET%%-*}" | sed -e 's/i.86/i386/' \
+ -e 's/sun4u/sparc64/' \
+ -e 's/arm.*/arm/' \
+ -e 's/sa110/arm/' \
+ -e 's/powerpc/ppc/')
+
+ # Sort reverse so that we will get ppc64 before ppc, etc
+ for x in $(ls -1 "${S}/include/arch/" | sort -r) ; do
+ if [[ ${host} == "${x}" ]] ; then
+ echo "${x}"
+ return 0
+ fi
+ done
+
+ return 1
+}
+
+pkg_setup() {
+ # Make sure kernel sources are OK
+ # (Override for linux-mod eclass)
+ check_kernel_built
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if [[ ! -d /usr/${CTARGET} ]] ; then
+ echo
+ eerror "It does not look like your cross-compiler is setup properly!"
+ die "It does not look like your cross-compiler is setup properly!"
+ fi
+
+ if ! guess_arch &>/dev/null ; then
+ echo
+ eerror "Could not guess klibc's ARCH from your CTARGET!"
+ die "Could not guess klibc's ARCH from your CTARGET!"
+ fi
+
+ kernel_arch=$(readlink "${KV_OUT_DIR}/include/asm" | sed -e 's:asm-::')
+ if [[ ${kernel_arch} != $(guess_arch) ]] ; then
+ echo
+ eerror "Your kernel sources are not configured for your chosen arch!"
+ eerror "(KERNEL_ARCH=\"${kernel_arch}\", ARCH=\"$(guess_arch)\")"
+ die "Your kernel sources are not configured for your chosen arch!"
+ fi
+
+ cd ${S}
+
+ # Add our linux source tree symlink
+ ln -snf ${KV_DIR} linux
+
+ # set the build directory
+ echo "KRNLOBJ = ${KV_OUT_DIR}" >> MCONFIG
+
+ # We do not want all the nice prelink warnings
+ # NOTE: for amd64, we might change below to '/usr/$(get_libdir)/klibc',
+ # but I do not do it right now, as the build system do not support
+ # the lib64 yet ....
+ cat > "${S}/70klibc" <<-EOF
+ PRELINK_PATH_MASK="/usr/lib/klibc"
+ EOF
+
+ # klibc detects mips64 systems as having 64bit userland
+ # Force them to 32bit userlands instead
+ #epatch ${FILESDIR}/${PN}-1.1-mips32.patch
+}
+
+src_compile() {
+ if is_cross ; then
+ einfo "ARCH = \"$(guess_arch)\""
+ einfo "CROSS = \"${CTARGET}-\""
+ emake ARCH=$(guess_arch) \
+ CROSS="${CTARGET}-" || die "Compile failed!"
+ else
+ env -u ARCH \
+ emake || die "Compile failed!"
+ fi
+}
+
+src_install() {
+ local klibc_prefix
+
+ if is_cross ; then
+ make INSTALLROOT=${D} \
+ ARCH=$(guess_arch) \
+ CROSS="${CTARGET}-" \
+ install || die "Install failed!"
+
+ klibc_prefix=$("${S}/${CTARGET}-klcc" -print-klibc-bindir)
+ else
+ env -u ARCH \
+ make INSTALLROOT=${D} install || die "Install failed!"
+
+ klibc_prefix=$("${S}/klcc" -print-klibc-bindir)
+ fi
+
+ # Hardlinks becoming copies
+ dosym gzip "${klibc_prefix}/gunzip"
+ dosym gzip "${klibc_prefix}/zcat"
+
+ if ! is_cross ; then
+ insinto /usr/share/aclocal
+ doins ${FILESDIR}/klibc.m4
+
+ doenvd ${S}/70klibc
+
+ dodoc ${S}/README ${S}/klibc/{LICENSE,CAVEATS}
+ newdoc ${S}/klibc/README README.klibc
+ newdoc ${S}/klibc/arch/README README.klibc.arch
+ docinto dash; newdoc ${S}/dash/README.klibc README
+ docinto gzip; dodoc ${S}/gzip/{COPYING,README}
+ fi
+}
+
+pkg_postinst() {
+ # Override for linux-mod eclass
+ return 0
+}