summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-20 11:28:45 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-20 11:28:45 +0000
commitf1a37aba1ef902fdddd350d768f98a364e54d9ed (patch)
treea1c384c3db86869ed87eab5d697e4528031e69d6 /dev-libs/json-glib/files
parentMask due keywords pending, bug #476710 (diff)
downloadhistorical-f1a37aba1ef902fdddd350d768f98a364e54d9ed.tar.gz
historical-f1a37aba1ef902fdddd350d768f98a364e54d9ed.tar.bz2
historical-f1a37aba1ef902fdddd350d768f98a364e54d9ed.zip
Apply upstream patch to use bsymbolic and prevent problems like bug #475954
Package-Manager: portage-2.1.12.13/cvs/Linux x86_64 Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'dev-libs/json-glib/files')
-rw-r--r--dev-libs/json-glib/files/json-glib-0.16.0-bsymbolic.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/json-glib/files/json-glib-0.16.0-bsymbolic.patch b/dev-libs/json-glib/files/json-glib-0.16.0-bsymbolic.patch
new file mode 100644
index 000000000000..81593a8f5b67
--- /dev/null
+++ b/dev-libs/json-glib/files/json-glib-0.16.0-bsymbolic.patch
@@ -0,0 +1,47 @@
+From a9327484746820a5a2b8c1acf4a78470b004f0a0 Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Thu, 11 Jul 2013 15:49:14 +0000
+Subject: build: Add configure option to enable -Bsymbolic
+
+We should always compile with -Bsymbolic enabled to avoid intra-library
+PLT jumps.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=703734
+---
+diff --git a/configure.ac b/configure.ac
+index 7c640fa..90654c6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -93,6 +93,30 @@ AC_MSG_RESULT([$platform_win32])
+ AM_CONDITIONAL(OS_LINUX, [test "$platform_linux" = "yes"])
+ AM_CONDITIONAL(OS_WIN32, [test "$platform_win32" = "yes"])
+
++# Check for -Bsymbolic-functions to avoid intra-library PLT jumps
++AC_ARG_ENABLE([Bsymbolic],
++ [AS_HELP_STRING([--disable-Bsymbolic],
++ [Avoid linking with -Bsymbolic])],
++ [],
++ [
++ saved_LDFLAGS="${LDFLAGS}"
++ AC_MSG_CHECKING([for -Bsymbolic-functions linker flag])
++ LDFLAGS=-Wl,-Bsymbolic-functions
++ AC_TRY_LINK([], [int main (void) { return 0; }],
++ [
++ AC_MSG_RESULT([yes])
++ enable_Bsymbolic=yes
++ ],
++ [
++ AC_MSG_RESULT([no])
++ enable_Bsymbolic=no
++ ])
++ LDFLAGS="${saved_LDFLAGS}"
++ ])
++
++AS_IF([test "x$enable_Bsymbolic" = "xyes"], [JSON_LINK_FLAGS=-Wl[,]-Bsymbolic-functions])
++JSON_LT_LDFLAGS="$JSON_LT_LDFLAGS $JSON_LINK_FLAGS"
++
+ AC_SUBST(JSON_LT_LDFLAGS)
+
+ dnl === Dependencies ==========================================================
+--
+cgit v0.9.2