summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-04-26 20:18:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-04-26 20:18:16 +0000
commit67bce799059b48545b95d40423b52a524def5407 (patch)
treee1633c1fe70bb9292540b1e9bfc9e08292af2208 /dev-libs/folks
parentStable on amd64 wrt bug #364409 (diff)
downloadhistorical-67bce799059b48545b95d40423b52a524def5407.tar.gz
historical-67bce799059b48545b95d40423b52a524def5407.tar.bz2
historical-67bce799059b48545b95d40423b52a524def5407.zip
Version bump with bug fixes.
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/folks')
-rw-r--r--dev-libs/folks/ChangeLog7
-rw-r--r--dev-libs/folks/folks-0.4.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-libs/folks/ChangeLog b/dev-libs/folks/ChangeLog
index 597594406c58..f399263e1e9f 100644
--- a/dev-libs/folks/ChangeLog
+++ b/dev-libs/folks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/folks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/folks/ChangeLog,v 1.9 2011/03/25 22:48:53 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/folks/ChangeLog,v 1.10 2011/04/26 20:18:16 eva Exp $
+
+*folks-0.4.3 (26 Apr 2011)
+
+ 26 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> +folks-0.4.3.ebuild:
+ Version bump with bug fixes.
*folks-0.4.2 (25 Mar 2011)
diff --git a/dev-libs/folks/folks-0.4.3.ebuild b/dev-libs/folks/folks-0.4.3.ebuild
new file mode 100644
index 000000000000..bec5755a6a07
--- /dev/null
+++ b/dev-libs/folks/folks-0.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/folks/folks-0.4.3.ebuild,v 1.1 2011/04/26 20:18:16 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="libfolks is a library that aggregates people from multiple sources"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Folks"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# FIXME: links against system libfolks instead of the built one
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=net-libs/telepathy-glib-0.13.1[vala]
+ dev-libs/dbus-glib
+ <dev-libs/libgee-0.7
+ dev-libs/libxml2
+ sys-libs/ncurses
+ sys-libs/readline
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.21
+ >=dev-lang/vala-0.11.6:0.12[vapigen]
+ >=dev-libs/gobject-introspection-0.9.12
+ sys-devel/gettext
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="${G2CONF}
+ --enable-import-tool
+ --enable-inspect-tool
+ --enable-vala
+ VALAC=$(type -p valac-0.12)
+ VAPIGEN=$(type -p vapigen-0.12)
+ --disable-docs
+ --disable-Werror"
+ # Rebuilding docs needs valadoc, which has no release
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "la files removal failed"
+}