summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-18 22:02:53 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-18 22:02:53 +0000
commit7a8878711246489dd5fe595d5002eefccf0a688d (patch)
treec8548cde559c898229668ac774305466755182c9 /dev-libs/boost
parentFixes #8457. (diff)
downloadhistorical-7a8878711246489dd5fe595d5002eefccf0a688d.tar.gz
historical-7a8878711246489dd5fe595d5002eefccf0a688d.tar.bz2
historical-7a8878711246489dd5fe595d5002eefccf0a688d.zip
Fixes #2851.
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog10
-rw-r--r--dev-libs/boost/boost-1.28.ebuild55
-rw-r--r--dev-libs/boost/files/digest-boost-1.281
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
new file mode 100644
index 000000000000..5bd7119b2cc7
--- /dev/null
+++ b/dev-libs/boost/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/boost
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.3 2002/05/07 03:58:19 drobbins Exp
+
+*boost-1.28 (19 Oct 2002)
+
+ 19 Oct 2002; Karl Trygve Kalleberg <markus-krainer@chello.at> boost-1.28.0.ebuild, files/digest-boost-1.28:
+ Initial import. All code submitted by Markus Krainer
+ <markus-krainer@chello.at>. Fixes #2851.
+
diff --git a/dev-libs/boost/boost-1.28.ebuild b/dev-libs/boost/boost-1.28.ebuild
new file mode 100644
index 000000000000..006c60538e8b
--- /dev/null
+++ b/dev-libs/boost/boost-1.28.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.28.ebuild,v 1.1 2002/10/18 22:02:53 karltk Exp $
+
+DESCRIPTION="Boost provides free peer-review portable C++ source libraries."
+MY_V="`echo ${PV} |sed -e 's:\.:_:g'`"
+S=${WORKDIR}/boost_${MY_V}
+SRC_URI="http://boost.sourceforge.net/release/boost_${MY_V}.tar.gz"
+HOMEPAGE="http://www.boost.org"
+LICENSE="freedist"
+DEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1"
+KEYWORDS="~x86"
+SLOT="1"
+IUSE=""
+
+src_compile() {
+
+ # first compile jam (the boost build tool)
+ cd ${S}/tools/build/jam_src
+ emake || die "couldn't build jam"
+
+ # now build boost libraries
+ cd ${S}
+ ./tools/build/jam_src/bin.linuxx86/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=2.2 \
+ -sTOOLS=gcc || die "build error"
+}
+
+src_install () {
+
+ # jam does not provide smth like 'make install' :(
+
+ cd ${S}
+ # install libraries
+ find libs -type f -name \*.a -exec dolib.a {} \;
+ find libs -type f -name \*.so -exec dolib.so {} \;
+
+ # install source/header files
+ find boost -type f -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install documentation
+ dodoc README
+
+ # this part should really use dohtml -- karltk
+ for i in htm html jpg jpeg gif css
+ do
+ find . -type f -name "*.${i}" -exec \
+ install -D -m0644 {} ${D}/usr/share/doc/${P}/html/{} \;
+ done
+
+}
+
diff --git a/dev-libs/boost/files/digest-boost-1.28 b/dev-libs/boost/files/digest-boost-1.28
new file mode 100644
index 000000000000..33b59167ddaa
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.28
@@ -0,0 +1 @@
+MD5 281e0e4cd6160ce2ba0d4df4a590070e boost_1_28_0.tar.gz 4195589