summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-11 19:14:22 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-11 19:14:22 +0000
commit488e9b5f9b6dd20f62536954706a656f866cb6f5 (patch)
tree193270e5cc51239755528cbd3b7185776d61bfae /dev-libs/apr
parentfix #220353 (diff)
downloadhistorical-488e9b5f9b6dd20f62536954706a656f866cb6f5.tar.gz
historical-488e9b5f9b6dd20f62536954706a656f866cb6f5.tar.bz2
historical-488e9b5f9b6dd20f62536954706a656f866cb6f5.zip
version bump wrt #225783
Package-Manager: portage-2.1.5.4
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog7
-rw-r--r--dev-libs/apr/apr-1.3.0.ebuild97
2 files changed, 103 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 07230f524df2..72b75c8bb745 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.102 2008/06/01 11:35:11 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.103 2008/06/11 19:12:54 hollow Exp $
+
+*apr-1.3.0 (11 Jun 2008)
+
+ 11 Jun 2008; Benedikt Böhm <hollow@gentoo.org> +apr-1.3.0.ebuild:
+ version bump wrt #225783
01 Jun 2008; Benedikt Böhm <hollow@gentoo.org> apr-1.2.11.ebuild,
apr-1.2.12.ebuild:
diff --git a/dev-libs/apr/apr-1.3.0.ebuild b/dev-libs/apr/apr-1.3.0.ebuild
new file mode 100644
index 000000000000..b1236ca2a2ae
--- /dev/null
+++ b/dev-libs/apr/apr-1.3.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.3.0.ebuild,v 1.1 2008/06/11 19:12:54 hollow Exp $
+
+inherit autotools
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc ipv6 urandom debug"
+RESTRICT="test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # for some reason not all the .m4 files that are referenced in
+ # configure.in exist, so we remove all references and include every
+ # .m4 file in build using aclocal via eautoreconf
+ # See bug 135463
+ sed -i -e '/sinclude/d' configure.in
+ AT_M4DIR="build" eautoreconf
+
+ epatch "${FILESDIR}"/config.layout.patch
+}
+
+src_compile() {
+ # For now we always enable ipv6. Testing has shown that is still works
+ # correctly in ipv4 systems, and currently, the ipv4-only support
+ # is broken in apr. (ipv6 is enabled by default)
+ #myconf="${myconf} $(use_enable ipv6)"
+
+ if use urandom; then
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ else
+ myconf="${myconf} --with-devrandom=/dev/random"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --enable-maintainer-mode"
+ myconf="${myconf} --enable-pool-debug=all"
+ fi
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+ econf --enable-layout=gentoo \
+ --enable-threads \
+ --enable-nonportable-atomics \
+ ${myconf}
+
+ # Make sure we use the system libtool
+ sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
+ sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' "${S}"/apr-1-config
+ rm -f "${S}"/libtool
+
+ emake || die "Make failed"
+
+ if use doc; then
+ emake dox || die "make dox failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/apr.exp
+
+ dodoc CHANGES NOTICE
+
+ if use doc; then
+ dohtml docs/dox/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ ewarn "We are now using the system's libtool rather then bundling"
+ ewarn "our own. You will need to rebuild Apache and possibly other"
+ ewarn "software if you get a message similiar to the following:"
+ ewarn
+ ewarn " /usr/share/apr-1/build-1/libtool: No such file or directory"
+ ewarn
+}