summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-08-29 11:53:43 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-08-29 11:53:43 +0000
commitdad4a6c7bf8fbeb2a9b4a79b36cbdcf400956a6c (patch)
tree54146e508ce623c949d7dc03ee1a253a3291ab2f /dev-libs/apr-util
parentAdd postinst message wrt crashreporter, bug #233728 and bug #229867 (diff)
downloadhistorical-dad4a6c7bf8fbeb2a9b4a79b36cbdcf400956a6c.tar.gz
historical-dad4a6c7bf8fbeb2a9b4a79b36cbdcf400956a6c.tar.bz2
historical-dad4a6c7bf8fbeb2a9b4a79b36cbdcf400956a6c.zip
version bump wrt #235938
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog7
-rw-r--r--dev-libs/apr-util/apr-util-1.3.4.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 7115555fdf83..a0dee47ca61a 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.115 2008/08/16 16:49:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.116 2008/08/29 11:53:43 hollow Exp $
+
+*apr-util-1.3.4 (29 Aug 2008)
+
+ 29 Aug 2008; Benedikt Böhm <hollow@gentoo.org> +apr-util-1.3.4.ebuild:
+ version bump wrt #235938
16 Aug 2008; Jeroen Roovers <jer@gentoo.org> apr-util-1.3.2.ebuild:
Stable for HPPA (bug #232671).
diff --git a/dev-libs/apr-util/apr-util-1.3.4.ebuild b/dev-libs/apr-util/apr-util-1.3.4.ebuild
new file mode 100644
index 000000000000..2e825ca2bcaf
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.3.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.4.ebuild,v 1.1 2008/08/29 11:53:43 hollow Exp $
+
+# usually apr-util has the same PV as apr, but in case of security fixes, this
+# may change.
+#APR_PV=${PV}
+APR_PV="1.3.3"
+
+inherit eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb doc freetds gdbm ldap mysql odbc postgres sqlite sqlite3"
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${APR_PV}
+ berkdb? ( =sys-libs/db-4* )
+ freetds? ( dev-db/freetds )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( virtual/postgresql-base )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ local myconf=""
+
+ use ldap && myconf="${myconf} --with-ldap"
+
+ if use berkdb; then
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf --datadir=/usr/share/apr-util-1 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $(use_with freetds) \
+ $(use_with gdbm) \
+ $(use_with mysql) \
+ $(use_with odbc) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite2) \
+ $(use_with sqlite3) \
+ ${myconf}
+
+ emake || die "emake failed!"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CHANGES NOTICE
+
+ if use doc; then
+ dohtml docs/dox/html/* || die "dohtml failed"
+ fi
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/aprutil.exp
+}