summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-10-29 17:38:45 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-10-29 17:38:45 +0000
commita1ccedf9c49d8a8e55dc9004e5a4d857d37b5eb6 (patch)
treebc68513554f2cca2190ad6b3564df43b027c465f /dev-lang
parentVersion bump. (diff)
downloadhistorical-a1ccedf9c49d8a8e55dc9004e5a4d857d37b5eb6.tar.gz
historical-a1ccedf9c49d8a8e55dc9004e5a4d857d37b5eb6.tar.bz2
historical-a1ccedf9c49d8a8e55dc9004e5a4d857d37b5eb6.zip
Version bump.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/prc-tools/Manifest4
-rw-r--r--dev-lang/prc-tools/files/digest-prc-tools-2.35
-rw-r--r--dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch292
-rw-r--r--dev-lang/prc-tools/prc-tools-2.3.ebuild121
4 files changed, 420 insertions, 2 deletions
diff --git a/dev-lang/prc-tools/Manifest b/dev-lang/prc-tools/Manifest
index cd03ce6e86e6..2534996e0261 100644
--- a/dev-lang/prc-tools/Manifest
+++ b/dev-lang/prc-tools/Manifest
@@ -1,6 +1,6 @@
-MD5 07934d8039871f65f8d44297458b13df ChangeLog 513
+MD5 c6446237da10a3ae51c4ba01437f6afd ChangeLog 516
MD5 3f28709d6eeac506b320d0bbe1d026ac prc-tools-2.2.ebuild 3082
-MD5 295da80c0a3f6584e1d760dabf38f818 prc-tools-2.3.ebuild 3133
+MD5 8cda8cdbcd430764068ea85b95c05ae4 prc-tools-2.3.ebuild 3234
MD5 4c73bc92caa33aa26b5c07c25bea44a3 files/digest-prc-tools-2.2 330
MD5 fcc20c7b30e20c7bc95f2accdfe8f569 files/prc-tools-2.2-compilefix.patch 6620
MD5 a7ab0a38eef025abb11ecefaa270c68b files/digest-prc-tools-2.3 323
diff --git a/dev-lang/prc-tools/files/digest-prc-tools-2.3 b/dev-lang/prc-tools/files/digest-prc-tools-2.3
new file mode 100644
index 000000000000..4de07be0bcd0
--- /dev/null
+++ b/dev-lang/prc-tools/files/digest-prc-tools-2.3
@@ -0,0 +1,5 @@
+MD5 038a42a71a984fee6f906abc85a032ec prc-tools-2.3.tar.gz 333417
+MD5 2da8def15d28af3ec6af0982709ae90a binutils-2.14.tar.bz2 10921504
+MD5 70e4ade69a2dff2c7b9af9a4ef44798f gdb-5.3.tar.bz2 11198721
+MD5 1135a104e9fa36fdf7c663598fab5c40 gcc-3.3.1.tar.bz2 23544362
+MD5 87ee083a830683e2aaa57463940a0c3c gcc-2.95.3.tar.bz2 9848842
diff --git a/dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch b/dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch
new file mode 100644
index 000000000000..ef22d41d3ff6
--- /dev/null
+++ b/dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch
@@ -0,0 +1,292 @@
+--- prc-tools-2.3/binutils/configure.in 2003-06-12 15:33:14.000000000 +0100
++++ prc-tools-2.3/binutils/configure.in.plasmaroo.sandboxSafe 2003-10-27 19:23:34.000000000 +0000
+@@ -945,36 +945,37 @@
+ fi
+ fi
+
+-# Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++## Handle ${copy_dirs}
++## *** DISABLED *** for happy sandboxing!
++#set fnord ${copy_dirs}
++#shift
++#while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
+--- prc-tools-2.3/gcc/configure.in 2003-10-27 19:02:11.000000000 +0000
++++ prc-tools-2.3/gcc/configure.in.plasmaroo.sandboxSafe 2003-10-27 19:25:39.000000000 +0000
+@@ -905,36 +905,37 @@
+ fi
+ fi
+
+-# Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++## Handle ${copy_dirs}
++## *** DISABLED *** for happy sandboxing!
++#set fnord ${copy_dirs}
++#shift
++#while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
+--- prc-tools-2.3/gcc295/configure.in 2002-05-15 00:47:22.000000000 +0100
++++ prc-tools-2.3/gcc295/configure.in 2003-07-01 22:02:49.000000000 +0100
+@@ -470,36 +470,39 @@
+ esac
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while [ $# != 0 ]; do
+- if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if [ -d $2 ]; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++#set fnord ${copy_dirs}
++#shift
++#while [ $# != 0 ]; do
++# if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if [ -d $2 ]; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Configure extra directories which are host specific
+
+--- prc-tools-2.3/gdb/configure.in 2002-12-10 21:34:10.000000000 +0000
++++ prc-tools-2.3/gdb/configure.in 2003-07-03 17:49:38.000000000 +0100
+@@ -909,35 +909,38 @@
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++# set fnord ${copy_dirs}
++# shift
++# while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
+--- prc-tools-2.3/doc/Makefile.in 2003-09-07 17:53:54.000000000 +0100
++++ prc-tools-2.3/doc/Makefile.in.plasmaroo.sandboxSafe 2003-10-27 19:31:06.000000000 +0000
+@@ -17,7 +17,7 @@
+ palmdev_prefix = @palmdev_prefix@
+ infodir = @infodir@
+ mandir = @mandir@
+-htmldir = @htmldocs_prefix@
++htmldir = ${D}/@htmldocs_prefix@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
diff --git a/dev-lang/prc-tools/prc-tools-2.3.ebuild b/dev-lang/prc-tools/prc-tools-2.3.ebuild
new file mode 100644
index 000000000000..51c7aace5c3b
--- /dev/null
+++ b/dev-lang/prc-tools/prc-tools-2.3.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc. and Tim Yamin [plasmaroo@gentoo.org]
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/prc-tools/prc-tools-2.3.ebuild,v 1.1 2003/10/29 17:38:35 plasmaroo Exp $
+
+DESCRIPTION="GNU-Based Palm C++ Development Suite"
+
+BIN_V="binutils-2.14"
+GDB_V="gdb-5.3"
+GCC_V_ARM="gcc-3.3.1"
+GCC_V_M68K="gcc-2.95.3"
+
+SRC_URI="mirror://sourceforge/prc-tools/${P}.tar.gz
+ ftp://sources.redhat.com/pub/binutils/releases/${BIN_V}.tar.bz2
+ ftp://sources.redhat.com/pub/gdb/releases/${GDB_V}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/${GCC_V_ARM}/${GCC_V_ARM}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/${GCC_V_M68K}/${GCC_V_M68K}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+HOMEPAGE="http://prc-tools.sourceforge.net"
+DEPEND=">=app-text/texi2html-1.64"
+
+S=${WORKDIR}/${P}
+
+src_unpack () {
+
+ cd ${WORKDIR}
+ unpack ${A} || die
+
+ cd ${P}
+ ln -s ../${BIN_V} binutils
+ ln -s ../${GDB_V} gdb
+ ln -s ../${GCC_V_ARM} gcc
+ ln -s ../${GCC_V_M68K} gcc295
+ cd ..
+
+ echo ">>> Patching sources..."
+ echo -n " "; epatch ${P}/${BIN_V}.palmos.diff || die
+ echo -n " "; epatch ${P}/${GCC_V_ARM}.palmos.diff || die
+ echo -n " "; epatch ${P}/${GCC_V_M68K}.palmos.diff || die
+ echo -n " "; epatch ${P}/${GDB_V}.palmos.diff || die
+ echo -n " "; epatch ${FILESDIR}/${P}-compilefix.patch || die
+
+ # This last patch disables dummy headers being copied.
+ # a) They're not needed
+ # b) This causes a sandboxing error
+ # +) Keeps 'palmdev-prep' pointed at the
+ # right place while making the docs install
+ # script from not install them to real root /
+
+ # Fix ${GCC_V_ARM} include problem
+ cp ${GCC_V_ARM}/gcc/fixinc/tests/base/unistd.h ${GCC_V_ARM}/gcc
+
+}
+
+src_config () {
+
+ echo ">>> Rebuilding configuration scripts"
+ cd binutils; autoconf || die "Failed to reconfigure binutils"; cd ..
+
+ cd ..
+ mkdir build
+ cd build
+
+ echo ">>> Configuring..."
+ echo
+
+ # Remove any flags; because the cross-compiler (2.9.x GCC)
+ # will not understand any of these optimizations {and will
+ # fail} once the cross-compiler compiles the m68k GCC suite
+
+ ALLOWED_FLAGS="-pipe -0 -01 -02"
+ strip-flags
+
+ ../${P}/configure --enable-targets=m68k-palmos,arm-palmos \
+ --enable-languages=c,c++ \
+ --with-headers=${WORKDIR}/build/empty --enable-html-docs \
+ --with-palmdev-prefix=/opt/palmdev --prefix=/usr || die
+
+ # These have to be real; otherwise the compiler is hard-coded
+ # and tries to find libraries in ${D}/....
+
+ # palmdev-prefix also has to be real; otherwise 'palmdev-prep'
+ # defaults to virtual ${D}/..
+
+}
+
+src_compile () {
+
+ src_config
+ make || die
+
+}
+
+src_install () {
+
+ cd ..
+ cd build
+ einstall || die
+
+}
+
+pkg_postinst () {
+
+ echo
+ einfo "PRC-Tools is now compiled and installed!"
+ einfo "<HTML docs are installed in /opt/palmdev>"
+ echo
+ einfo "For a complete Palm Development Environment you will also need..."
+ echo
+ einfo "[ ] PilRC; the Palm resource compiler; emerge pilrc"
+ einfo "[ ] POSE; The Palm OS Emulator; emerge pose"
+ echo " ->> A ROM for POSE; available from Palm"
+ einfo "[ ] An SDK; available from the Palm Website"
+ echo " ->> Decompress this to /opt/palmdev and then run"
+ echo " 'palmdev-prep /opt/palmdev'"
+ echo
+
+}