summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-04-03 08:34:05 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-04-03 08:34:05 +0000
commit402f10a27136235a85cfefd26c9efe778d9ad6ab (patch)
tree1dda484949808715b1a50e9752f6110a8bb02a7b /dev-lang
parent~ppc marked (diff)
downloadhistorical-402f10a27136235a85cfefd26c9efe778d9ad6ab.tar.gz
historical-402f10a27136235a85cfefd26c9efe778d9ad6ab.tar.bz2
historical-402f10a27136235a85cfefd26c9efe778d9ad6ab.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog7
-rw-r--r--dev-lang/gnu-smalltalk/Manifest6
-rw-r--r--dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el3
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild11
4 files changed, 20 insertions, 7 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 4a98ae19996b..fb8663ba4801 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.5 2005/03/31 19:07:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.6 2005/04/03 08:34:05 mkennedy Exp $
+
+ 03 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ files/50gnu-smalltalk-gentoo.el, gnu-smalltalk-2.1.10.ebuild:
+ Correct messy Emacs Lisp installation; Include autoload for Emacs
+ interactive function: smalltalk-mode.
31 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org>
gnu-smalltalk-2.1.10.ebuild:
diff --git a/dev-lang/gnu-smalltalk/Manifest b/dev-lang/gnu-smalltalk/Manifest
index a573b292df39..cc6679f211d0 100644
--- a/dev-lang/gnu-smalltalk/Manifest
+++ b/dev-lang/gnu-smalltalk/Manifest
@@ -1,9 +1,9 @@
-MD5 7fa3c2f5ed998d77bb48c25536b6b7d9 ChangeLog 1157
+MD5 f54413cfd39fec2fe65c8c62715879ab ChangeLog 1383
MD5 0c6eaf50a0c054e0cec00460354fcf4c gnu-smalltalk-2.1.8.ebuild 1655
MD5 54532d9cd3833e3c65d9136f3a1b6458 metadata.xml 630
-MD5 cafd11b4939182212d2ab83fadf22954 gnu-smalltalk-2.1.10.ebuild 2038
+MD5 1a3439b164e0123a56d22c4e39c504e2 gnu-smalltalk-2.1.10.ebuild 2197
MD5 2a74f549d87286f4ceed883af53724c2 files/2.1.8-gst-package-mktemp-gentoo.patch 780
-MD5 4e4efa446a75ebaf3437fe42510348c5 files/50gnu-smalltalk-gentoo.el 143
+MD5 0663c2da97b15849626149d2cc36d3d6 files/50gnu-smalltalk-gentoo.el 220
MD5 66ddf9dc07f2331955851bc54cb3b17f files/digest-gnu-smalltalk-2.1.8 68
MD5 3c44219f948e6f4f983ac5225c93a845 files/digest-gnu-smalltalk-2.1.10 69
MD5 38985fa85d0e6de68b4ac79a1bb08da7 files/2.1.10-gst-image-temp.patch 2125
diff --git a/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el b/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el
index 1915d5c15d97..074204d47dfd 100644
--- a/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el
+++ b/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el
@@ -2,4 +2,5 @@
;;; gnu-smalltalk site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
-(add-to-list 'auto-mode-alist '("\\.st\\'" . smalltalk-mode)) \ No newline at end of file
+(autoload 'smalltalk-mode "smalltalk-mode" "Autoload for smalltalk-mode" t)
+(add-to-list 'auto-mode-alist '("\\.st\\'" . smalltalk-mode))
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild
index 6778370dbbae..87760b58b7bf 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild,v 1.2 2005/03/31 19:07:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild,v 1.3 2005/04/03 08:34:05 mkennedy Exp $
inherit elisp-common flag-o-matic eutils gcc
@@ -52,6 +52,9 @@ src_compile() {
${myconf} \
|| die
emake || die "emake failed"
+ if use emacs; then
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+ fi
}
src_install() {
@@ -60,7 +63,11 @@ src_install() {
${D}/usr/include/snprintfv \
${D}/usr/share/aclocal/snprintfv.m4
dodoc AUTHORS COPYING* ChangeLog NEWS PATCHES README THANKS TODO
- use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ rm -rf ${D}/var
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
}
pkg_postinst() {