summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2005-10-31 18:13:08 +0000
committerTom William Payne <twp@gentoo.org>2005-10-31 18:13:08 +0000
commit393cb5956f4087e81bddafd18d9bd4b443a2488d (patch)
tree7e6f213d1d92285c8c7c6028b4073693a848d983 /dev-lang/tolua
parentStable on x86. (diff)
downloadhistorical-393cb5956f4087e81bddafd18d9bd4b443a2488d.tar.gz
historical-393cb5956f4087e81bddafd18d9bd4b443a2488d.tar.bz2
historical-393cb5956f4087e81bddafd18d9bd4b443a2488d.zip
Use portability eclass to conditionally link to dl. Bug # 106446.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'dev-lang/tolua')
-rw-r--r--dev-lang/tolua/ChangeLog7
-rw-r--r--dev-lang/tolua/Manifest8
-rw-r--r--dev-lang/tolua/files/digest-tolua-5.0-r11
-rw-r--r--dev-lang/tolua/tolua-5.0-r1.ebuild44
4 files changed, 56 insertions, 4 deletions
diff --git a/dev-lang/tolua/ChangeLog b/dev-lang/tolua/ChangeLog
index 5aca55274adf..14b821f30335 100644
--- a/dev-lang/tolua/ChangeLog
+++ b/dev-lang/tolua/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tolua
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/ChangeLog,v 1.5 2005/05/18 11:41:32 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/ChangeLog,v 1.6 2005/10/31 18:13:08 twp Exp $
+
+*tolua-5.0-r1 (31 Oct 2005)
+
+ 31 Oct 2005; Tom Payne <twp@gentoo.org> +tolua-5.0-r1.ebuild:
+ Use portability eclass to conditionally link to dl. Bug # 106446.
18 May 2005; Tom Payne <twp@gentoo.org> tolua-5.0.ebuild:
Use toolchain-funcs eclass. Bug # 92745.
diff --git a/dev-lang/tolua/Manifest b/dev-lang/tolua/Manifest
index a74d35fcd801..01b9845a2c68 100644
--- a/dev-lang/tolua/Manifest
+++ b/dev-lang/tolua/Manifest
@@ -1,4 +1,6 @@
-MD5 9ab5079ce4a53d7a16104c257b36ec38 tolua-5.0.ebuild 1007
-MD5 c503c1806e155f6650a5cef268e1c80c ChangeLog 586
-MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
+MD5 6d342f7efe3fe705cf5ee00a3fc7c6ca ChangeLog 748
MD5 8e839d58ded054bfa49ba75a9e769951 files/digest-tolua-5.0 60
+MD5 8e839d58ded054bfa49ba75a9e769951 files/digest-tolua-5.0-r1 60
+MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
+MD5 bb4e0d3830e5426762496f20c39cebfe tolua-5.0-r1.ebuild 1032
+MD5 9ab5079ce4a53d7a16104c257b36ec38 tolua-5.0.ebuild 1007
diff --git a/dev-lang/tolua/files/digest-tolua-5.0-r1 b/dev-lang/tolua/files/digest-tolua-5.0-r1
new file mode 100644
index 000000000000..d9469566c491
--- /dev/null
+++ b/dev-lang/tolua/files/digest-tolua-5.0-r1
@@ -0,0 +1 @@
+MD5 d572bfe7b8cd2af46fcb0a276929f973 tolua-5.0.tar.gz 85636
diff --git a/dev-lang/tolua/tolua-5.0-r1.ebuild b/dev-lang/tolua/tolua-5.0-r1.ebuild
new file mode 100644
index 000000000000..ea397f3b596d
--- /dev/null
+++ b/dev-lang/tolua/tolua-5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/tolua-5.0-r1.ebuild,v 1.1 2005/10/31 18:13:08 twp Exp $
+
+inherit toolchain-funcs portability
+
+DESCRIPTION="A tool that simplifies the integration of C/C++ code with Lua"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~celes/tolua/"
+SRC_URI="ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/^CC=/ s/=.*/=$(tc-getCC)/" \
+ -e "/^LUA=/ s:=.*:=/usr:" \
+ -e "s/^\(LIB=.*\)/\1 $(dlopen_lib)/" \
+ -e "s:-O2:${CFLAGS}:" config || \
+ die "sed config failed"
+ sed -i \
+ -e 's:make:$(MAKE):' Makefile || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin bin/tolua || die
+ dolib.a lib/libtolua.a
+ insinto /usr/include
+ doins include/tolua.h
+ dodoc INSTALL README
+ dohtml doc/*
+}