summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-15 12:10:15 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-15 12:10:15 +0000
commit32bab6806b1bb6828404f65888d46ad3c20e2a66 (patch)
treeb4d8a7972f29eb1353829e37b2dbc19fc6253514 /dev-lang/tk
parentDelete older ebuild. (diff)
downloadhistorical-32bab6806b1bb6828404f65888d46ad3c20e2a66.tar.gz
historical-32bab6806b1bb6828404f65888d46ad3c20e2a66.tar.bz2
historical-32bab6806b1bb6828404f65888d46ad3c20e2a66.zip
QA, imported prefix changes
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog8
-rw-r--r--dev-lang/tk/files/tk-8.4.15-aqua.patch20
-rw-r--r--dev-lang/tk/tk-8.5.8-r1.ebuild115
3 files changed, 142 insertions, 1 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index e1581c993636..7fe5b7db345d 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.132 2010/01/07 14:20:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.133 2010/06/15 12:10:14 jlec Exp $
+
+*tk-8.5.8-r1 (15 Jun 2010)
+
+ 15 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/tk-8.4.15-aqua.patch,
+ +tk-8.5.8-r1.ebuild:
+ QA, imported prefix changes
*tk-8.5.8 (07 Jan 2010)
diff --git a/dev-lang/tk/files/tk-8.4.15-aqua.patch b/dev-lang/tk/files/tk-8.4.15-aqua.patch
new file mode 100644
index 000000000000..0131dbd69bd1
--- /dev/null
+++ b/dev-lang/tk/files/tk-8.4.15-aqua.patch
@@ -0,0 +1,20 @@
+--- unix/Makefile.in
++++ unix/Makefile.in
+@@ -280,7 +280,7 @@
+ TK_RSRC_FILE = @TK_RSRC_FILE@
+ WISH_RSRC_FILE = @WISH_RSRC_FILE@
+ REZ = @REZ@
+-REZ_SWITCHES = @REZ_FLAGS@ -i $(GENERIC_DIR) -i $(TCL_GENERIC_DIR)
++REZ_SWITCHES = @REZ_FLAGS@ -i $(GENERIC_DIR) -i $(TCL_GENERIC_DIR) -i @GENTOO_PORTAGE_EPREFIX@/usr/include
+
+ #----------------------------------------------------------------
+ # The information below is modified by the configure script when
+@@ -468,7 +468,7 @@
+
+ AQUA_HDRS = $(MAC_OSX_DIR)/tkMacOSX.h $(GENERIC_DIR)/tkIntXlibDecls.h
+
+-AQUA_XLIB_HDRS = $(XLIB_DIR)/X11/*.h $(XLIB_DIR)/xbytes.h
++AQUA_XLIB_HDRS =
+
+ AQUA_PRIVATE_HDRS = $(MAC_OSX_DIR)/tkMacOSXPort.h $(MAC_OSX_DIR)/tkMacOSXInt.h
+
diff --git a/dev-lang/tk/tk-8.5.8-r1.ebuild b/dev-lang/tk/tk-8.5.8-r1.ebuild
new file mode 100644
index 000000000000..77ff8ffdb73f
--- /dev/null
+++ b/dev-lang/tk/tk-8.5.8-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.8-r1.ebuild,v 1.1 2010/06/15 12:10:14 jlec Exp $
+
+EAPI="3"
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit autotools eutils multilib toolchain-funcs prefix
+
+MY_P="${PN}${PV/_beta/b}"
+DESCRIPTION="Tk Widget Set"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug threads truetype aqua"
+
+RDEPEND="!aqua? ( x11-libs/libX11 )
+ ~dev-lang/tcl-${PV}"
+DEPEND="${RDEPEND}
+ !aqua? (
+ truetype? ( x11-libs/libXft )
+ x11-libs/libXt
+ x11-proto/xproto
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use threads ; then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
+
+ epatch "${FILESDIR}"/${PN}-8.4.15-aqua.patch
+ eprefixify unix/Makefile.in
+
+ # Bug 125971
+ epatch "${FILESDIR}"/${PN}-8.5_alpha6-tclm4-soname.patch
+
+ cd "${S}"/unix
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ cd "${S}"/unix
+
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+
+ econf \
+ --with-tcl="${EPREFIX}"/usr/${mylibdir} \
+ $(use_enable threads) \
+ $(use_enable aqua) \
+ $(use_enable truetype xft) \
+ $(use_enable debug symbols) || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd "${S}"/unix
+ S= emake DESTDIR="${D}" install || die
+
+ # normalize $S path, bug #280766 (pkgcore)
+ local nS="$(cd "${S}"; pwd)"
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${nS}/unix,\1${EPREFIX}/usr/${mylibdir}," \
+ -e "s,^\(TK_SRC_DIR='\)${nS}',\1${EPREFIX}/usr/${mylibdir}/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${nS}/unix,\1${EPREFIX}/usr/${mylibdir}," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${nS}/unix,\1${EPREFIX}/usr/${mylibdir}," \
+ "${ED}"/usr/${mylibdir}/tkConfig.sh || die
+ [[ ${CHOST} != *-darwin* ]] && sed -i \
+ -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:${EPREFIX}/usr/${mylibdir}'," \
+ -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:${EPREFIX}/usr/${mylibdir}'," \
+ "${ED}"/usr/${mylibdir}/tkConfig.sh
+
+ # install private headers
+ insinto /usr/${mylibdir}/tk${v1}/include/unix
+ doins "${S}"/unix/*.h || die
+ insinto /usr/${mylibdir}/tk${v1}/include/generic
+ doins "${S}"/generic/*.h || die
+ rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
+ rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
+ rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
+ dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname) || die
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a || die
+
+ dosym wish${v1} /usr/bin/wish || die
+
+ cd "${S}"
+ dodoc ChangeLog* README changes || die
+}