summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2004-04-24 19:00:40 +0000
committerIan Leitch <port001@gentoo.org>2004-04-24 19:00:40 +0000
commit916e211c3847202c0be07d8814d2e131d9151d57 (patch)
tree6010e7910379c82209e008841c1823506c4fdb6f /dev-lang/tk/tk-8.3.4-r1.ebuild
parentversion bump, bug 47435. (diff)
downloadhistorical-916e211c3847202c0be07d8814d2e131d9151d57.tar.gz
historical-916e211c3847202c0be07d8814d2e131d9151d57.tar.bz2
historical-916e211c3847202c0be07d8814d2e131d9151d57.zip
Enable threads with local USE flag 'threads'. #2024
Diffstat (limited to 'dev-lang/tk/tk-8.3.4-r1.ebuild')
-rw-r--r--dev-lang/tk/tk-8.3.4-r1.ebuild30
1 files changed, 28 insertions, 2 deletions
diff --git a/dev-lang/tk/tk-8.3.4-r1.ebuild b/dev-lang/tk/tk-8.3.4-r1.ebuild
index a9ff43c8ef87..d29fb63a14a9 100644
--- a/dev-lang/tk/tk-8.3.4-r1.ebuild
+++ b/dev-lang/tk/tk-8.3.4-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4-r1.ebuild,v 1.6 2004/01/03 18:37:24 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4-r1.ebuild,v 1.7 2004/04/24 19:00:40 port001 Exp $
inherit eutils
+IUSE="threads"
+
DESCRIPTION="Tk Widget Set"
HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
@@ -19,6 +21,21 @@ DEPEND=">=sys-apps/sed-4.0.5
S=${WORKDIR}/${PN}${PV}
+pkg_setup() {
+
+ if [ "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ sleep 5
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}/library
@@ -29,9 +46,18 @@ src_unpack() {
#
src_compile() {
cd ${S}/unix
+
+ local local_config_use=""
+
+ if [ "`use threads`" ]
+ then
+ local_config_use="--enable-threads"
+ fi
+
econf \
--with-tcl=/usr/lib \
- --enable-threads || die
+ ${local_config_use} || die
+
emake CFLAGS="${CFLAGS}" || die
}