summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-04-03 10:38:52 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-04-03 10:38:52 +0000
commit3fb6f99577507d7ff00eaa45cbc7b66481b92ec0 (patch)
tree41f597580a288c162f4890b0554bb1a76fff1999 /dev-lang/smlnj
parentBumped stable on ppc (diff)
downloadhistorical-3fb6f99577507d7ff00eaa45cbc7b66481b92ec0.tar.gz
historical-3fb6f99577507d7ff00eaa45cbc7b66481b92ec0.tar.bz2
historical-3fb6f99577507d7ff00eaa45cbc7b66481b92ec0.zip
new package, Standart ML
Diffstat (limited to 'dev-lang/smlnj')
-rw-r--r--dev-lang/smlnj/ChangeLog10
-rw-r--r--dev-lang/smlnj/files/digest-smlnj-110.429
-rw-r--r--dev-lang/smlnj/smlnj-110.42.ebuild82
3 files changed, 101 insertions, 0 deletions
diff --git a/dev-lang/smlnj/ChangeLog b/dev-lang/smlnj/ChangeLog
new file mode 100644
index 000000000000..a07da6dca9d1
--- /dev/null
+++ b/dev-lang/smlnj/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/smlnj
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/ChangeLog,v 1.1 2003/04/03 10:38:52 george Exp $
+
+*smlnj-110.42.ebuild (03 Apr 2003)
+
+ 03 Apr 2003; George Shapovalov <george@gentoo.org> smlnj-110.42.ebuild, files/digest-smlnj-110.42 :
+ initial release (#9989)
+ Standard ML of New Jersey compiler and libraries
+ ebuild submitted by Vadim Berezniker <vadim@berezniker.com> and updated by Ivan Raikov <raikov@cc.gatech.edu>
diff --git a/dev-lang/smlnj/files/digest-smlnj-110.42 b/dev-lang/smlnj/files/digest-smlnj-110.42
new file mode 100644
index 000000000000..b019f5d109fd
--- /dev/null
+++ b/dev-lang/smlnj/files/digest-smlnj-110.42
@@ -0,0 +1,9 @@
+MD5 43e569b0c702466d2a3c851fbf5cc8a8 config.tgz 13660
+MD5 2fbd0a8bf452c7ada0369fec1c3b732c runtime.tgz 313057
+MD5 68c57ff4f1e91c76abb47bab76476567 boot.x86-unix.tgz 5147025
+MD5 00569c04368da182310eed501a87f787 ml-lex.tgz 32108
+MD5 362edafbf2fdbda35505ac9784c86ee2 ml-yacc.tgz 95608
+MD5 efa7b9b411f2a674e39383d723040c64 ml-burg.tgz 31696
+MD5 294b04dd18877c1c7848adf12aae3c3f smlnj-lib.tgz 251230
+MD5 5418fecfdf569e356a6b5f00ed808ac9 cml.tgz 128485
+MD5 0f303ecba76f750ab1b0e38e17428fba eXene.tgz 695431
diff --git a/dev-lang/smlnj/smlnj-110.42.ebuild b/dev-lang/smlnj/smlnj-110.42.ebuild
new file mode 100644
index 000000000000..52a6737a8587
--- /dev/null
+++ b/dev-lang/smlnj/smlnj-110.42.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.42.ebuild,v 1.1 2003/04/03 10:38:52 george Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard ML of New Jersey compiler and libraries"
+SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/config.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/runtime.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/boot.x86-unix.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/ml-lex.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/ml-yacc.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/ml-burg.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/smlnj-lib.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/cml.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/eXene.tgz"
+
+HOMEPAGE="http://cm.bell-labs.com/cm/cs/what/smlnj/"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+SLOT="0"
+DEPEND="virtual/glibc"
+
+SMLNJ_DEST="/usr/share/smlnj"
+SMLNJ_TARGETS="./config/targets"
+
+GEN_POSIX_NAMES_PATCH="15i\n#\n.\nj\nw\nq"
+
+ARCH_BOOT="sml.boot.x86-unix"
+
+src_unpack() {
+ unpack ${A}
+
+ dirs=`ls ${WORKDIR}`
+ mkdir ${WORKDIR}/src
+
+ for i in $dirs; do
+ if test "$i" != "config" -a "$i" != ${ARCH_BOOT}; then
+ mv ${WORKDIR}/${i} ${WORKDIR}/src
+ fi
+ done
+
+ printf ${GEN_POSIX_NAMES_PATCH} | ed -s ${WORKDIR}/src/runtime/config/gen-posix-names.sh
+}
+
+src_compile() {
+ if test "${SMLNJ_HOME}" != ""; then
+ SMLNJ_HOME=""
+ fi
+
+ cd ${WORKDIR}
+
+ echo "request ml-burg" >> $SMLNJ_TARGETS
+ echo "request cml" >> $SMLNJ_TARGETS
+ echo "request cml-lib" >> $SMLNJ_TARGETS
+ echo "request eXene" >> $SMLNJ_TARGETS
+
+ ./config/install.sh || die
+}
+
+src_install () {
+
+ dodir ${SMLNJ_DEST}
+
+ cp -r ${WORKDIR}/{bin,lib} ${D}${SMLNJ_DEST} || die
+
+ dodir /etc/env.d
+ echo -e SMLNJ_HOME=${SMLNJ_DEST} > ${D}/etc/env.d/10smlnj
+
+ #need to provide symlinks into /usr/bin
+ dodir /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-build /usr/bin/
+ dosym ${SMLNJ_DEST}/bin/ml-burg /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-lex /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-makedepend /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-yacc /usr/bin
+ dosym ${SMLNJ_DEST}/bin/sml /usr/bin
+
+}