summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-26 01:03:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-26 01:03:01 +0000
commit6c0bd3732e86e85d4194d9c807b19a51532b2b97 (patch)
treecc20c6a5998bf3e8b17f5ab11132238a6fb3c846 /dev-lang/ruby
parent3.3alpha1 - hardmasked (diff)
downloadhistorical-6c0bd3732e86e85d4194d9c807b19a51532b2b97.tar.gz
historical-6c0bd3732e86e85d4194d9c807b19a51532b2b97.tar.bz2
historical-6c0bd3732e86e85d4194d9c807b19a51532b2b97.zip
arm KEYWORDS
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ruby-1.8.1-r6.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-lang/ruby/ruby-1.8.1-r6.ebuild b/dev-lang/ruby/ruby-1.8.1-r6.ebuild
index 078123f194b0..ec300e925e04 100644
--- a/dev-lang/ruby/ruby-1.8.1-r6.ebuild
+++ b/dev-lang/ruby/ruby-1.8.1-r6.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r6.ebuild,v 1.3 2004/05/19 20:19:52 fmccor Exp $
-
-IUSE="socks5 tcltk cjk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r6.ebuild,v 1.4 2004/05/26 01:03:01 vapier Exp $
ONIGURUMA="onigd2_2_8"
SNAP_DATE="20040424-1"
inherit flag-o-matic alternatives eutils gnuconfig
-filter-flags -fomit-frame-pointer
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
@@ -18,19 +15,19 @@ SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz
LICENSE="Ruby"
SLOT="1.8"
-KEYWORDS="~amd64 alpha ~hppa -ia64 ~mips ppc sparc x86 ~s390"
+KEYWORDS="x86 ppc sparc ~mips alpha arm ~hppa ~amd64 -ia64 ~s390"
+IUSE="socks5 tcltk cjk"
RDEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
socks5? ( >=net-misc/dante-1.1.13 )
- tcltk? ( dev-lang/tk )
+ tcltk? ( dev-lang/tk )
>=dev-ruby/ruby-config-0.2"
DEPEND="sys-devel/autoconf
sys-apps/findutils
${RDEPEND}"
-
PROVIDE="virtual/ruby"
S=${WORKDIR}/${P%_pre*}
@@ -42,7 +39,7 @@ src_unpack() {
epatch ../${P}-${SNAP_DATE}.diff
popd
- if [ -n "`use cjk`" ] ; then
+ if use cjk ; then
einfo "Applying ${ONIGURUMA}"
pushd ${WORKDIR}/oniguruma
econf --with-rubydir=${S} || die "econf failed"
@@ -51,14 +48,16 @@ src_unpack() {
fi
# Enable build on alpha EV67
- if use alpha; then
+ if use alpha ; then
gnuconfig_update || die "gnuconfig_update failed"
fi
}
src_compile() {
+ filter-flags -fomit-frame-pointer
+
# Socks support via dante
- if [ ! -n "`use socks5`" ] ; then
+ if use socks5; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.
@@ -71,7 +70,9 @@ src_compile() {
export CFLAGS
fi
- econf --program-suffix=${SLOT/./} --enable-shared \
+ econf \
+ --program-suffix=${SLOT/./} \
+ --enable-shared \
`use_enable socks5 socks` \
|| die "econf failed"
emake || die "emake failed"
@@ -102,7 +103,6 @@ pkg_postinst() {
}
pkg_postrm() {
-
if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
fi