summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-07-02 04:11:49 +0000
committerJon Nelson <jnelson@gentoo.org>2002-07-02 04:11:49 +0000
commited653a63bda38f631d9114ff9defd7e8ef03001e (patch)
treea3a7a0074cc7fc68fc4de6df82bd5528f822e833 /dev-lang/python
parentremove old python ebuilds (diff)
downloadhistorical-ed653a63bda38f631d9114ff9defd7e8ef03001e.tar.gz
historical-ed653a63bda38f631d9114ff9defd7e8ef03001e.tar.bz2
historical-ed653a63bda38f631d9114ff9defd7e8ef03001e.zip
update python 2.2.1-r2 ebuild and 2.1.3 ebuild
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog17
-rw-r--r--dev-lang/python/files/digest-python-2.2.1-r21
-rw-r--r--dev-lang/python/files/python-config-2.2.12
-rw-r--r--dev-lang/python/python-2.2.1-r2.ebuild77
4 files changed, 95 insertions, 2 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index d0f182f70278..44c46234e187 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for dev-lang/python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.9 2002/05/30 03:13:31 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.10 2002/07/02 04:11:49 jnelson Exp $
+
+*python-2.1.3 (1 Jul 2002)
+
+ 1 Jul 2002; Jon Nelson <jnelson@gentoo.org>: python-2.1.3.ebuild
+ This is a python 2.1.3 ebuild that does *not* conflict with
+ python 2.2.*
+ Note that 99.9% of the people out there won't use it anyway,
+ because 2.2 will always be selected as most recent. ;-)
+
+*python-2.2.1-r2 (1 Jul 2002)
+
+ 30 Jun 2002; Jon Nelson <jnelson@gentoo.org>: python-2.2.1-r2.ebuild
+ Add "-lm" to the python-config script. Closes bug #4217.
+ 2.2.1-r2 has a 100% identical ebuild file to 2.2.1-r1, just the
+ python-config file has changed.
*python-2.2.1-r1 (29 May 2002)
diff --git a/dev-lang/python/files/digest-python-2.2.1-r2 b/dev-lang/python/files/digest-python-2.2.1-r2
new file mode 100644
index 000000000000..ea99f8857c06
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.2.1-r2
@@ -0,0 +1 @@
+MD5 e7012d611602b62e36073c2fd02396a3 Python-2.2.1.tgz 6535104
diff --git a/dev-lang/python/files/python-config-2.2.1 b/dev-lang/python/files/python-config-2.2.1
index 2bcfdae49fb8..056b27125ae9 100644
--- a/dev-lang/python/files/python-config-2.2.1
+++ b/dev-lang/python/files/python-config-2.2.1
@@ -1,3 +1,3 @@
#!/usr/bin/python
import distutils.sysconfig, string
-print "-lpython2.2 -L /usr/lib/python2.2/config",string.join(string.split(distutils.sysconfig.get_config_var("MODLIBS")))
+print "-lpython2.2 -lm -L/usr/lib/python2.2/config",string.join(string.split(distutils.sysconfig.get_config_var("MODLIBS")))
diff --git a/dev-lang/python/python-2.2.1-r2.ebuild b/dev-lang/python/python-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..ffec2cc19eff
--- /dev/null
+++ b/dev-lang/python/python-2.2.1-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r2.ebuild,v 1.1 2002/07/02 04:11:49 jnelson Exp $
+
+PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
+PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+S=${WORKDIR}/Python-${PV}
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
+
+HOMEPAGE="http://www.python.org"
+LICENSE="PSF-2.2"
+
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )"
+if [ -z "`use build`" -a -z "`use bootstrap`" ]; then
+ DEPEND="$DEPEND dev-libs/expat"
+fi
+RDEPEND="$DEPEND dev-python/python-fchksum"
+
+# The dev-python/python-fchksum RDEPEND is needed to that this python provides
+# the functionality expected from previous pythons.
+
+PROVIDE="virtual/python"
+
+SLOT="2.2"
+
+src_compile() {
+ export OPT="$CFLAGS"
+
+ # adjust makefile to install pydoc into ${D} correctly
+ t=${S}/Makefile.pre.in
+ cp $t $t.orig || die
+ sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
+
+ local myopts
+ #if we are creating a new build image, we remove the dependency on g++
+ if [ "`use build`" -a ! "`use bootstrap`" ]
+ then
+ myopts="--with-cxx=no"
+ fi
+
+ econf --with-fpectl \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ $myopts || die
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr || die
+ rm "${D}/usr/bin/python"
+ dosym python${PYVER_MAJOR} /usr/bin/python
+ dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
+ dodoc README
+
+ # install our own custom python-config
+ exeinto /usr/bin
+ newexe ${FILESDIR}/python-config-${PYVER} python-config
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/lib/python${PYVER}/config
+ doins ${S}/Makefile.pre.in
+
+ # If USE tcltk lets install idle
+ # Need to script the python version in the path
+ if use tcltk; then
+ mkdir "${D}/usr/lib/python${PYVER}/tools"
+ mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
+ dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
+ fi
+}