summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-15 00:32:54 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-15 00:32:54 +0000
commite95b4a2936dffb36c95ab13a082aae171f81233e (patch)
tree79618d59514c6e1491dc0deef45c952167641383 /dev-lang/python
parentwas missing (diff)
downloadhistorical-e95b4a2936dffb36c95ab13a082aae171f81233e.tar.gz
historical-e95b4a2936dffb36c95ab13a082aae171f81233e.tar.bz2
historical-e95b4a2936dffb36c95ab13a082aae171f81233e.zip
Integrated the new tcl-tk scheme. This hasn't been tested much, so people
using these applications, please try it out. I've done this to advance the new scheme and start the testing of it. It's a good thing that tcl and tk are seperated, and the earlier the better.
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/files/digest-python-2.23
-rw-r--r--dev-lang/python/files/digest-python-2.2-r13
-rw-r--r--dev-lang/python/files/digest-python-2.2-r23
-rw-r--r--dev-lang/python/python-2.2-r1.ebuild131
-rw-r--r--dev-lang/python/python-2.2-r2.ebuild131
-rw-r--r--dev-lang/python/python-2.2-r3.ebuild4
6 files changed, 2 insertions, 273 deletions
diff --git a/dev-lang/python/files/digest-python-2.2 b/dev-lang/python/files/digest-python-2.2
deleted file mode 100644
index 0d73e1a12a91..000000000000
--- a/dev-lang/python/files/digest-python-2.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 87febf0780c8e18454022d34b2ca70a0 Python-2.2.tgz 6557696
-MD5 03be17baafacc3508224d9542c0a61b3 python-fchksum-1.6.tar.gz 36864
-MD5 3f79a00b72d7282ecbbadc4effb00683 python-fchksum_1.6-2.diff.gz 24576
diff --git a/dev-lang/python/files/digest-python-2.2-r1 b/dev-lang/python/files/digest-python-2.2-r1
deleted file mode 100644
index 79484978b348..000000000000
--- a/dev-lang/python/files/digest-python-2.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 87febf0780c8e18454022d34b2ca70a0 Python-2.2.tgz 6545408
-MD5 03be17baafacc3508224d9542c0a61b3 python-fchksum-1.6.tar.gz 36864
-MD5 3f79a00b72d7282ecbbadc4effb00683 python-fchksum_1.6-2.diff.gz 24576
diff --git a/dev-lang/python/files/digest-python-2.2-r2 b/dev-lang/python/files/digest-python-2.2-r2
deleted file mode 100644
index 79484978b348..000000000000
--- a/dev-lang/python/files/digest-python-2.2-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 87febf0780c8e18454022d34b2ca70a0 Python-2.2.tgz 6545408
-MD5 03be17baafacc3508224d9542c0a61b3 python-fchksum-1.6.tar.gz 36864
-MD5 3f79a00b72d7282ecbbadc4effb00683 python-fchksum_1.6-2.diff.gz 24576
diff --git a/dev-lang/python/python-2.2-r1.ebuild b/dev-lang/python/python-2.2-r1.ebuild
deleted file mode 100644
index c632f236e76a..000000000000
--- a/dev-lang/python/python-2.2-r1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r1.ebuild,v 1.1 2002/01/03 16:41:37 drobbins Exp $
-
-S=${WORKDIR}/Python-${PV}
-FCHKSUM="python-fchksum-1.6"
-FCHKSUMP="python-fchksum_1.6-2"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUMP}.diff.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tcl-tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.2"
-
-src_unpack() {
- # unpack python
- unpack Python-${PV}.tgz
- # unpack fchksum and move pieces into Modules subdir
- cd ${S}/Modules
- unpack ${FCHKSUM}.tar.gz
- zcat ${DISTDIR}/${FCHKSUMP}.diff.gz | patch -p0
- cd ${FCHKSUM}
- cp md5.h ../md5_2.h
- cp cksum.[ch] sum.[ch] fchksum.h ..
- sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
- # add fchksum configuration to Setup
- cd ${S}
- echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-}
-
-src_compile() {
- # python's config seems to ignore CFLAGS
- export OPT=$CFLAGS
-
- # configure fchksum
- cd ${S}/Modules/${FCHKSUM}
- ./configure
- cp pfconfig.h ..
-
- # adjust Setup to include the various modules we need
- cd ${S}
- scmd=""
- # adjust for USE readline
- if use readline; then
- scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
- scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
- fi
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s:# \(_tkinter \):\1:;"
- scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
- scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
- scmd="$scmd s:#\(\t-lX11.*\):\1:;"
- fi
- # adjust for USE berkdb
- if use berkdb; then
- # patch the dbmmodule to use db3's dbm compatibility code. That way,
- # we're depending on db3 rather than old db1.
- t=Modules/dbmmodule.c
- cp $t $t.orig || die
- sed \
- -e '10,25d' \
- -e '26i\' \
- -e '#define DB_DBM_HSEARCH 1\' \
- -e 'static char *which_dbm = "BSD db";\' \
- -e '#include <db3/db.h>' \
- $t.orig > $t
- # now fix Setup
- scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
- fi
- # no USE vars to switch off these adjustments:
- scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
- scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
- scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
- scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
- sed "$scmd" Modules/Setup.dist > Modules/Setup
-
- ./configure \
- --prefix=/usr \
- --without-libdb \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man
- assert "Configure failed"
- # kill the -DHAVE_CONFIG_H flag
- mv Makefile Makefile.orig
- sed -e 's/-DHAVE_CONFIG_H//' Makefile.orig > Makefile
- #emake || die "Parallel make failed"
- make || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python2.2 /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-2.2 python-config
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- mkdir "${D}/usr/lib/python2.2/tools"
- mv "${S}/Tools/idle" "${D}/usr/lib/python2.2/tools/"
- dosym /usr/lib/python2.2/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
diff --git a/dev-lang/python/python-2.2-r2.ebuild b/dev-lang/python/python-2.2-r2.ebuild
deleted file mode 100644
index cd8cb230dc00..000000000000
--- a/dev-lang/python/python-2.2-r2.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r2.ebuild,v 1.1 2002/01/05 22:17:02 g2boojum Exp $
-
-S=${WORKDIR}/Python-${PV}
-FCHKSUM="python-fchksum-1.6"
-FCHKSUMP="python-fchksum_1.6-2"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUMP}.diff.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tcl-tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.2"
-
-src_unpack() {
- # unpack python
- unpack Python-${PV}.tgz
- # unpack fchksum and move pieces into Modules subdir
- cd ${S}/Modules
- unpack ${FCHKSUM}.tar.gz
- zcat ${DISTDIR}/${FCHKSUMP}.diff.gz | patch -p0
- cd ${FCHKSUM}
- cp md5.h ../md5_2.h
- cp cksum.[ch] sum.[ch] fchksum.h ..
- sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
- # add fchksum configuration to Setup
- cd ${S}
- echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-}
-
-src_compile() {
- # python's config seems to ignore CFLAGS
- export OPT=$CFLAGS
-
- # configure fchksum
- cd ${S}/Modules/${FCHKSUM}
- ./configure
- cp pfconfig.h ..
-
- # adjust Setup to include the various modules we need
- cd ${S}
- scmd=""
- # adjust for USE readline
- if use readline; then
- scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
- scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
- fi
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s:# \(_tkinter \):\1:;"
- scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
- scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
- scmd="$scmd s:#\(\t-lX11.*\):\1:;"
- fi
- # adjust for USE berkdb
- if use berkdb; then
- # patch the dbmmodule to use db3's dbm compatibility code. That way,
- # we're depending on db3 rather than old db1.
- t=Modules/dbmmodule.c
- cp $t $t.orig || die
- sed \
- -e '10,25d' \
- -e '26i\' \
- -e '#define DB_DBM_HSEARCH 1\' \
- -e 'static char *which_dbm = "BSD db";\' \
- -e '#include <db3/db.h>' \
- $t.orig > $t
- # now fix Setup
- scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
- fi
- # no USE vars to switch off these adjustments:
- scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
- scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
- scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
- scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
- sed "$scmd" Modules/Setup.dist > Modules/Setup
-
- ./configure \
- --prefix=/usr \
- --without-libdb \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man
- assert "Configure failed"
- # kill the -DHAVE_CONFIG_H flag
- mv Makefile Makefile.orig
- sed -e 's/-DHAVE_CONFIG_H//' Makefile.orig > Makefile
- #emake || die "Parallel make failed"
- make || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python2.2 /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-2.2 python-config
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- mkdir "${D}/usr/lib/python2.2/tools"
- mv "${S}/Tools/idle" "${D}/usr/lib/python2.2/tools/"
- dosym /usr/lib/python2.2/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
diff --git a/dev-lang/python/python-2.2-r3.ebuild b/dev-lang/python/python-2.2-r3.ebuild
index 2ebafa965f41..cf09963e7d85 100644
--- a/dev-lang/python/python-2.2-r3.ebuild
+++ b/dev-lang/python/python-2.2-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r3.ebuild,v 1.1 2002/01/14 22:06:05 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r3.ebuild,v 1.2 2002/01/15 00:32:54 gbevin Exp $
PYVER="`echo ${PV} | cut -d '.' -f 1,2`"
S=${WORKDIR}/Python-${PV}
@@ -17,7 +17,7 @@ HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum
DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tcl-tk-8.0 )"
+ tcltk? ( >=dev-lang/tk-8.0 )"
RDEPEND="$DEPEND"
PROVIDE="virtual/python-${PYVER}"