summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-05-07 16:36:19 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-05-07 16:36:19 +0000
commitd2ff2e72f29fb664e7090f2558135fc7a621b187 (patch)
tree16fe5015cd6ac4440f889b1f9258e35db0110d84 /dev-lang/python
parentfinally a new update to openoffice-ximian-bin (diff)
downloadhistorical-d2ff2e72f29fb664e7090f2558135fc7a621b187.tar.gz
historical-d2ff2e72f29fb664e7090f2558135fc7a621b187.tar.bz2
historical-d2ff2e72f29fb664e7090f2558135fc7a621b187.zip
Don't skip sax test.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/Manifest10
-rw-r--r--dev-lang/python/python-2.3.5.ebuild31
-rw-r--r--dev-lang/python/python-2.4.1.ebuild4
3 files changed, 9 insertions, 36 deletions
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 2a2437497ee7..18ecfa86a7b0 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -5,9 +5,9 @@ MD5 1e424541a26b4d5785a6e830e6a14fe8 python-2.2.3-r6.ebuild 4498
MD5 7f3667e4438f584ce1c60834a8d8c6d8 ChangeLog 24193
MD5 8145ce0144332d6caca98fa5fb648741 metadata.xml 221
MD5 b0dabb5b661c34b2054f5ae852c2fd45 python-2.1.3-r1.ebuild 2329
-MD5 c2855c96958ce131b60abeb826387439 python-2.4.1.ebuild 7952
+MD5 1e8979b45045a6cbc3aa3db2af675ff6 python-2.4.1.ebuild 7948
MD5 6bfece64d89a1688ed4736f94a5b966e python-2.3.4-r1.ebuild 7182
-MD5 79152d78bd231a04f69f481035c088fd python-2.3.5.ebuild 8450
+MD5 bddd8b7e2c3c82073567a8663e7bf30b python-2.3.5.ebuild 7717
MD5 11883082a4dbea2432a68330776944dd python-2.4-r3.ebuild 7102
MD5 47e9455f3e16c3369c9e57388ba3d643 files/python-2.4.1-readline.patch 8984
MD5 1cf4c21ad3b0aafc571b05b9a9e54594 files/python-updater 8761
@@ -53,7 +53,7 @@ MD5 6eab04aaa6abe2b795e4e5f4983bea38 files/python-2.4-readline.patch 9099
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCfO07Kf2g/qXtneoRAtZnAJ0VoM2G7xYPZnxSNHF2pZOlYrZ2IgCePUBd
-spoZohfpzaqTodG8cej2jbI=
-=6Wd4
+iD8DBQFCfO6WKf2g/qXtneoRAiHoAKCNSa/nCF7DzAocHF92bk+1KkUITwCfXMIy
+Jg/ogeALjcvhZ2cL6IMIlqA=
+=RPlp
-----END PGP SIGNATURE-----
diff --git a/dev-lang/python/python-2.3.5.ebuild b/dev-lang/python/python-2.3.5.ebuild
index 163bcf826dcb..e8ec9d6b1f05 100644
--- a/dev-lang/python/python-2.3.5.ebuild
+++ b/dev-lang/python/python-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.11 2005/05/07 16:30:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.12 2005/05/07 16:36:19 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -134,33 +134,6 @@ src_compile() {
emake || die "Parallel make failed"
}
-src_test() {
- local skip_tests="import sax"
- #Move known bad tests out of the way while we run good ones
- for test in ${skip_tests} ; do
- mv ${S}/Lib/test/test_${test}.py ${T}
- done
-
- make test || die "make test failed"
-
- #Move bad tests back so they get emerged
- for test in ${skip_tests} ; do
- mv ${T}/test_${test}.py ${S}/Lib/test/test_${test}.py
- done
-
- einfo "Portage skipped the following tests which aren't able to run from emerge:"
- for test in ${skip_tests} ; do
- einfo "test_${test}.py"
- done
- einfo "These tests normally pass when not run from emerge."
- einfo "If you'd like to run them, you may:"
- einfo "cd /usr/lib/python${PYVER}/test"
- einfo "and run the tests separately."
- einfo "See bug# 67970"
- ebeep 2
-}
-
-
src_install() {
dodir /usr
src_configure
@@ -240,7 +213,7 @@ src_test() {
#skip all tests that fail during emerge but pass without emerge:
#(See bug# 67970)
- local skip_tests="sax subprocess tcl urllib urllib2"
+ local skip_tests="subprocess tcl urllib urllib2"
for test in ${skip_tests} ; do
mv ${S}/Lib/test/test_${test}.py ${T}
diff --git a/dev-lang/python/python-2.4.1.ebuild b/dev-lang/python/python-2.4.1.ebuild
index 6081b77bc045..7773397d5e50 100644
--- a/dev-lang/python/python-2.4.1.ebuild
+++ b/dev-lang/python/python-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.3 2005/05/07 16:30:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.4 2005/05/07 16:36:19 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -231,7 +231,7 @@ src_test() {
#skip all tests that fail during emerge but pass without emerge:
#(See bug# 67970)
- local skip_tests="sax subprocess tcl urllib urllib2"
+ local skip_tests="subprocess tcl urllib urllib2"
for test in ${skip_tests} ; do
mv ${S}/Lib/test/test_${test}.py ${T}