summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-03-14 14:43:20 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-03-14 14:43:20 +0000
commitc9340e01a32120bb4f4132d945c63b0233adf0e4 (patch)
treec9496b7259e8bea3f56c154aaa64538642014d64 /dev-lang/pugs
parentinitial import (diff)
downloadhistorical-c9340e01a32120bb4f4132d945c63b0233adf0e4.tar.gz
historical-c9340e01a32120bb4f4132d945c63b0233adf0e4.tar.bz2
historical-c9340e01a32120bb4f4132d945c63b0233adf0e4.zip
Introducing pugs, an implenetation of perl6 in haskell
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lang/pugs')
-rw-r--r--dev-lang/pugs/ChangeLog13
-rw-r--r--dev-lang/pugs/Manifest14
-rw-r--r--dev-lang/pugs/files/digest-pugs-6.0.111
-rw-r--r--dev-lang/pugs/metadata.xml10
-rw-r--r--dev-lang/pugs/pugs-6.0.11.ebuild37
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-lang/pugs/ChangeLog b/dev-lang/pugs/ChangeLog
new file mode 100644
index 000000000000..7ef7a676c801
--- /dev/null
+++ b/dev-lang/pugs/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-lang/pugs
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/ChangeLog,v 1.1 2005/03/14 14:43:20 mcummings Exp $
+
+*pugs-6.0.11 (14 Mar 2005)
+
+ 14 Mar 2005; Michael Cummings <mcummings@gentoo.org> +metadata.xml,
+ +pugs-6.0.11.ebuild:
+ Introducing pugs, an implementation of the not yet released perl6 language
+ using haskell. Ebuild worked on tirelessly by Adrian Lambeck
+ <adrian@basicsedv.de> in bug 8335. This is being added to dev-lang since
+ currently it is a seperate entity from dev-lang/perl.
+
diff --git a/dev-lang/pugs/Manifest b/dev-lang/pugs/Manifest
new file mode 100644
index 000000000000..dd7fc88f4dee
--- /dev/null
+++ b/dev-lang/pugs/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e195d07dd8c771cb3816ab6cece1510e metadata.xml 464
+MD5 071b0e3e4022ab788fa5c846cc4d45a9 pugs-6.0.11.ebuild 1077
+MD5 1138bd9f086106dced69d5b13e84f757 ChangeLog 595
+MD5 9b22fae8c9c831a52de40862635a0763 files/digest-pugs-6.0.11 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCNaMVtG5z4I8BtQoRAmMwAJ0Uo+6nLYDaPfnHwm9TMiyOA5M4mwCcCqrO
+ETU+nxiLsq+KaDYYNaH4cY0=
+=eIgo
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/pugs/files/digest-pugs-6.0.11 b/dev-lang/pugs/files/digest-pugs-6.0.11
new file mode 100644
index 000000000000..f3652d9f31a4
--- /dev/null
+++ b/dev-lang/pugs/files/digest-pugs-6.0.11
@@ -0,0 +1 @@
+MD5 0ff4b1f4b93d2288894e975f0e4926a1 Perl6-Pugs-6.0.11.tar.gz 315826
diff --git a/dev-lang/pugs/metadata.xml b/dev-lang/pugs/metadata.xml
new file mode 100644
index 000000000000..c4275e586dbe
--- /dev/null
+++ b/dev-lang/pugs/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription>Pugs is a peek at what perl6 will be like. It aims to implement the full Perl6 specification, as detailed in the Synopses(http://dev.perl.org/perl6/synopsis/).</longdescription>
+</pkgmetadata>
diff --git a/dev-lang/pugs/pugs-6.0.11.ebuild b/dev-lang/pugs/pugs-6.0.11.ebuild
new file mode 100644
index 000000000000..01fbe18c4910
--- /dev/null
+++ b/dev-lang/pugs/pugs-6.0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/pugs-6.0.11.ebuild,v 1.1 2005/03/14 14:43:20 mcummings Exp $
+
+inherit perl-module
+
+MY_P="Perl6-Pugs-${PV}"
+S="${WORKDIR}/-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Pugs is an implementation of Perl 6, written in Haskell"
+HOMEPAGE="http://pugscode.org/"
+SRC_URI="mirror://cpan/authors/id/A/AU/AUTRIJUS/${MY_P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+
+# Not sure how kosher this approach is - basically didn't want to force
+# the user to compile ghc if they didn't already have a copy - but didn't want
+# to force ghc-bin if they had a copy of ghc already installed.
+
+if has "dev-lang/ghc" ; then
+ DEPEND=">=dev-lang/ghc-6.2.1
+ dev-perl/Term-ReadLine-Perl"
+else
+ DEPEND=">=dev-lang/ghc-bin-6.2.1
+ dev-perl/Term-ReadLine-Perl"
+fi
+
+#TODO:
+#headers for readline are missing -> does not work yet !
+ #readline? (>=dev-perl/Term-ReadLine-Perl-1.0203
+ #>=sys-libs/readline-4.3-r5)
+