summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2002-12-09 16:38:27 +0000
committerJon Portnoy <avenj@gentoo.org>2002-12-09 16:38:27 +0000
commit3b0c1e9fd2ffd7d28178b3843d0d08c51af5947c (patch)
tree63a16a6c14aca332aa4e65ee7c316614856b981d /dev-lang/ifc
parentFixes bug #11466 (diff)
downloadhistorical-3b0c1e9fd2ffd7d28178b3843d0d08c51af5947c.tar.gz
historical-3b0c1e9fd2ffd7d28178b3843d0d08c51af5947c.tar.bz2
historical-3b0c1e9fd2ffd7d28178b3843d0d08c51af5947c.zip
Ebuild for the latest IFC
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog11
-rw-r--r--dev-lang/ifc/files/7.0.064/05icc-ifc6
-rw-r--r--dev-lang/ifc/files/digest-ifc-7.0.0641
-rw-r--r--dev-lang/ifc/ifc-7.0.064.ebuild98
4 files changed, 112 insertions, 4 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index d54c5e03d39b..18802fd98d04 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for dev-lang/icc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.2 2002/12/09 04:20:58 manson Exp $
+# $Header:
+
+*ifc-7.0.064 (9 Dec 2002)
+
+ 9 Dec 2002 Jon Portnoy <avenj@gentoo.org> icc-7.0.064.ebuild :
+
+ Latest IFC, ebuild submitted by Daniel Jaeggi (daniel@jaeggi.co.uk)
-\* Autoupdate keywords (12-6-02)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
-
*ifc-6.0 (13 May 2002)
13 May 2002 William McArthur <sandymac@gentoo.org> icc-6.0.ebuild :
diff --git a/dev-lang/ifc/files/7.0.064/05icc-ifc b/dev-lang/ifc/files/7.0.064/05icc-ifc
new file mode 100644
index 000000000000..7134ac814afd
--- /dev/null
+++ b/dev-lang/ifc/files/7.0.064/05icc-ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler70/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler70/ia32/lib
+MANPATH=/opt/intel/compiler70/man
+PATH=/opt/intel/compiler70/ia32/bin
+ROOTPATH=/opt/intel/compiler70/ia32/bin
diff --git a/dev-lang/ifc/files/digest-ifc-7.0.064 b/dev-lang/ifc/files/digest-ifc-7.0.064
new file mode 100644
index 000000000000..57c793e8ecf4
--- /dev/null
+++ b/dev-lang/ifc/files/digest-ifc-7.0.064
@@ -0,0 +1 @@
+MD5 43a618fbdd8ce01917c5ae656f58bfe4 l_fc_p_7.0.064.tar 88709120
diff --git a/dev-lang/ifc/ifc-7.0.064.ebuild b/dev-lang/ifc/ifc-7.0.064.ebuild
new file mode 100644
index 000000000000..774d9668d540
--- /dev/null
+++ b/dev-lang/ifc/ifc-7.0.064.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}
+DESCRIPTION="Intel Fortran Compiler - The Pentium optimized compiler for Linux"
+
+SRC_URI1="http://developer.intel.com/software/products/compilers/downloads/l_fc_p_7.0.064.tar"
+SRC_URI2="ftp://download.intel.com/software/products/compilers/downloads/l_fc_p_7.0.064.tar"
+SRC_URI3="ftp://download.intel.co.jp/software/products/compilers/downloads/l_fc_p_7.0.064.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2} ${SRC_URI3}"
+
+HOMEPAGE="http://developer.intel.com/software/products/compilers/flin/"
+
+ # Effectively the same license as icc
+LICENSE="icc-7.0"
+SLOT="0"
+KEYWORDS="~x86"
+
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4"
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler70/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ SUPPORTFILE=${SD}/compiler70/docs/fsupport
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+
+ SUPPORTFILE=${SD}/compiler70/docs/idbsupport
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+}
+
+src_install () {
+ dodoc flicense
+ cp -a opt ${D}
+
+ # ifc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/flin/noncom.htm"
+ einfo "From the above url you can get a free, non-time limited, non-commercial"
+ einfo "personal use license key that comes with no support. You will need to read"
+ einfo "and agree to the license and then fill in your info to have one emailed to"
+ einfo "you. Read the website for the details."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler70/docs/"
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/"
+ einfo
+ if [ -d /opt/intel/compiler[56]0 ]
+ then
+ ewarn
+ ewarn "Packages compiled with older versions of icc will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change 'compiler70'"
+ ewarn "to 'compiler60' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ fi
+ ewarn "Due to a bug in ifc 7.0, the primary executable (ifc) may not work."
+ ewarn "Instead of invoking the compiler as ifc, use ifcbin."
+}