summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-03-22 19:33:43 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-03-22 19:33:43 +0000
commitf66d0f9e4b77ae343e7068d928c3c674a1d43277 (patch)
treedad1af7107d87324bc4bb48190fb7d888d6b721b /dev-lang/ghc
parentVersion bump, fixed copyrights, added metadata.xml with herd as media-video. (diff)
downloadhistorical-f66d0f9e4b77ae343e7068d928c3c674a1d43277.tar.gz
historical-f66d0f9e4b77ae343e7068d928c3c674a1d43277.tar.bz2
historical-f66d0f9e4b77ae343e7068d928c3c674a1d43277.zip
new ghc version 6.2.1
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/Manifest4
-rw-r--r--dev-lang/ghc/files/digest-ghc-6.2.11
-rw-r--r--dev-lang/ghc/ghc-6.2.1.ebuild162
4 files changed, 172 insertions, 2 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index e9c96facdfe2..23d0e10efed9 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.28 2004/03/11 12:43:23 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.29 2004/03/22 19:33:43 kosmikus Exp $
+
+*ghc-6.2.1 (22 Mar 2004)
+
+ 22 Mar 2004; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.1.ebuild:
+ Version bump.
*ghc-6.2-r1 (11 Mar 2004)
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index 28d16f024434..fa7bd9d464ea 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,8 +1,9 @@
+MD5 7b978be025bfcd06858fc407c1a6de33 ghc-6.2.1.ebuild 5146
MD5 e95779532f1a701a9f0a29bab9447ead ghc-5.04.3-r1.ebuild 7402
MD5 e6cb655b6e491861cde72bf8695c53eb ghc-6.0.ebuild 4282
MD5 802669d9b27965494cb6b7e4d8cece09 ghc-6.2.ebuild 5065
MD5 eb902d291c43516728dc3b4e00834029 ghc-6.0.1.ebuild 4878
-MD5 f35e220ac554e9dcb54fb5f467b20751 ChangeLog 6467
+MD5 6f93d75c20ad6d5fd0549285f3878bee ChangeLog 6577
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 6f91c4a82ebba2f3ce7f2704257f0adb ghc-6.2-r1.ebuild 5235
MD5 9da9270be8ac4d92d6a5c23fd519cc3c files/lndir.c 8050
@@ -10,6 +11,7 @@ MD5 9c184505ec441675c94d47a3110fa754 files/ghc-6.2.documentation.patch 721
MD5 d4a4184d5dcf525047332f9c68e522f7 files/ghc-5.04.3-r1.patch 2717
MD5 a20f2d9eabadd7ed4890784b905f857c files/digest-ghc-5.04.3-r1 68
MD5 d417c9e24a826959ad6d921247e43328 files/digest-ghc-6.0.1 67
+MD5 0cc23d312b60d64e20735768503db1c6 files/digest-ghc-6.2.1 67
MD5 f210562a7af8d7d2aad2c1f7100c2a40 files/ghc-6.2.hardened-gcc.patch.bz2 471
MD5 2e1bd1157c6d47093864b670d6b51a64 files/digest-ghc-6.2-r1 65
MD5 1b6997afc8940a5df3f780897d78ee0a files/digest-ghc-6.0 65
diff --git a/dev-lang/ghc/files/digest-ghc-6.2.1 b/dev-lang/ghc/files/digest-ghc-6.2.1
new file mode 100644
index 000000000000..61f5b8e7bb46
--- /dev/null
+++ b/dev-lang/ghc/files/digest-ghc-6.2.1
@@ -0,0 +1 @@
+MD5 fa9f90fd6b8852679c5fc16509e94d7a ghc-6.2.1-src.tar.bz2 5367409
diff --git a/dev-lang/ghc/ghc-6.2.1.ebuild b/dev-lang/ghc/ghc-6.2.1.ebuild
new file mode 100644
index 000000000000..d27c28d3abeb
--- /dev/null
+++ b/dev-lang/ghc/ghc-6.2.1.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.1.ebuild,v 1.1 2004/03/22 19:33:43 kosmikus Exp $
+
+#Some explanation of bootstrap logic:
+#
+#After thinking through the best way to bootstrap ghc I decided to split it into
+#ghc and ghc-bin and make ghc depend on ghc-bin.
+# The ebuild has been revamped and greatly simplified. Bootstrap off old 4x hc files no longer works on x86.
+#Not sure what happens with old scheme on sparc, as I did not see any test reports.
+#
+#The considerations:
+#Making ghc unpack binary build first (under ${WORKDIR}) and bootstrapping from that will effectively force
+#ghc-bin reinstall every time ghc is rebuilt or upgraded. What is worse it will likely force download of binary image
+#at upgrade, which is not nice (in fact quite bad for modem users - 16+ MB).
+#
+#The best results are achieved if ghc-bin is left alone after ghc installation -
+#Both ebuilds install in the same place, thus space penalty is minimal. In fact only the docs exist in double
+#(considering that ghc is not installing much docs at present this looks more like an advantage).
+#When the upgrade time comes, if you still have ghc-bin around, portage will happily bootstrap off
+#your existing ghc (or ghc-bin, whichever was merged last), without attempting to ruin anything...
+#
+#There is only one issue: ghci will be successfully built only if ghc is bootstrapped from the same version.
+#Thus we need to detect presently installed one and bootstrap in one or two stages..
+
+inherit base
+
+IUSE="doc tetex opengl"
+
+DESCRIPTION="The Glasgow Haskell Compiler"
+HOMEPAGE="http://www.haskell.org/ghc/"
+
+SRC_URI="http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-src.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 -ppc -alpha"
+
+
+PROVIDE="virtual/ghc"
+# FIXME: Add USE support for parallel haskell (requires PVM)
+# Get PVM from ftp://ftp.netlib.org/pvm3/
+DEPEND="virtual/ghc
+ >=dev-lang/perl-5.6.1
+ >=sys-devel/gcc-2.95.3
+ >=sys-devel/make-3.79.1
+ >=sys-apps/sed-3.02.80
+ >=sys-devel/flex-2.5.4a
+ >=dev-libs/gmp-4.1
+ doc? ( >=app-text/openjade-1.3.1
+ >=app-text/sgml-common-0.6.3
+ =app-text/docbook-sgml-dtd-3.1-r1
+ >=app-text/docbook-dsssl-stylesheets-1.64
+ >=dev-haskell/haddock-0.6-r2
+ tetex? ( >=app-text/tetex-1.0.7
+ >=app-text/jadetex-3.12 ) )
+ opengl? ( virtual/opengl
+ virtual/glu
+ virtual/glut )"
+
+RDEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.3
+ >=dev-lang/perl-5.6.1
+ >=dev-libs/gmp-4.1
+ opengl? ( virtual/opengl virtual/glu virtual/glut )"
+
+# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
+GHCPATH="${PATH}:/opt/ghc/bin"
+
+src_unpack() {
+ base_src_unpack
+
+ # hardened-gcc needs to be disabled, because the
+ # mangler doesn't accept its output; yes, the 6.2 version
+ # should do ...
+ cd ${S}
+ bzcat ${FILESDIR}/ghc-6.2.hardened-gcc.patch.bz2 | patch -p1
+}
+
+src_compile() {
+ local myconf
+ if [ `use opengl` ]; then
+ myconf="--enable-hopengl"
+ fi
+
+ # disable the automatic PIC building which is considered as Prologue Junk by the Haskell Compiler
+ # thanks to Peter Simons for finding this and giving notice on bugs.gentoo.org
+ # (this is still necessary, even though we have the patch, because
+ # we might be bootstrapping from a version that didn't have the
+ # patch included)
+ if has_version "sys-devel/hardened-gcc"
+ then
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> mk/build.mk
+ fi
+
+ # force the config variable ArSupportsInput to be unset;
+ # ar in binutils >= 2.14.90.0.8-r1 seems to be classified
+ # incorrectly by the configure script
+ echo "ArSupportsInput:=" >> mk/build.mk
+
+ # unset SGML_CATALOG_FILES because documentation installation
+ # breaks otherwise ...
+ PATH="${GHCPATH}" SGML_CATALOG_FILES="" econf \
+ --enable-threaded-rts ${myconf} || die "econf failed"
+
+ # the build does not seem to work all that
+ # well with parallel make
+ make || die "make failed"
+
+ # if documentation has been requested, build documentation ...
+ if use doc; then
+ make html || die "make html failed"
+ if use tetex; then
+ make ps || die "make ps failed"
+ fi
+ fi
+
+}
+
+src_install () {
+ local mydoc
+ local insttarget
+
+ insttarget="install"
+
+ # determine what to do with documentation
+ if [ `use doc` ]; then
+ mydoc="html"
+ insttarget="${insttarget} install-docs"
+ if [ `use tetex` ]; then
+ mydoc="${mydoc} ps"
+ fi
+ else
+ mydoc=""
+ # needed to prevent haddock from being called
+ echo NO_HADDOCK_DOCS=YES >> mk/build.mk
+ fi
+ echo SGMLDocWays="${mydoc}" >> mk/build.mk
+
+ make ${insttarget} \
+ prefix="${D}/usr" \
+ datadir="${D}/usr/share/doc/${PF}" \
+ infodir="${D}/usr/share/info" \
+ mandir="${D}/usr/share/man" || die
+
+ #need to remove ${D} from ghcprof script
+ cd ${D}/usr/bin
+ mv ghcprof ghcprof-orig
+ sed -e 's:$FPTOOLS_TOP_ABS:#$FPTOOLS_TOP_ABS:' ghcprof-orig > ghcprof
+ chmod a+x ghcprof
+ rm -f ghcprof-orig
+
+ cd ${S}/ghc
+ dodoc README ANNOUNCE LICENSE VERSION
+}
+
+
+pkg_postinst () {
+ einfo "If you have dev-lang/ghc-bin installed, you might"
+ einfo "want to unmerge it again. It is no longer needed."
+}