summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-18 22:54:07 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-18 22:54:07 +0000
commit95b759a3250d10b78050729dcb8b79346ca0249b (patch)
treecc27db253fe36e99782808cdb40638e84b899ad6 /dev-lang/ghc-bin
parentstable on mips wrt bug 67326 (diff)
downloadhistorical-95b759a3250d10b78050729dcb8b79346ca0249b.tar.gz
historical-95b759a3250d10b78050729dcb8b79346ca0249b.tar.bz2
historical-95b759a3250d10b78050729dcb8b79346ca0249b.zip
fix environment settings
Diffstat (limited to 'dev-lang/ghc-bin')
-rw-r--r--dev-lang/ghc-bin/ChangeLog5
-rw-r--r--dev-lang/ghc-bin/Manifest4
-rw-r--r--dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild27
3 files changed, 25 insertions, 11 deletions
diff --git a/dev-lang/ghc-bin/ChangeLog b/dev-lang/ghc-bin/ChangeLog
index 582966120424..db4124cdcd38 100644
--- a/dev-lang/ghc-bin/ChangeLog
+++ b/dev-lang/ghc-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc-bin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.18 2004/10/18 17:03:04 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.19 2004/10/18 22:54:07 kosmikus Exp $
+
+ 19 Oct 2004; Andres Loeh <kosmikus@gentoo.org> ghc-bin-6.2.1.ebuild:
+ Fix amd64 version to properly install environment file.
*ghc-bin-6.2.2 (18 Oct 2004)
diff --git a/dev-lang/ghc-bin/Manifest b/dev-lang/ghc-bin/Manifest
index 0c3a1d8a0099..e56241faeb75 100644
--- a/dev-lang/ghc-bin/Manifest
+++ b/dev-lang/ghc-bin/Manifest
@@ -1,8 +1,8 @@
MD5 6bcb39e43042ae34b089d7ed5aff38b0 ghc-bin-6.2.2.ebuild 1375
-MD5 3f291f6738dd4cf28df0bee0575d7732 ghc-bin-6.2.1.ebuild 1341
+MD5 091b42749e14c5649f08db531056d98d ghc-bin-6.2.1.ebuild 1567
MD5 08266b96fed68394570f9610a3e4e90b ghc-bin-5.04.3.ebuild 1504
MD5 4e3dbc12aff326b145ce1d8a4ee4f9a0 ghc-bin-6.0.ebuild 1502
-MD5 3e94ee731839f7bd14cc6c217e2e585a ChangeLog 3222
+MD5 1e5070f1fd11a726734c6985e674421f ChangeLog 3352
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 dc2076294cb2b94c5cfe811acf61ad68 ghc-bin-6.2.ebuild 1374
MD5 a82ba08a8abb4ae38bcc8d467c665e7b files/10ghc 40
diff --git a/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild b/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild
index cb0e3b8486f0..d66b69683c79 100644
--- a/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild,v 1.1 2004/10/17 09:05:32 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild,v 1.2 2004/10/18 22:54:07 kosmikus Exp $
IUSE=""
@@ -8,13 +8,16 @@ S="${WORKDIR}"
DESCRIPTION="Glasgow Haskell Compiler (binary-only version for amd64)"
SRC_URI="http://debian-amd64.alioth.debian.org/pure64/pool/unstable/main/amd64/g/ghc6/ghc6_6.2.1-5_amd64.deb"
HOMEPAGE="http://www.haskell.org"
+
LICENSE="as-is"
KEYWORDS="-* ~amd64"
SLOT="0"
+
DEPEND="app-arch/dpkg"
RDEPEND=">=dev-lang/perl-5.6.1
>=sys-devel/gcc-2.95.3
>=dev-libs/gmp-4.1"
+
PROVIDE="virtual/ghc"
src_unpack() {
@@ -38,16 +41,24 @@ src_install () {
# Generate symlinks in ${D}/opt/ghc/bin
mkdir -p ${D}/opt/ghc/bin
pushd ${D}/opt/ghc/bin
- ln -s ../lib/bin/ghc ghc6
- ln -s ../lib/bin/ghci ghci6
- ln -s ghc6 ghc
- ln -s ghci6 ghci
+ ln -s ../lib/bin/ghc ghc-${PV}
+ ln -s ../lib/bin/ghci ghci-${PV}
+ ln -s ghc-${PV} ghc
+ ln -s ghci-${PV} ghci
popd
+ # TODO: what about documentation
+ # TODO: can clean_wrappers be reused from the other ghc-bin
+ # ebuilds; isn't RDEPEND perl needed if we call perl here?
+
# Adjust paths in ${D}/opt/ghc/lib/bin
pushd ${D}/opt/ghc/lib/bin
- perl -i -ne 's#/usr/lib/ghc-6.2.1#/opt/ghc/lib#g;
- s#/usr/share/ghc-6.2.1#/opt/ghc/share#g;print' \
- ghc-6.2.1 ghci-6.2.1 ghcprof hsc2hs ghc-pkg-6.2.1
+ perl -i -ne "s:/usr/lib/ghc-${PV}:/opt/ghc/lib:g;
+ s:/usr/share/ghc-${PV}:/opt/ghc/share:g;print" \
+ ghc-${PV} ghci-${PV} ghcprof hsc2hs ghc-pkg-${PV}
popd
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10ghc
+
}