summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-21 16:40:44 +0000
committerChris White <chriswhite@gentoo.org>2004-08-21 16:40:44 +0000
commit025c5caf7b1549bb373d7193fd94b8950020f0a4 (patch)
tree5837b6088f847a8e686509e9e4f3df1658880a87 /dev-lang/fpc-source
parentfpc-source is in testing and is a cvs snapshot. (diff)
downloadhistorical-025c5caf7b1549bb373d7193fd94b8950020f0a4.tar.gz
historical-025c5caf7b1549bb373d7193fd94b8950020f0a4.tar.bz2
historical-025c5caf7b1549bb373d7193fd94b8950020f0a4.zip
Initial import into the tree for testing.
Diffstat (limited to 'dev-lang/fpc-source')
-rw-r--r--dev-lang/fpc-source/ChangeLog10
-rw-r--r--dev-lang/fpc-source/Manifest4
-rw-r--r--dev-lang/fpc-source/files/digest-fpc-source-1.9.5_pre200408202
-rw-r--r--dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild62
-rw-r--r--dev-lang/fpc-source/metadata.xml8
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-lang/fpc-source/ChangeLog b/dev-lang/fpc-source/ChangeLog
new file mode 100644
index 000000000000..565cb792763a
--- /dev/null
+++ b/dev-lang/fpc-source/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/fpc-source
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-source/ChangeLog,v 1.1 2004/08/21 16:40:44 chriswhite Exp $
+
+*fpc-source-1.9.5_pre20040820 (22 Aug 2004)
+
+ 22 Aug 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +fpc-source-1.9.5_pre20040820.ebuild:
+ Initial package import. Adding myself as maintainer.
+
diff --git a/dev-lang/fpc-source/Manifest b/dev-lang/fpc-source/Manifest
new file mode 100644
index 000000000000..048c911afd9c
--- /dev/null
+++ b/dev-lang/fpc-source/Manifest
@@ -0,0 +1,4 @@
+MD5 f5f1522837a3398846f77d381fda47ec metadata.xml 226
+MD5 aba28f24a0e766e95af99ea2cd6b65a9 fpc-source-1.9.5_pre20040820.ebuild 1640
+MD5 fe2012a27686f9a0c433c9f30470fb09 ChangeLog 423
+MD5 3197b41dcf78a69bd6aba5c9f97a3cb7 files/digest-fpc-source-1.9.5_pre20040820 141
diff --git a/dev-lang/fpc-source/files/digest-fpc-source-1.9.5_pre20040820 b/dev-lang/fpc-source/files/digest-fpc-source-1.9.5_pre20040820
new file mode 100644
index 000000000000..e9d5b1297b2f
--- /dev/null
+++ b/dev-lang/fpc-source/files/digest-fpc-source-1.9.5_pre20040820
@@ -0,0 +1,2 @@
+MD5 007813d978515daaa37fdd9a97161879 fpc-source-1.9.5_pre20040820.tar.bz2 10538800
+MD5 724cf7311ff2c34fa8848f259815a8ef doc-html.zip 7249589
diff --git a/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild b/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild
new file mode 100644
index 000000000000..39b5712aa105
--- /dev/null
+++ b/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild,v 1.1 2004/08/21 16:40:44 chriswhite Exp $
+
+inherit eutils
+
+FPC_V="1.9.5"
+
+DESCRIPTION="Source build for the Free Pascal Compiler"
+HOMEPAGE="http://www.us.freepascal.org/fpc.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ doc? ( ftp://ftp.freepascal.org/pub/fpc/docs/doc-html.zip )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND=""
+S=${WORKDIR}/fpc-${FPC_V}
+
+src_compile() {
+ cd ${S}
+
+ einfo "Building the fpc compiler and units"
+ emake \
+ build \
+ OS_TARGET=linux \
+ PP=${S}/ppc386 \
+ PREFIX=${D}/usr \
+ || die "Free Pascal Compiler build process failed!"
+}
+
+src_install() {
+
+ einfo "Installing the fpc compiler and units"
+ emake \
+ install \
+ OS_TARGET=linux \
+ PP=${S}/ppc386 \
+ PREFIX=${D}/usr \
+ || die "Free Pascal Compiler install failed!"
+
+ if use doc
+ then
+ #install the html docs
+ einfo "Installing html docs"
+ mkdir ${D}/usr/share/doc/fpc-${FPC_V}/html
+ cp -r ${WORKDIR}/doc/* ${D}/usr/share/doc/fpc-${FPC_V}/html
+ fi
+}
+
+config() {
+ #Create our configuration file so fpc
+ #is easier to use
+ /usr/lib/fpc/${FPC_V}/samplecfg /usr/lib/fpc/${FPC_V} /etc
+
+ einfo "The configuration file for fpc has been placed in /etc/fpc.cfg"
+ einfo "Use this to customize your pascal compile flags"
+ einfo "More information on the fpc flags can be found in the fpc manpage"
+ echo
+ einfo "Examples and docs can be found in /usr/share/doc/fpc-${FPC_V}"
+ einfo "Upstream support can be found at: http://community.freepascal.org:10000/"
+}
diff --git a/dev-lang/fpc-source/metadata.xml b/dev-lang/fpc-source/metadata.xml
new file mode 100644
index 000000000000..b452dec7e591
--- /dev/null
+++ b/dev-lang/fpc-source/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>chriswhite@gentoo.org</email>
+</maintainer>
+</pkgmetadata>