summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-02-06 00:37:14 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-02-06 00:37:14 +0000
commitf76c9c75cf4f0e41057d59434e17a1b5d277be5b (patch)
treedfd18f4eb75089e6badbe8c6cce1575b23b79302 /dev-java
parentStable on alpha. (diff)
downloadhistorical-f76c9c75cf4f0e41057d59434e17a1b5d277be5b.tar.gz
historical-f76c9c75cf4f0e41057d59434e17a1b5d277be5b.tar.bz2
historical-f76c9c75cf4f0e41057d59434e17a1b5d277be5b.zip
Initial import.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/cdegroot-db/ChangeLog11
-rw-r--r--dev-java/cdegroot-db/Manifest6
-rw-r--r--dev-java/cdegroot-db/cdegroot-db-0.08.ebuild44
-rw-r--r--dev-java/cdegroot-db/files/build.xml59
-rw-r--r--dev-java/cdegroot-db/files/cdegroot-db-0.08-gentoo.patch205
-rw-r--r--dev-java/cdegroot-db/files/digest-cdegroot-db-0.081
-rw-r--r--dev-java/cdegroot-db/metadata.xml5
7 files changed, 331 insertions, 0 deletions
diff --git a/dev-java/cdegroot-db/ChangeLog b/dev-java/cdegroot-db/ChangeLog
new file mode 100644
index 000000000000..b933e769b368
--- /dev/null
+++ b/dev-java/cdegroot-db/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/cdegroot-db
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cdegroot-db/ChangeLog,v 1.1 2005/02/06 00:37:14 luckyduck Exp $
+
+*cdegroot-db-0.08 (06 Feb 2005)
+
+ 06 Feb 2005; Jan Brinkmann <luckyduck@gentoo.org> +metadata.xml,
+ +files/build.xml, +files/cdegroot-db-0.08-gentoo.patch,
+ +cdegroot-db-0.08.ebuild:
+ Initial import.
+
diff --git a/dev-java/cdegroot-db/Manifest b/dev-java/cdegroot-db/Manifest
new file mode 100644
index 000000000000..84896caf8fc4
--- /dev/null
+++ b/dev-java/cdegroot-db/Manifest
@@ -0,0 +1,6 @@
+MD5 954a9abd4e2f746ec9d7a5de844bf908 cdegroot-db-0.08.ebuild 1067
+MD5 c4750e531014d9324cb278aff47ad6da ChangeLog 421
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 0839e4d1aa7db825c3497cbf2f19792a files/cdegroot-db-0.08-gentoo.patch 7920
+MD5 f3cc57a67351b2ef9680cc84f976f0ac files/digest-cdegroot-db-0.08 72
+MD5 8a493b5dc089dc8afc56c353d5bb8fa7 files/build.xml 1612
diff --git a/dev-java/cdegroot-db/cdegroot-db-0.08.ebuild b/dev-java/cdegroot-db/cdegroot-db-0.08.ebuild
new file mode 100644
index 000000000000..2fa5915747a9
--- /dev/null
+++ b/dev-java/cdegroot-db/cdegroot-db-0.08.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cdegroot-db/cdegroot-db-0.08.ebuild,v 1.1 2005/02/06 00:37:14 luckyduck Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="OO database written in Java"
+HOMEPAGE="http://www.cdegroot.com/software/db/"
+SRC_URI="http://www.cdegroot.com/software/db/download/com.${P/-/.}.tar.gz"
+
+LICENSE="cdegroot"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jikes"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/com.${P/-/.}
+
+src_unpack() {
+ unpack ${A}
+ rm -rf ${S}/src/db/test
+
+ cd ${S}
+ cp ${FILESDIR}/build.xml ${S}/build.xml
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ local antflags="jar"
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ dodoc TODO VERSION CHANGES BUGS README
+ use doc && java-pkg_dohtml docs/*
+}
diff --git a/dev-java/cdegroot-db/files/build.xml b/dev-java/cdegroot-db/files/build.xml
new file mode 100644
index 000000000000..282ebdfc70e5
--- /dev/null
+++ b/dev-java/cdegroot-db/files/build.xml
@@ -0,0 +1,59 @@
+<?xml version="1.0"?>
+
+<project name="cdegroot-db" default="jar">
+ <!-- some properties -->
+ <property name="src.dir" value="src/db" />
+ <property name="build.dir" value="build" />
+ <property name="docs.dir" value="docs" />
+ <property name="dist.dir" value="dist" />
+ <property name="lib.dir" value="lib" />
+ <property name="jarfile" value="${dist.dir}/${ant.project.name}.jar" />
+ <property name="target.jdk" value="1.3" />
+
+ <!-- init -->
+ <target name="init">
+ <mkdir dir="${dist.dir}" />
+ <mkdir dir="${build.dir}" />
+ <mkdir dir="${docs.dir}" />
+ </target>
+
+ <!-- compile everything -->
+ <target name="compile" depends="init">
+ <mkdir dir="${build.dir}" />
+ <javac srcdir="${src.dir}"
+ destdir="${build.dir}"
+ source="${target.jdk}"
+ target="${target.jdk}"/>
+ </target>
+
+ <!-- build the jar file -->
+ <target name="jar" depends="compile">
+ <jar jarfile="${jarfile}" basedir="${build.dir}" />
+ </target>
+
+ <!-- generate javadocs -->
+ <target name="docs" depends="init">
+ <javadoc sourcepath="${src.dir}"
+ packagenames="com.*"
+ destdir="${docs.dir}"
+ author="true"
+ version="true"
+ use="true"
+ windowtitle="${ant.project.name} API" />
+ </target>
+
+ <!-- clean up -->
+ <target name="clean">
+ <delete dir="${build.dir}" />
+ <delete dir="${docs.dir}" />
+ <delete dir="${dist.dir}" />
+ </target>
+
+ <!-- zip the sources -->
+ <target name="sourcezip">
+ <zip destfile="${dist.dir}/${ant.project.name}-src.zip">
+ <zipfileset dir="${src.dir}" />
+ </zip>
+ </target>
+
+</project>
diff --git a/dev-java/cdegroot-db/files/cdegroot-db-0.08-gentoo.patch b/dev-java/cdegroot-db/files/cdegroot-db-0.08-gentoo.patch
new file mode 100644
index 000000000000..c150ff045858
--- /dev/null
+++ b/dev-java/cdegroot-db/files/cdegroot-db-0.08-gentoo.patch
@@ -0,0 +1,205 @@
+diff -urpN src.orig/db/com/cdegroot/db/hash/EntryPage.java src/db/com/cdegroot/db/hash/EntryPage.java
+--- src.orig/db/com/cdegroot/db/hash/EntryPage.java 2005-02-06 00:40:17.191151504 +0100
++++ src/db/com/cdegroot/db/hash/EntryPage.java 2005-02-06 00:54:14.045930240 +0100
+@@ -25,7 +25,7 @@ final class EntryPage extends PageHeader
+ /**
+ * Constructs a page view from the indicated block.
+ */
+- EntryPage(BlockIo block) {
++ public EntryPage(BlockIo block) {
+ super(block);
+ }
+
+@@ -33,7 +33,7 @@ final class EntryPage extends PageHeader
+ * Factory method to create or return a data page for the
+ * indicated block.
+ */
+- static EntryPage getEntryPageView(BlockIo block) {
++ public static EntryPage getEntryPageView(BlockIo block) {
+ BlockView view = block.getView();
+ if (view != null && view instanceof EntryPage)
+ return (EntryPage) view;
+diff -urpN src.orig/db/com/cdegroot/db/recman/BlockIo.java src/db/com/cdegroot/db/recman/BlockIo.java
+--- src.orig/db/com/cdegroot/db/recman/BlockIo.java 2005-02-06 00:40:17.192151352 +0100
++++ src/db/com/cdegroot/db/recman/BlockIo.java 2005-02-06 00:58:02.990125432 +0100
+@@ -31,7 +31,7 @@ package com.cdegroot.db.recman;
+ * @see java.io.DataInput
+ * @see java.io.DataOutput
+ */
+-final class BlockIo implements java.io.Serializable {
++final public class BlockIo implements java.io.Serializable {
+ private long blockId;
+ private final byte[] snapshot; // committed snapshot.
+ private boolean snapshotValid = false;
+@@ -44,7 +44,7 @@ final class BlockIo implements java.io.S
+ * Constructs a new BlockIo instance working on the indicated
+ * buffer.
+ */
+- BlockIo(long blockId, byte[] data) {
++ public BlockIo(long blockId, byte[] data) {
+ // removeme for production version
+ if (blockId > 10000000000L)
+ throw new Error("bogus block id " + blockId);
+@@ -108,7 +108,7 @@ final class BlockIo implements java.io.S
+ /**
+ * Returns the current view of the block.
+ */
+- BlockView getView() {
++ public BlockView getView() {
+ return view;
+ }
+
+@@ -172,17 +172,25 @@ final class BlockIo implements java.io.S
+ /**
+ * Reads a short from the indicated position
+ */
+- short readShort(int pos) {
++ public short readShort(int pos) {
+ return (short)
+ (((short) (data[pos+0] & 0xff) << 8) |
+ ((short) (data[pos+1] & 0xff) << 0));
+
+ }
++
++ public byte readByte(int pos) {
++ return data[pos];
++ }
++
++ public void writeByte(int pos, byte value)
++ { data[pos] = value;
++ }
+
+ /**
+ * Writes a short to the indicated position
+ */
+- void writeShort(int pos, short value) {
++ public void writeShort(int pos, short value) {
+ data[pos+0] = (byte)(0xff & (value >> 8));
+ data[pos+1] = (byte)(0xff & (value >> 0));
+ setDirty();
+@@ -191,7 +199,7 @@ final class BlockIo implements java.io.S
+ /**
+ * Reads an int from the indicated position
+ */
+- int readInt(int pos) {
++ public int readInt(int pos) {
+ return
+ (((int)(data[pos+0] & 0xff) << 24) |
+ ((int)(data[pos+1] & 0xff) << 16) |
+@@ -202,7 +210,7 @@ final class BlockIo implements java.io.S
+ /**
+ * Writes an int to the indicated position
+ */
+- void writeInt(int pos, int value) {
++ public void writeInt(int pos, int value) {
+ data[pos+0] = (byte)(0xff & (value >> 24));
+ data[pos+1] = (byte)(0xff & (value >> 16));
+ data[pos+2] = (byte)(0xff & (value >> 8));
+@@ -213,7 +221,7 @@ final class BlockIo implements java.io.S
+ /**
+ * Reads a long from the indicated position
+ */
+- long readLong(int pos) {
++ public long readLong(int pos) {
+ return
+ (((long)(data[pos+0] & 0xff) << 56) |
+ ((long)(data[pos+1] & 0xff) << 48) |
+@@ -228,7 +236,7 @@ final class BlockIo implements java.io.S
+ /**
+ * Writes a long to the indicated position
+ */
+- void writeLong(int pos, long value) {
++ public void writeLong(int pos, long value) {
+ data[pos+0] = (byte)(0xff & (value >> 56));
+ data[pos+1] = (byte)(0xff & (value >> 48));
+ data[pos+2] = (byte)(0xff & (value >> 40));
+diff -urpN src.orig/db/com/cdegroot/db/recman/BlockView.java src/db/com/cdegroot/db/recman/BlockView.java
+--- src.orig/db/com/cdegroot/db/recman/BlockView.java 2005-02-06 00:40:17.193151200 +0100
++++ src/db/com/cdegroot/db/recman/BlockView.java 2005-02-06 00:47:57.632153832 +0100
+@@ -28,5 +28,5 @@ package com.cdegroot.db.recman;
+ *
+ * @see BlockIo.setView()
+ */
+-interface BlockView {
++public interface BlockView {
+ }
+diff -urpN src.orig/db/com/cdegroot/db/recman/Magic.java src/db/com/cdegroot/db/recman/Magic.java
+--- src.orig/db/com/cdegroot/db/recman/Magic.java 2005-02-06 00:40:17.193151200 +0100
++++ src/db/com/cdegroot/db/recman/Magic.java 2005-02-06 00:44:22.164909832 +0100
+@@ -25,7 +25,7 @@ package com.cdegroot.db.recman;
+ /**
+ * This interface contains magic cookies.
+ */
+-interface Magic {
++public interface Magic {
+ /** Magic cookie at start of file */
+ short FILE_HEADER = 0x1350;
+
+@@ -57,4 +57,6 @@ interface Magic {
+ int SZ_INT = 4;
+ /** Size of an externalized long */
+ int SZ_LONG = 8;
++ /** Size of byte */
++ int SZ_BYTE = 1;
+ }
+diff -urpN src.orig/db/com/cdegroot/db/recman/PageHeader.java src/db/com/cdegroot/db/recman/PageHeader.java
+--- src.orig/db/com/cdegroot/db/recman/PageHeader.java 2005-02-06 00:40:17.193151200 +0100
++++ src/db/com/cdegroot/db/recman/PageHeader.java 2005-02-06 00:50:10.236994832 +0100
+@@ -28,15 +28,15 @@ import java.io.*;
+ * This class represents a page header. It is the common superclass for
+ * all different page views.
+ */
+-class PageHeader implements BlockView {
++public class PageHeader implements BlockView {
+ // offsets
+ private static final short O_MAGIC = 0; // short magic
+ private static final short O_NEXT = Magic.SZ_SHORT; // long next
+ private static final short O_PREV = O_NEXT + Magic.SZ_LONG; // long prev
+- static final int SIZE = O_PREV + Magic.SZ_LONG;
++ public static final int SIZE = O_PREV + Magic.SZ_LONG;
+
+ // my block
+- BlockIo block;
++ public BlockIo block;
+
+ /**
+ * Constructs a PageHeader object from a block
+@@ -45,7 +45,7 @@ class PageHeader implements BlockView {
+ * @throws IOException if the block is too short to keep the file
+ * header.
+ */
+- PageHeader(BlockIo block) {
++ public PageHeader(BlockIo block) {
+ initialize(block);
+ if (!magicOk())
+ throw new Error("CRITICAL: page header magic for block "
+@@ -66,7 +66,7 @@ class PageHeader implements BlockView {
+ * Factory method to create or return a page header for the
+ * indicated block.
+ */
+- static PageHeader getView(BlockIo block) {
++ public static PageHeader getView(BlockIo block) {
+ BlockView view = block.getView();
+ if (view != null && view instanceof PageHeader)
+ return (PageHeader) view;
+diff -urpN src.orig/db/com/cdegroot/db/recman/RecordFile.java src/db/com/cdegroot/db/recman/RecordFile.java
+--- src.orig/db/com/cdegroot/db/recman/RecordFile.java 2005-02-06 00:40:17.193151200 +0100
++++ src/db/com/cdegroot/db/recman/RecordFile.java 2005-02-06 00:45:38.616287456 +0100
+@@ -33,7 +33,7 @@ import java.util.*;
+ * The set of dirty records on the in-use list constitutes a transaction.
+ * Later on, we will send these records to some recovery thingy.
+ */
+-final class RecordFile {
++final public class RecordFile {
+ private final TransactionManager txnMgr;
+
+ // Todo: reorganize in hashes and fifos as necessary.
+@@ -48,7 +48,7 @@ final class RecordFile {
+ private boolean transactionsDisabled = false;
+
+ /** The length of a single block. */
+- final static int BLOCK_SIZE = 8192;//4096;
++ final public static int BLOCK_SIZE = 8192;//4096;
+
+ /** The extension of a record file */
+ final static String extension = ".db";
diff --git a/dev-java/cdegroot-db/files/digest-cdegroot-db-0.08 b/dev-java/cdegroot-db/files/digest-cdegroot-db-0.08
new file mode 100644
index 000000000000..d3f78c446dc7
--- /dev/null
+++ b/dev-java/cdegroot-db/files/digest-cdegroot-db-0.08
@@ -0,0 +1 @@
+MD5 a122bd83105cc59222b5c2135fa0c005 com.cdegroot.db-0.08.tar.gz 154705
diff --git a/dev-java/cdegroot-db/metadata.xml b/dev-java/cdegroot-db/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/cdegroot-db/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>