summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:38:08 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:38:08 +0000
commite003a5d24987065c48edbfa67cf4ba72701060bd (patch)
tree650e4d3b2e771e1d14096f95caa4238c868a060b /dev-java
parentFixes #8529. (diff)
downloadhistorical-e003a5d24987065c48edbfa67cf4ba72701060bd.tar.gz
historical-e003a5d24987065c48edbfa67cf4ba72701060bd.tar.bz2
historical-e003a5d24987065c48edbfa67cf4ba72701060bd.zip
Fixes #8530.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-collections/ChangeLog10
-rw-r--r--dev-java/commons-collections/commons-collections-2.0.ebuild33
-rw-r--r--dev-java/commons-collections/files/digest-commons-collections-2.01
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
new file mode 100644
index 000000000000..a5044985c2b1
--- /dev/null
+++ b/dev-java/commons-collections/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/commons-collections
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.1 2002/10/31 20:38:08 karltk Exp $
+
+*commons-collections-2.0 (31 Oct 2002)
+
+ 31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> commons-collections-2.0.ebuild files/digest-commons-collections-2.0 :
+ Initial import. Ebuild submitted by Adrian Almenar
+ <aalmenar@conectium.com>.
+
diff --git a/dev-java/commons-collections/commons-collections-2.0.ebuild b/dev-java/commons-collections/commons-collections-2.0.ebuild
new file mode 100644
index 000000000000..72974db6befe
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.0.ebuild,v 1.1 2002/10/31 20:38:08 karltk Exp $
+
+S=${WORKDIR}/commons-collections-${PV}-src
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/commons-collections/v${PV}/commons-collections-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+IUSE=""
+
+src_compile() {
+ ant dist-jar || die "Compilation Failed"
+ ant doc || die "Unable to create documents"
+}
+
+src_install () {
+ dojar dist/commons-collections*.jar || die "Unable to Install"
+ dodir /usr/share/doc/${P}
+ dohtml dist/*.html
+ dohtml -r dist/docs/*
+}
+
+pkg_postinst() {
+ einfo "********** Documentation can be found at *********\n
+ http://jakarta.apache.org/commons/beanutils.html\n
+ **************************************************"
+}
diff --git a/dev-java/commons-collections/files/digest-commons-collections-2.0 b/dev-java/commons-collections/files/digest-commons-collections-2.0
new file mode 100644
index 000000000000..f21c4c2cbc3c
--- /dev/null
+++ b/dev-java/commons-collections/files/digest-commons-collections-2.0
@@ -0,0 +1 @@
+MD5 c7cc95130838336ec5ffe14ea5fcb661 commons-collections-2.0-src.tar.gz 139562